Jump to content

jyt

Members
  • Content count

    36
  • Joined

  • Last visited

1 Follower

Profile Information

  1. looking at your suggestion, it wouldn't work since this isn't also increment the product table, but by adding this also you do increment both, the only problem is the module doesn't recognize the incrementation properly and jump an extra product_ID, which mean it doesn't see the first product_ID, it's there but can be pick by the domain_search.php, it need extra coding here. tep_db_query("insert into " . TABLE_PRODUCTS . " values ('', '1', '" . $type . "', '', '" . $price ."', '', '0', '1', '1', '1', '', '" . $newcount ."', '')"); tep_db_query("insert into " . TABLE_PRODUCTS . " values ('', '1', '" . $type . "', '', '" . $price ."', '', '0', '1', '1', '1', '', '" . $newcount ."', '')"); tep_db_query("insert into " . TABLE_PRODUCTS_DESCRIPTION . " values ('', '1', '". $what ."', '" . $type . "', '', '')"); tep_db_query("insert into " . TABLE_PRODUCTS_DESCRIPTION . " values ('', '4', '". $what ."', '" . $type . "', '', '')"); in regard of your bug (fcolse() error ), not certain why it is happening to you perhaps you are using a more recent version of osC then mine.
  2. try to figure it out, here what i found in the domain_search.php file: tep_db_query("insert into " . TABLE_PRODUCTS_DESCRIPTION . " values ('', '1', '". $what ."', '" . $type . "', '', '')"); if you replace the value 1 for an other language id like for me it's 4 for french then it does work in french, but french only, how can i set this to change depending of the language? that's the next step, anybody knows how to, I'm not to familiar with php coding but should be simple. -jy
  3. Finally working again on my site, it has been a while since I had the time to work at it, been too busy. Mais oui Pica, moi aussi je veut offrir le service en francais, mais il y a un gros probleme avec la basse de donne, i will have to look at it closely, in the mean time I had no problem setting the .ca registrar in my site, but one again only in english, hopefully soon someone will find a way to add multi-language to this great contributions, all for the best for OS users and developper for .ca add the following to the domain_search.php $caserver = "whois.cira.ca"; $canomatch = "AVAIL"; //$cainclude = true; // not needed ----- case ca: $price="18.95"; break; ----- <OPTION VALUE=ca> .CA ----- // .ca if($type == "ca") { $caarray = array($domain.".ca"); $cacount = count($caarray); $i=0; for ($i=0;$i<$cacount;$i++) { $domname = $caarray[$i]; $query = $domname."@".$caserver; $result = ""; $ns = fsockopen($caserver,43); fputs($ns,"$domnamern"); while(!feof($ns)) $result .= fgets($ns,128); fclose($ns); if (eregi($canomatch,$result)) { dispav($domname); } else { dispun($domname,$caserver); } } echo "<tr><td colspan=5 bgcolor=$sepcolor><font face=$fontface size=$fontsize> </td></tr>"; } ---- that's it, as simple as the other one
  4. one more thing, Eliot's fixes work great.
  5. it does work fine for me i run 2.2, the only thing i find it the total vote result does not show properly in multi-language, so if you have 3 vote in french and 4 vote in english, it show the right total of 7 but in each language it show only the vote related to that language, i mean has the graphics result, it's very strange, is it supposed to be that way? also yes the comment out still doesn't work, I just install it today, so this info is real fresh, but overall it's pretty good stuff, thanks
  6. hi, cralyn , very nice work here. wondering if it is possible to have your developement site as a zip, i have small problem trying to figure out the inital instruction, the readme file is badly done, it does not tell you which part to replace, just...around line 115 you will notice the changes... which isn't easy if you're not totally an expert in php. anyway i'm also interested in building a none computer related site which will need the same principle which is to build a product, like building clothes, like t-shirt, pick the type of shirt, arm, neck, etc, then make it and add it into the shopping cart. anyway, thanks
  7. jyt

    ePDQ payment module v1

    ok new year, can someone help me with this ePDQ module
  8. jyt

    ePDQ payment module v1

    so if i understand you are saying that this below: modify the form action in the ePDQ include file to hit a jump page which echoes the HTTP_POST_VARS. e.g. 'epdqdata=' . $HTTP_POST_VARS['epdqdata'] and submit the form onLoad (onLoad="document.forms[0].submit() ) have something to do with curl, ok is there a way around that. how much would you charge to debug the whole thing, we've been told by ePDQ that if we can get the account up and running they will cancel our account, which mean we have to get this up somehow, so basicaly at this point i'm looking for someone to debug this thing, please let me know ASAP
  9. jyt

    ePDQ payment module v1

    finally i have it to work, except that now i need to modify the form action in the ePDQ include file to hit a jump page which echoes the HTTP_POST_VARS. e.g. 'epdqdata=' . $HTTP_POST_VARS['epdqdata'] and submit the form onLoad (onLoad="document.forms[0].submit() ) but i'm totally lost on how to build this, the problem is that ePDQ doesn't like catalog/checkout_confirmation.php?osCsid=76661342308b45d8a9920b056587e6ba which is the url that send to ePDQ
  10. jyt

    ePDQ payment module v1

    here the error that i have right now, anybody can help!!! this is at 'confim order' step Error: Charge Total "0" is invalid. Only numerics are expected in xxxxxx.xx format
  11. jyt

    ePDQ payment module v1

    curl is needed, that's for sure, but would it be possible to bypass the use of curl, since all the other module do not use it, or do they? and if so how can I modified the module?
  12. jyt

    ePDQ payment module v1

    did anyone got it to work on v.2.2 , I'm trying but can't. my version is tep_snapshot-20021120.tar.gz the osC does not see the module!
  13. jyt

    ePDQ payment module v1

    I'm trying to install ePDQ module, everything seem to be fine but when I submit an order, it say Payment Method ePDQ, but then nothing reach ePDQ, it all goes no where actually I'm not reach them after I click on confirm order, it reply"Your Order Has Been Processed!" I look at the admin and I see the order still saying Payment Method ePDQ. if something is set wrong I should at least get an error from ePDQ when i submit the order....help! anybody knows what I'm missing sorry for my frenglish!
×