Latest News: (loading..)

bhbilbao

Members
  • Content count

    308
  • Joined

  • Last visited

  • Days Won

    1

bhbilbao last won the day on January 7 2010

bhbilbao had the most liked content!

6 Followers

About bhbilbao

  • Birthday 01/21/1976

Profile Information

  • Real Name
    BLACKHOLE
  • Gender
    Male
  • Location
    Spain
  • Interests
    OSC
  1. 8. Try converting the file codification to UTF-8 without BOM.
  2. above that option there is a mode to change the path rewrite. Try changing the mode.
  3. 7.Could be a problem with the database engine. I dont know about portugues. Look in languages/portugues.php define('CHARSET', 'iso-8859-1'); Some new versions of osc uses UTF-8 Compare it with the database engine & collation. Good luck.
  4. 1.the files must be in \includes\modules\ultimate_seo_urls5\includes\character_conversion 2. make 1 file per language 3. your file seems to be the spanish version. Rename it as espanol.php 4. if you installed for example 3 languages in your osc, delete the other ones folders. = 1 folder per languaje(default espanol, english, german) 5. It seems to be right but try with this one: <?php // Spanish $char_convert = array('á' => 'a', 'é' => 'e', 'í' => 'i', 'ñ' => 'n', 'ã' => 'a', 'á' => 'a', 'ó' => 'o', 'ú' => 'u', 'ü' => 'u', 'Á' => 'A', 'É' => 'E', 'Í' => 'I', 'Ñ' => 'N', 'Ó' => 'O', 'Ú' => 'U', 'Ü' => 'U', '¿' => '-', '¡' => '-'); ?> 6. this is the code that gets the error: $final_text_array = array(); foreach ( $text_array as $key => $text ) { if ( tep_not_null( trim( $text ) ) ) { $final_text_array[$key] = $text; } } // We will cache this result Usu_Main::i()->getVar( 'registry' )->attach( $this->key, $this->keys_index[$this->key], $final_text_array ); return $final_text_array; } Could be that you have some products without any products_name asigned (empty or null). Try to write some name description for all languages. Then RESET cache.
  5. probably your conversion file is bad. Problem with some coma `` or ,
  6. Hi again Robert, some weeks ago I made you a question about USU5. I need help for a new open source project im working on. Thanks in advance.
  7. Open your eyes. There is an option down in USU admin panel. FORCE www.mysite.com/en/ when www.mysite.com/index.php/en
  8. 1)install languages 2)activate Enable multi language support? true then: www.your web .com (default) www.your web .com/de/... www.your web .com/es/... ...etc
  9. Choose the uri format path_rewrite Choose how your product link text is made up cp Hi again Robert, for products (product_info,php) works fine with path_rewrite + cp. But for articles doesnt add the category because they are topics ( xxx-t-3.html). Is there a way in the articles contribution to add the topic before?? I want this: http:// myweb .com/news/this-is-an-article-a-17.html http:// myweb .com/articles/this-is-an-article-a-18.html http:// myweb .com/reviews/this-is-an-article-a-19.html In other way for future releases of your addon it could be interesting to add the category path only for some categories products (selectable). Thanks in advance.
  10. Hi Robert Fisher, i need sugestion for this. Using the article_info.php contibution the urls goes right. For example: http:// myweb .com/this-is-an-article-a-17.html but i need to add a word(not category or topic) between as: http:// myweb .com/articles/this-is-an-article-a-17.html How can I get this?? 1) In .htaccess # Articles contribution RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA] 2) In your addon. where to add the "articles/" word??? Thanks in advance.
  11. @@RobC1962 try these solutions: 1) remove from general.php and includes it in each archive manually: require('includes/application_top.php'); require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_ARTICLE_INFO); include(DIR_WS_FUNCTIONS . '/refund_functions.php'); 2)put the doctype at begining of archive. before the includes <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"> <?php require('includes/application_top.php'); require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_ARTICLE_INFO); include(DIR_WS_FUNCTIONS . '/refund_functions.php'); or 3)refund_functions.php at the begining change <? to <?php
  12. See the problem: <?php // Start - CREDIT CLASS Gift Voucher Contribution echo $order_total_modules->credit_selection(); // End - CREDIT CLASS Gift Voucher Contribution ?> That code must be inserted after echo $order_total_modules->sub_credit_selection(); pasting before doesnt work.
  13. Hi all, i continue with the same problem described here: http://forums.oscomm...ost__p__1509926 checkout_payment.php <?php // Start - CREDIT CLASS Gift Voucher Contribution echo $order_total_modules->credit_selection(); // End - CREDIT CLASS Gift Voucher Contribution ?> In /includes/modules/order_total/ot_gv.php $image_submit = '<input type="image" name="submit_redeem" onClick="submitFunction()" src="' . DIR_WS_LANGUAGES . $language . '/images/buttons/button_redeem.gif" border="0" alt="' . IMAGE_REDEEM_VOUCHER . '" title = "' . IMAGE_REDEEM_VOUCHER . '">'; In /includes/modules/order_total/ot_couponphp $selection_string .= TEXT_ENTER_GV_CODE . tep_draw_input_field('gv_redeem_code', 'redeem code') ; $selection_string .= ' '; $selection_string .= tep_image_submit('button_redeem.gif', IMAGE_REDEEM_VOUCHER, 'onclick="return submitFunction()"'); I insert the code GIFT20 on the box, but clicking button_redeem.gif nothing happens!!!! Cannot redeem! I dont know how to fix it.
  14. For other people asked. There is no need to use with CCGV contrib. They are diferent contribs(but they works in same manner). The CCGV has additional advantages but its hard to install. CCGV tables: # # Table structure for table 'coupon_email_track' # # # Table structure for table 'coupon_gv_customer' # # # Table structure for table 'coupon_gv_queue' # # # Table structure for table 'coupon_redeem_track' # # # Table structure for table 'coupons' # # # Table structure for table 'coupons_description' # Account balance tables: CREATE TABLE customers_balance_history I will try to modify them and only use 1 table for them, in this case coupon_gv_customer amount=customers_account_balance
  15. Rosemaryann, same problem here(the same problem as CCGV contrib). Im thinking to notify to customer when this happens. For other people with problems, try deleting: ot_account_balance_org.php use only ot_account_balance.php and activate it on modules with the highest order number. In my case there is problems in the instalation instructions: First: In file catalog\admin\orders.php Find: case 'deleteconfirm': $oID = tep_db_prepare_input($HTTP_GET_VARS['oID']); tep_remove_order($oID, $HTTP_POST_VARS['restock']); tep_redirect(tep_href_link(FILENAME_ORDERS, tep_get_all_get_params(array('oID', 'action')))); break; REPLACE with: // Account Balance Modif case 'deleteconfirm': $oID = tep_db_prepare_input($HTTP_GET_VARS['oID']); tep_remove_order($oID, $HTTP_POST_VARS['restock']); tep_add_customer_balance($oID, $HTTP_POST_VARS['account_balance'], $cID); tep_redirect(tep_href_link(FILENAME_ORDERS, tep_get_all_get_params(array('oID', 'action')))); break; // End Account Balance Modif then: In file catalog\admin\orders.php Find: if ($order_updated == true) { $messageStack->add_session(SUCCESS_ORDER_UPDATED, 'success'); } else { $messageStack->add_session(WARNING_ORDER_NOT_UPDATED, 'warning'); } tep_redirect(tep_href_link(FILENAME_ORDERS, tep_get_all_get_params(array('action')) . 'action=edit')); break; Add after: // Account Balance Modif case 'deleteconfirm': $oID = tep_db_prepare_input($HTTP_GET_VARS['oID']); $ab = tep_db_prepare_input($HTTP_POST_VARS['account_balance']); if ($ab == true) { ... bla bla bla case deleteconfirm appears twice, 2 times!! In the original code the first part is deleted. In other case I think there is need to place some code in checkout_confirmation.php In estimate_shipping is right, and the email order confirmation also right. But checkout_confirmation bad. Also, with admin/order_edit.php needs to modify, all quantities to 0€. Other issue is on customers_balance_history.php Adding credit from customers_edit page works fine, it adds a line to customers_balance_history table. The problem here is after finishing the order, when a customer checks out, the account balance is reduced right but it doesnt add any line to customers_balance_history table (suposed a new line with Order #)