Jump to content

Eirik

Members
  • Content count

    64
  • Joined

  • Last visited

Posts posted by Eirik


  1. On the front page of my shop, click "Better Together" then scroll down to "See it live." What I've done is documented there.

     

     

    Thanks Scott, I read through that before but didn't catch that the example about the marketing was how it alerted customers to the available discount. Going to have a long look at it this weekend, thanks so much for the speedy reply earlier.

     

    Eirik.


  2. I've been using http://addons.oscommerce.com/info/5527 for my online gift cards and everything works great except I have just noticed that it does not remove the shipping tax from the cards balance. I have tested this multiple times with different shipping options and every time the order is processed, and in the admin panel the order is correct tax and all but when it subtracts the used amount from the gift card balance it somehow drops the sales tax from the shipping. Yes shipping is set as a taxable good, and yes it does calculate the final order with the shipping tax included, the only place that it drops the tax is when it alters the gift card balance in the database.

     

    If anyone has any ideas of suggestions where this error is occurring I would love to hear them.

     

    Thank you in advance for your time and consideration.

    Eirik

     

     

    Just figured I would post this in case someone sometime has a similar issue, perhaps this will help them out.

     

    I pretty much scraped the gift certificate addon and made my own, it had a host of problems that just in the end made it very undesirable. However to the meat of the matter. there is a line in the checkout_process.php

    $order_totals = $order_total_modules->process();

    So any payment/credit type edits/addons should be inserted after that point otherwise all the tax computations are not complete yet.

     

    Anyway I hope this helps someone. Just a final thought, I found it handy to be able to see what variables were actually being passed as. What I ended up doing was using the redirect link at the end of the checkout_process.php to pass the variables via the url to checkout_success.php.

     

    The line you are looking for is

    tep_redirect(tep_href_link(FILENAME_CHECKOUT_SUCCESS, '', 'SSL'));

     

    and you can pass variables like this

     

    tep_redirect(tep_href_link(FILENAME_CHECKOUT_SUCCESS, 'ordertotal='.$order->info['total'].'&regulartax='.$order->info['tax'], 'SSL'));


  3. I've been using http://addons.oscommerce.com/info/5527 for my online gift cards and everything works great except I have just noticed that it does not remove the shipping tax from the cards balance. I have tested this multiple times with different shipping options and every time the order is processed, and in the admin panel the order is correct tax and all but when it subtracts the used amount from the gift card balance it somehow drops the sales tax from the shipping. Yes shipping is set as a taxable good, and yes it does calculate the final order with the shipping tax included, the only place that it drops the tax is when it alters the gift card balance in the database.

     

    If anyone has any ideas of suggestions where this error is occurring I would love to hear them.

     

    Thank you in advance for your time and consideration.

    Eirik


  4. // BOF Anti Robotic Registration v3.1
    if (ACCOUNT_VALIDATION == 'true' ) {
     include(DIR_WS_MODULES . FILENAME_CHECK_VALIDATION);
      if ($entry_antirobotreg_error == true) $messageStack->add('contact', $text_antirobotreg_error);
    }
    // EOF Anti Robotic Registration v3.1

     

     

     

    Just something I noticed when I was installing this on my gift card redemption, it should be

     

     

    // BOF Anti Robotic Registration v3.1
    if (ACCOUNT_VALIDATION == 'true' ) {
     include(DIR_WS_MODULES . FILENAME_CHECK_VALIDATION);
      if ($entry_antirobotreg_error == true) $messageStack->add('contact', $text_antirobotreg_error);
    }
    
       if (!$entry_antirobotreg_error) {
    // EOF Anti Robotic Registration v3.1

     

    then close the bracket once you run your form processes.


  5. So I've been looking over this code and searched this forum and I'm trying to reduce the size of the indent when show products in a category is on.

     

    $spacer_string = '',
    $spacer_multiplier = 1;

     

    I tried playing with those settings as mentioned in another response on this thread for increasing the indent but even there I couldn't alter the look. Any help would be much appreciated.

     

    Thank you much for your time and consideration.


  6. you are missing the period . after </a><br>'

     

    the code should be

     

    '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a><br>'.
    							   '<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_DISCOUNT_COUPONS . '</a>' );


  7. Hi again Jack!

     

    A thread with over 136 pages is very hard to search (especially for us who dont speak your language that well) , is there a way for you to make a new thread with maybe a faq? I think that would help many of us newbies :P And save you time, not needing to answer the same question again and again..

     

    To get back to my problem, i dont know if i made my self clear, i mean that before i installed your contrib i could use TinyMce for my productdescription, and now after installing your contrib i can only use that in the meta product description and not in the old regular product description area... I even upoaded the included admin/configure.php file but there was no difference.

     

    And the Path Standard text over my header in product page is shown as well even with your admin/categories.php

     

    Solan

     

    Solan I don't personally use tinymce but I looked at the code that is included with the header tags contribution and it calls for the insertion of this

     

    <?php // START tinyMCE Anywhere
    if (HEADER_TAGS_ENABLE_TINYMCE_META_DESC == 'true' || HEADER_TAGS_ENABLE_TINYMCE_CATEGORIES == 'true' || HEADER_TAGS_ENABLE_TINYMCE_PRODUCTS == 'true')
    {  
     if ($action == 'new_product' || $action == 'new_category' || $action == 'edit_category') { // No need to put JS on all pages.
       $languages = tep_get_languages(); // Get all languages
     // Build list of textareas to convert
       $str = '';
       for ($i = 0, $n = sizeof($languages); $i < $n; $i++) {
         if (HEADER_TAGS_ENABLE_TINYMCE_META_DESC  == 'true') $str .= "products_head_desc_tag[".$languages[$i]['id']."],";
         if (HEADER_TAGS_ENABLE_TINYMCE_CATEGORIES == 'true') $str .= "categories_htc_description[".$languages[$i]['id']."],";
         if (HEADER_TAGS_ENABLE_TINYMCE_PRODUCTS == 'true') $str .= "products_head_description[".$languages[$i]['id']."],";
       }  //end for each language
       $mce_str = rtrim ($str,","); // Removed the last comma from the string.
     // You can add more textareas to convert in the $str, be careful that they are all separated by a comma.
       echo '<script language="javascript" type="text/javascript" src="includes/javascript/tiny_mce/tiny_mce.js"></script>';
       include "includes/javascript/tiny_mce/general.php";
     } 
    } // END tinyMCE Anywhere
    ?>

     

    and I think it should be

     

    <?php // START tinyMCE Anywhere
    if (HEADER_TAGS_ENABLE_TINYMCE_META_DESC == 'true' || HEADER_TAGS_ENABLE_TINYMCE_CATEGORIES == 'true' || HEADER_TAGS_ENABLE_TINYMCE_PRODUCTS == 'true')
    {  
     if ($action == 'new_product' || $action == 'new_category' || $action == 'edit_category') { // No need to put JS on all pages.
       $languages = tep_get_languages(); // Get all languages
     // Build list of textareas to convert
       $str = '';
       for ($i = 0, $n = sizeof($languages); $i < $n; $i++) {
         $str.="products_description[".$languages[$i]['id']."],";
         if (HEADER_TAGS_ENABLE_TINYMCE_META_DESC  == 'true') $str .= "products_head_desc_tag[".$languages[$i]['id']."],";
         if (HEADER_TAGS_ENABLE_TINYMCE_CATEGORIES == 'true') $str .= "categories_htc_description[".$languages[$i]['id']."],";
         if (HEADER_TAGS_ENABLE_TINYMCE_PRODUCTS == 'true') $str .= "products_head_description[".$languages[$i]['id']."],";
       }  //end for each language
       $mce_str = rtrim ($str,","); // Removed the last comma from the string.
     // You can add more textareas to convert in the $str, be careful that they are all separated by a comma.
       echo '<script language="javascript" type="text/javascript" src="includes/javascript/tiny_mce/tiny_mce.js"></script>';
       include "includes/javascript/tiny_mce/general.php";
     } 
    } // END tinyMCE Anywhere
    ?>

     

     

    But I have to be honest I have no idea why you would ever want to use a wysiwyg on header tags and titles. Anyway like I said I don't use this myself but I would give that a try.. maybe put you on the right path at least.


  8. I know this post was from ages ago but does anyone happen to know what this "patch" that Mike is referring to to is or know of another thread where I can find the answer?

     

    Thank you in advance for your time and consideration.

     

     

    Just a follow up for anyone else having this same problem. The problem was caused by Ultimate SEO attempting to validate to W3C standard so just turning this option off in the SEO section of the admin configuration panel fixed the issue.


  9. The problem was when you use this cntribution with ultimate SEO you need to patch seo.class.php to correctly redirect.

     

    Thank you

     

    Mike

     

     

    I know this post was from ages ago but does anyone happen to know what this "patch" that Mike is referring to to is or know of another thread where I can find the answer?

     

    Thank you in advance for your time and consideration.


  10. So I have gone through and reinstalled Ultimate SEO three times, I tried with 2.1d original and with 2.7 and the same problem occurs whenever a error is (credit card is invalid etc) detected in checkout you lose your osCid. I thought about forcing cookies but I would rather not have to take that step. Is there a way for Ultimate SEO to not apply itself during the checkout stage?


  11. So I have have come up against a issue and while I'm still searching I figured I would post here as well. I have installed 2.1d updated and not any time an error happens within the checkout process the user is dumped back to the login page and the shopping cart is emptied, so pretty much loses the osCid. If anyone has found a resolution to this issue I would be greatly appreciative.

     

    Thank you in advance for your time and consideration.


  12. I've been looking at editing in an additional exclusion, or rather and inclusion. I want to setup someway to encourage customers who haven't purchased in awhile into making another purchase. The way I have it envisioned is issuing discounts like normal but I want to target specific accounts, now the exclude accounts does almost exactly that however any new accounts get added into the allowed accounts which is no good because the discounts are one use only and a customer could theoretically just create new accounts to reuse the discount. these are going to be pretty heavy discounts so I need to lock in specific users and no one else.

     

    If anyone has done anything like this I would love to hear how you approached it. I have looked at other gift voucher contributions but I really would like to stay within the frame work of this contribution because it is solid and works well with my accounting system.


  13. Hi great mod but when i went to uninstall this is has now messed up the moduls page in admin Order Total

     

    MODULE_ORDER_TOTAL_DISCOUNT_COUPON_TITLE

     

    is this there i reuploaded my orig file but its still there i get error

     

    Warning: include/includes/languages/english/modules/order_total/ot_discount_coupon.php) [function.include]: failed to open stream: No such file or directory in admin/modules.php on line 128

     

    Warning: include() [function.include]: Failed opening /includes/languages/english/modules/order_total/ot_discount_coupon.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/usr/local/lib/php/Zend:/usr/local/src/ZendFramework-1.0.3/library') in /home/thedat24/public_html/admin/modules.php on line 128

     

    at the top how can i get rid of all this please ?

     

    Thank you

     

    I believe you forgot to upload your language file :)

     

    make sure you put it inside the language/modules and not just modules


  14. The positioning will vary with different fonts, I use 5 as patrick has detailed

     

    I quite like the way the characters are sometimes just off, its rare that its difficult to distinguish.

     

    The character set is done in the function in account_validation.php

     

    find:

     

    $chars = array('a','b','c','d','e','f','g','h','j','k','l','m','n','p','q','r','s','t','u','v','w','x','y','z', '1', '2', '3', '4', '5', '6', '7', '8', '9', ' @ ', '#', '?', '+', '=');

    and set as you wish

    I must have missed this the first time through, Sam you rock.. such a wealth of knowledge.

     

    Also for anyone else who is wondering about the links_submit it appears to be part of some other contribution, please correct me if I'm wrong.


  15. Something came up and I'm hoping there is someone who knows how I can fix this, I've looked back over the 30 some pages of posts for this contribution and can't find the answer. The contribution uses symbols( @ + ) as well as alpha numeric which I would wager from a security stand point is good, but from a maximizing customer stand point it isn't so hot. So what I am trying to accomplish is limit the characters that are used for generating the sequence to just alpha numeric 0-9 a-z .

     

    Thanks all in advance for any insights you may have.

×