Jump to content

alexsimon23

Members
  • Content count

    8
  • Joined

  • Last visited

Profile Information

  • Real Name
    Alex
  • Gender
    Male
  • Location
    Los Angeles, CA
  • Website
  1. Looking at the source code of a first-time attempt and a second-time attempt (remember, it always works the second time but not the first) has revealed that the correct checkout_confirmation form is created both times, and the form_action_url is also correct both times. Clicking "Confirm & Pay" always takes me to the proper form_action_url, but a first attempt creates a form and (inexplicably) does not send it to authorize.net. A second attempt goes to the proper form_action_url, creates a form, and does send it to authorize.net. Every time. I'm stumped. :blink: Cheers, Alex
  2. I'm running into the same "Error 13" problem with my authorize.net module as well on my page, www.hollywoodbreastforms.com (it's a lingerie site, so be careful if you're looking at it at work or something). Here's the weird thing though: I receive the error when I click "confirm & pay". But then I hit back on my browser, click "confirm & pay" again, and it goes to the proper transact.dll page where I input CC info! Why would it not work one time, but work the second time? Also, if I get to the checkout_confirmation.php page the first time and hit refresh in my browser, it will go to the proper transact.dll page without showing the Error 13. I've used the fix posted above and both lines 37 and 41 point to 'https://secure.authorize.net/gateway/transact.dll'. I talked to support at authorize.net and they told me to use the data validation URL (http://developer.authorize.net/tools/datavalidation/) to see what info was coming through. I did this and the first "confirm & pay" showed nothing, hit back in the browser and "confirm" again, and I received all the validation info correctly. Anyone know why my site won't connect to the authorize.net SIM secure checkout page upon first try, but does upon second try? Cheers, Alex
  3. I'm currently using Show All Products in Category & Subcategories V2.0 (http://addons.oscommerce.com/info/5351) to list my products. This allows me to show all the products in several subcategories on the same page (technically all the subcategories in a subcategory of a main category). What I'm trying to do now is have a heading image for each sub-subcategory mixed in with the list of products. As an example: Subcategory Page Sub-subcategory 1 Image Sub-subcategory Product 1 Sub-subcategory Product 2 Sub-subcategory Product 3 Sub-subcategory 2 Image Sub-subcategory Product 1 Sub-subcategory Product 2 Sub-subcategory 3 Image Sub-subcategory Product 1 Sub-subcategory Product 2 Sub-subcategory Product 3 etc. Any thoughts on how I can accomplish this? I'm pretty new to PHP, though I have been able to modify several contributions already to suit my needs. Any help at all would be greatly appreciated. Cheers, Alex
×