Jump to content

Guidingfoot

Members
  • Content count

    7
  • Joined

  • Last visited

Profile Information

  • Real Name
    Tom
  • Location
    Wisconsin
  1. Guidingfoot

    osC reCaptcha

    Well, let me be the first to say; that I am in no way an expert when it comes to coding. I am not qualified enough to say what it good code VS bad code. However: I can say, that I have a very good idea what this problem is (BUT, I do not know how to fix/correct it), because of my limitations on understanding coding. The problem (I believe), is the person who wrote the instructions, in how to install the contrib, has made errors. Little as they may be, but, keep in mind, if one place leaves out, OR misses a spot in dropping a peice of code into a spot, and even 1 piece of code is either wrong, or not placed correctly. Hence you will get error on page problems. Missing one _ that, or this ` or "" or a bracket can do this, and in diffrent spots. Now: Other things can cause this problem as well, when all the instructions are correct. When using editing software, some wont encode it correctly, and simple bump of the space key can adjust a single code. However: In my case, I believe the error lies in the instructions, why? Because I am having simler problems after installing this contirb, and not know how to fix it, I need the instructions corrected, or the problem they caused to be listed how to fix the error after using them. In my case: I use dreamwever, and ftp up my files through filezilla. AND, I did all the changes through out the instructions, AS WELL paying attention using Option B, and not option A choices. So option B applies to me, and I am not sure if A has any problems. I am very lousy when it comes to coding things, However: I am VERY GOOD at following percise instructions. After dropping the code into place (where instructed to), the problems showed up. Now, I do understand the coder (I would think) surely knows what there doing, and I would save to bet the code is 100% correct. HOWEVER, in the kindness of putting it together, they by mistake, missed a spot where to drop it in the before or after, which ever applys. Meaning: That say; if you were told to drop it after the } and before the {, which I did it by the instructions percisley, is in where the error/s lie. NOTE IMPORTANT! I can not (with certainty) say I am correct on this, or have not a clue what I am talking about. Because as I have stated honestly and to the best of my ability, am NOT a coder, nore do I know how to catch the problem. I can say, that another who is VERY GOOD with code, did what I did, they may come to find I am correct on this. This is only my gutt instince based on knowing that I (almost 99%+) followed the instructions to the T. As well have no clue how to fix it. Thanks, and nothing personal towards the maker, for who am I to judge? :-)
  2. Guidingfoot

    osC reCaptcha

    I have this very same problem. :-( I use a shared SSL, and though I have my catalog set up fine, but when I use the non ssl option, I get that dreded warning about pages not being secure warning. Would make customers feel concerned. I tried choosing show both secure and non secure. But then the page defaults out of ssl too http from https. When I choose do not show non secure, then the captcha fails and wont load at all. Like, with full ssl, you would have: https://mywebsite.com But with a shared you have: https://otherwebsite.com/~a_user_name_here/...ate_account.php? With out the ability to some how tell the contirb to default to the shared SSL, I know me have no clue how I could use this. I get warning if using non ssl, in shared ssl mode, and warning above if I set it to use standard SSL. :-( Using now Rc2a, and reCaptcha 1.4
  3. Guidingfoot

    Official PayPal IPN Support Thread

    Well looking over this contrib, I am quite confused. Because things are not adding up for me. I am reading/seeing conflicting things with my layout, upgrading, instructions and so forth. This is the set up and where I am at: I have now this installed (concerns conflicts at bottom): ^^^^^^^^^^^^^^^^^>>>>>>>>> I have osCommerce Description: (v2.2ms2-060817) osCommerce 2.2-MS2. And in that build, I have done changes to the files that the osCommerce 2.2 MS2 PayPal IPN Payment Module v2.3.4.7 contrib refers to, like "shopping_cart.php", and some others, but not have added anything yet for those changes. Meaning, I have done things with my setup and the current osCommerece I am using. Having to do with other minor adjustments for other contribs. But no other payment type mods. I have NOT installed, or used this contrib yet "osCommerce 2.2 MS2 PayPal IPN Payment Module v2.3.4.7" http://addons.oscommerce.com/info/2679 and have done no changes of any kind, yet. I ran into some conflicts, and know best to come here for help, before really GOOFING something up. I am quite lousy with PHP, however, I am good at following step-by-step- instructions. I need your help please. In my current set up, I have this stuff, and my conflicts as to why I am here asking for guiandance. /public_html/osc/admin/includes/modules/newsletters And in that path are two files. newsletter.php And product_notification.php As for payment modules, there all located in here: /public_html/osc/includes/modules/payment And there are three sections in there for three types of modules: /public_html/osc/includes/modules /modules/order_total /modules/payment /modules/shipping And in the payment one for the paypal, there is at moment the "paypal.php,v 1.39" in there with other types of various mods. Based on the instructions below. How do I then get to: (http://yourdomain.com/catalog/ext/modules/payment/paypal_ipn/ipn.php?'>http://yourdomain.com/catalog/ext/modules/payment/paypal_ipn/ipn.php? As well I use/have a shared SSL set up, and I look at the path for this file "ipn.php" as needing to be in here: \catalog\ext\modules\payment\paypal_ipn My path on my server is this: /public_html/osc/admin/includes/modules/newsletters And /public_html/osc/includes/modules/payment So when I read this stuff below, I thought (knew better) it best to come ask for help with this. Try to open catalog/ext/modules/payment/paypal_ipn/ipn.php in internet browser (http://yourdomain.com/catalog/ext/modules/payment/paypal_ipn/ipn.php If payments are being received at PayPal but the stock level/orders status is not updated and confirmation emails are not sent, then IPN (Instant Payment Notification) is not working. Follow the check list below for trouble shooting: Make sure you have copied the ext folder to your server under your catalog directory. Try to open catalog/ext/modules/payment/paypal_ipn/ipn.php in internet browser (http://yourdomain.com/catalog/ext/modules/payment/paypal_ipn/ipn.php change the words marked in red corresponding to your store). A blank page will show up if there is no problem accessing this script. Follow Up Info: See, at moment, I am trying to want to get this set up, so I can test it in sandbox, I am plaining to upgrade my paypal to an account as needed. But before I do that, I need to badly get this working. I have no other payment modules activated besides the one lone paypal that came with the osCommerce it came with. And I had to get that adjusted by the host, to be sure atleast the paypal was loading. I have yet to be able to test it, but I can see from all I read at paypal, I need a different setup and need to get to Website Payments Standards. So here I am. :-( I am little fellow, in BIG world, and badly need help with this. I am lousy with code, but great on following instructions IF there given to me step by step and leaving nothing out. Thank you for ALL your help. :-)
×