Jump to content

Eric B

Members
  • Content count

    70
  • Joined

  • Last visited

Everything posted by Eric B

  1. Thanks Jack, I realized it just after I sent the post. All is working well now...
  2. Hi Jack, I found out what was disturbing my categories (w00t) In the ADMIN >> SEO URLs >> Add category parent to product URLs? I changed from False =>> to =>> True and all is working now! It adds at the end of the original "clean" link this (exemple of one product, ) : ?cPath=21_24_89_188 Visually not the best but it works :thumbsup: Now I just wonder if my Google ranking will be as it was! So far, I have tested on my localhost many old links (without "?cPath=21_24_89_188") and they seem to be OK. What do you think about Google Ranking, will it be an issue from my old links to the new ones? Also, all categories and products with accents (French) are giving a wrong text in the URLs: from améthyste to améthyste Do you know how to correct this? Thanks
  3. Oh I see, but if I take off this contribution, it's working normaly, beside not having a nice URL :( Anyway, I will have a look on my contributions... As you can see in my signature, I have a few B) but maybe you heard one of them has an issue or maybe you can tell me which one can interfere with it? Thanks Regards PS: My template is from the official French osCommerce site, and I just added contributions
  4. Hi Jack and everyone, I just found out that some of my products are linked in the "wrong" categories. I think it is from this contribution cause I had this issue only on the web (where this comtribution is), not in my test area (localhost). After looking everywhere I finally installed this contribution in my localhost and now I have the same issue. I explain myself with an example (breadcrumb): Accueil » Catalogue » Colliers BIJOUTERIE » Colliers Colliers » Colliers Par pierre » Colliers Corail when I click on an article (Collier corail et argent C-952) of the of the category list Colliers Corail, I get the right product but a wrong breadcrumb : Accueil » Catalogue » Colliers BIJOUTERIE » Colliers Colliers » Colliers Par couleur » Colliers Rouge » Collier corail et argent C-952 As you can see, the last 2 categories changed! (from Colliers Par pierre » Colliers Corail -> to -> Colliers Par couleur » Colliers Rouge) in ENGLISH ;) : (from Necklaces by Stones » Necklaces Coral -> to -> Necklaces by Color » Necklaces Red) The funny thing is that it happens only with some categories, the last ones I think! Instead, I'd like to get this, as many others products in my website: Accueil » Catalogue » Colliers BIJOUTERIE » Colliers Colliers » Colliers Par pierre » Colliers Corail » Collier corail et argent C-952 Any idea? By the way, in my category menu on the left, the category name is not in "bold" anymore, only when I'm on the product page, like it is without the contribution. Thanks
  5. Eric B

    Who's Online Enhancement 1.4

    Found a way for that and it is working: http://forums.oscommerce.com/topic/124853-whos-online-enhancement-14/page__st__1640__p__1502838#entry1502838
  6. Eric B

    Who's Online Enhancement 1.4

    I forgot... The only thing who is not working is step 5 (even if I use all good files from Who's Online Enhancement). (5. In the Admin area, go to Configuration -> Store -> Google Maps Key and enter the key from the previous step) I have no Google Maps Key option in my ADMIN. Means I can show the Google Map! An idea? Thanks
  7. Eric B

    Who's Online Enhancement 1.4

    Last minute... if I keep the original file whos_online.php (from whosonlineturbov1.1) in catalog/includes/fonctions/whos_online.php it seems working fine in ADMIN and Website! But it still don't know if is it ok and I can use it the same way for my main website! Someone knows? Thanks
  8. Eric B

    Who's Online Enhancement 1.4

    Hello everyone, I read a lot on this forum without founding my problem. I have install whosonlineturbov1.1 a long time ago but now I like to change it with Who's Online Enhancement cause I heart only good things about this contribution. SQL downloaded for whosonlineturbov1.1: ALTER TABLE whos_online ADD http_referer VARCHAR(255) NOT NULL; ALTER TABLE whos_online ADD user_agent VARCHAR(255) NOT NULL; ////// At the start, I have to download the SQL file but I get an error: Erreur requête SQL: ALTER TABLE whos_online ADD http_referer VARCHAR( 255 ) NOT NULL ; MySQL a répondu:Documentation #1060 - Duplicate column name 'http_referer' //////// I have push up and finish to install all the files. My admin side is working normaly and I can see whos_online but my website is down with an error: 1054 - Unknown column 'hostname' in 'field list' insert into whos_online (customer_id, full_name, session_id, ip_address, hostname, time_entry, time_last_click, last_page_url, http_referer, user_agent) values ('0', 'Guest', 'd33a478148c4e95a2b3cxxxxxxxxxx', '101.231.216.249', '101.231.216.249', '1303000657', '1303000657', '/catalog/index.php', '', 'Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 ( .NET CLR 3.5.30729; .NET4.0E)') [TEP STOP] I have change a few numbers..., cause I don't know if it is safe to show them! Someone as an idea please? Thanks
  9. Eric B

    Header Tags SEO

    OK Jack Now it looks much better and the code source (via Firefox) and the TAGS are looking the same. Thanks for your time
  10. Eric B

    Header Tags SEO

    I have found a post about my problem (HERE) and it seems working normaly and at the same time I have the title of my product instead of the details, which is better for me. Jack, can you please confirm if this code (from jailaxmi) is OK (fully working with your contribution?) cause it is very different? // add the products name to the breadcrumb trail if (isset($_GET['products_id'])) { $products_query = tep_db_query("select pd.products_name from " . TABLE_PRODUCTS . " p left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id where p.products_id = '" . (int)$_GET['products_id'] . "' and pd.language_id ='" . (int)$languages_id . "' LIMIT 1"); if (tep_db_num_rows($products_query)) { $products = tep_db_fetch_array($products_query); $breadcrumb->add($products['products_name'], tep_href_link(FILENAME_PRODUCT_INFO, 'cPath=' . $cPath . '&products_id=' . $_GET['products_id'])); } } Thanks
  11. Eric B

    Header Tags SEO

    Hi Jack, Thanks for your quick reply... I don't really understand your explanation and what to do! Sorry but I am working hard to understand codes and other things but it is too fast/far sometimes. Anyway, if you can be a bit more "simple" :blush:;) in what to do..., and to be sure you understand what I mean: HERE is a link of one of my issue. Thanks
  12. Eric B

    Header Tags SEO

    Hi Jack First, thanks for your contribution I have a little issue on my trail... Now that I have make longer titles in catagories I have notice that my product name in the trail in underneath the categories (still in the trail-Breadcrumb)! (the little points are to make it clearer) EX. trail N.1: SHOP>>Catalogue>>XXXXXXXXXXXXXXXXXXXXXXXXX>>XXXXXXXXXXXXXXXXXXXXXXX>>XXXXXXXXXXXXXXXXX >>XXXXXXXXXXXXXXXXXX>> ...........................................................................................................................................................My Account | Cart Contents | Checkout XXXXXXXXXXXXXXXXXXXhere my product name I have tried a lot of things and read a lot but still don't how to make it straight like: EX. trail N.2: SHOP>>Catalogue>>XXXXXXXXXXXXXXXXXXXXXXXXX>>XXXXXXXXXXXXXXXXXXXXXXX>>XXXXXXXXXXXXXXXXX >>XXXXXXXXXXXXXXXXXX>>XXXXXXXXXXXXXXXXXXXhere my product name..................................................My Account | Cart Contents | Checkout That way my trail won't be thick as it is right now. Maybe I have miss a thread about it but if you have an idea have to change it as EX. 2? Thanks (I am with HEader Tag SEO 3.1.4)
  13. It works!!! I was trying to make it work only on my test area (localhost) but there it doesn't. But it works online! Don't know why! Anyway, thanks again
  14. Hi chooch! Then if I get it right, I just need to fill up the product name (ex: GIFT_25) and make sure that the weight is at 0 (as I read already in the post) + an image or a link if I want to. No more details in the product, just the Product name and the weight? Can it be off status as it appears if I put it on? Hope that someone will give an issue for the Gift voucher code in the email cause I have tried a lot of things (without knowing how to code) and cause can only send then via "Gift Vouchers sent" and can't do it automatically (first user). But I am already happy with what I have... Thanks for your contribution chooch!
  15. Hi Guys! Great contribution....thanks I have just a 2 small issues on the confirmation new customer's email and on how to make a GIFT voucher... ( I can still send to customers Gift and Vouchers): 1st: All is going well but when the customer is getting the email of confirmation he had a new account in my website (as normal) it has the test under saying that "as a new subscriber, you have a "welcome-coupon" for your first order" see the code below... There isn't a code under it is all blank! I have created the code. I have writed down the code in the Admin/configuration/To offer a discount coupon..., I have set to 0 "To offer a gift voucher" - but still not working! DO YOU KNOW HOW I CAN MAKE MY CODE APPEAR in the email? 2nd: I still don't get it about the gift voucher! I have made a GIFT_WELCOME as a product. But I do I fill it up please? *Where do I put this product? *In Products Manufacturer, do I put something? *Is the status has to be ON or OFF? (cause if put ON it will apprear in my "new product banner"! *In Products Name, do I put GIFT_WELCOME here? If yes English, french,... have to have the same name: GIFT_WELCOME? *In Products Description, do I put something in here too? *In Products Quantity, do I put a quantity of how many time I want to use it? *In Products Model, do I put the name of the Gift Voucher again (GIFT_WELCOME)? *In Products Image, I can add any .gif image? *In Products URL, any URL I suppose? *and In Products Weight, I read it has to be 0, is it right? If you can tell me how to make it please it will be very nice cause I have been reading most of the forum and couldn'd found a clair view. Thanks
  16. Eric B

    Customers extra fields

    Ok I have found this problem and those who need it : It was missing a @ in the code: { $item = trim($item); $extra_fields_string .= tep_draw_selection_field('fields_' . $extra_fields['fields_id'] . '_' . ($cnt++), 'checkbox', $item, ((@in_array($item, $value_list))?(true):(false))).$item. (($extra_fields['fields_required_status']==1) ? '<span class="inputRequirement">*</span>': '').'<br>'; $extra_fields['fields_required_status'] = 0; } I still have a problem, the data are still not showing in my ADMIN but they are in the customer's detail If someone knows what to do cause I have tried a few things from here but still the same?! Thanks
  17. Eric B

    Customers extra fields

    Hi everyone, I have just install the last update (Customer Extra Fields EXTENDED 1.3 matta 16 Jun 2009) full package. Very good contribution, thanks! But when I go in my ADMIN/Customers/XXX (detail) I have a Warning: Warning: in_array() [function.in-array]: Wrong datatype for second argument in C:\wamp\www\catalog\xxxx\includes\functions\general.php on line 1446 Warning: in_array() [function.in-array]: Wrong datatype for second argument in C:\wamp\www\catalog\xxxx\includes\functions\general.php on line 1446 This is the second argument: { $item = trim($item); $extra_fields_string .= tep_draw_selection_field('fields_' . $extra_fields['fields_id'] . '_' . ($cnt++), 'checkbox', $item, ((in_array($item, $value_list))?(true):(false))).$item. (($extra_fields['fields_required_status']==1) ? '<span class="inputRequirement">*</span>': '').'<br>'; $extra_fields['fields_required_status'] = 0; } Do you know what to do please??? Thanks
  18. Eric B

    Customers extra fields

    Hi guys, It looks a very good contrib and it did work fine until I found out that all fields who are fill up by customers are blank in my ADMIN (they are ok in the file that the customer can see when he login)! I read a lot all along this post but I couldn't found the right way to change it. Could someone help me on it please? Thanks
  19. Eric B

    [contribution] GroupDiscount

    Hello everyone, I have tried a few contributions to have groups and to make special prices to them but nothing is working cause I have to install it with a few contribution that I have aready on my website: GoogleXML_sitemap HEader Tag SEO 3.1.4 AntiRobotRegistrationValidation-3.1 TinyMCE WYSIWYG HTML EDITOR PDF Invoice 1.5 Quick Stock Update v3.8.1 Specials_enhanced_v1_3_1 and Ultimate SEO URLs 2.1d My best try was with GroupDiscount but I still have a problem with it. I am testing GroupDicount_v1.4-3 on my localhost but when I get the confirmation of the buy done with a group who get -50% off, he pay the right amount but an error is on the bill (email confirmation who gets the buyer and the owner of the shop). See below an exemple (the original price of the necklace is 295euros) : As you can see, the "Sub-total" and the "Total" of the necklace are right but in the details it is not (1 x Necklace amethyste 129 (C-129) = €73,75)! Don't know why it is divided by 2 again (€73,75)! QUESTIONS : Do you know how to change that? If not, can you tell me which contribution can I use to do the same thing respected all the contributions that I have already? As I said - I have try a few contributions, but they didn't work cause I think it was hard to fit between all the others! Thanks
  20. Yes I will love to use it but for that I will need to have an other account with my provider I think cause I have chose PHP4... for my curent website (cause the provider was giving me the choice between 4 and 5 but recommended 4) and now if I want to change from 4 to 5 I have to change all (or subscribe a new one for my new project with PHP5), means my current website. Hard to imagine now that I have just finish (nearly) my website that I have to do all again! :( ;) I can make different DATA BASE / SQL on my current subscription but I am not sure if I can have different PHP on one account with 2 data base! I will ask... Thanks again anyway
  21. Hi FWR Media, Just a quick word to tell you THANKS for all your support !!! Your contribution is working very well... cause of you! Anyway, I am planing to do an other website and it will be with PHP5....then see you soon ;) Eric
  22. Eric B

    Header Tags SEO

    Hi Kornel76, It woks for me too very well. I was just asking myself if having this "warning" in my admin was not dangerous (security) or... But same as you ---->>>> MANY THANKS JACK!!!!
  23. Eric B

    Header Tags SEO

    OK that's fine! Can I live it like that if Header Tag works properly??? Many Thanks anyway PS: which file do I have to change back to unwriteble in Header Tags if I can list all the files that I have to change ???
  24. Eric B

    Header Tags SEO

    Actually Jack they just reply to me: Le CHMOD 777 est possible (vous aurez lecture, ecriture, modification, suppression). Pour cela, il est nécessaire de choisir l'option : Mettre les droits en ecriture sur tout votre site. Impératif pour SPIP,JOOMLA,OSCOMMERCE... Means in English: Chmod 777 is possible (you will have reading, writing, modification, suppression). For it, you need to choice the option : Put rights in writing on all your website Imperative for SPIP,JOOMLA,OSCOMMERCE... As I told you, it sounds a bit extreme for me cause even if I can do it, which files will I have to put back on unwriteble to have my website safe?
  25. Eric B

    Header Tags SEO

    Hi Jack, I have tried all again: To set the directory /includes/ to writeble chmod (with all files) via FTP, can't be done, same as the test done first via FTP with header_tags.php. I can write change in the file includes/header_tags.php and recorde them via FTP, cause when I open my file again via FTP it has the change that I had done. It means it is writeble (I suppose?) I have read a lot of things in my host website and there are saying that if I want to change a file in 777, I have to change my all website in 777!!! Sounds a bit extreme for me cause even if I can do it, which files will I have to put back on unwriteble???! Your contribution seems working good actualy with still the error: Erreur Permissions settings for the D:/www/my-site.fr/htdocs/catalog/includes/header_tags.php file appear to be incorrect. Change to 777. NOTE: Disregard if on Windows server. It sounds like the best (if I can write on the files with my test) to leave it like that and to set the option to ignore the permissions setting and forget about it like you said. What do you think?
×