Jump to content

TS153

Members
  • Content count

    45
  • Joined

  • Last visited

Posts posted by TS153


  1. I have noticed with USU 5 that when a customer selects a manufacturer from the dropdown box, once the page has loaded if the customer then goes back to the dropdown box(which should have the loaded manufacturer preselected) and selects "Please Select" the USU 5 error page shows.

    Is there a way around this to the show the index page for http://www.x.com/index.php?manufacturers_id=

     

    I noticed this was bought up before but from memory no solution was posted and seems to be in all sites I have seen with this installed so it isn't just mine.

    I dont have an issue with doing a custom error page but I just thought that this could be a common selection with customers and would prefer them not to see it unless an error has occured.

    I tried some htaccess redirects and a few other things but none ended up being a great long term solution.

    Thanks in advanced


  2. There is no "super simple" solution to this .. you would need to open up ..

     

    kiss_meta_tags/modules/product_info.php then change the order that $leading_values is built .. the code that does this is ..

     

          $leading_values = KissMT::init()->entities( trim( $product_results['products_name'] ), $decode = true );
         if ( tep_not_null( $product_results['products_model'] ) ) {  
            $leading_values .= '[-separator-]' . trim( $product_results['products_model'] );
         } 
         $leading_values .= '[-separator-]' . implode( '[-separator-]', $breadcrumb );
         if ( tep_not_null( $product_results['manufacturers_name'] ) ) { 
           $leading_values .= '[-separator-]' . sprintf( KISSMT_BRAND_TEXT, trim( $product_results['manufacturers_name'] ) );
         }

     

    This is what I got that seems to work for what I want with my non-existent php skills.

     

    $leading_values = KissMT::init()->entities( trim( $product_results['products_name'] ), $decode = true );
         if ( tep_not_null( $product_results['manufacturers_name'] ) ) {
      $leading_values .= '[ ]' . sprintf( KISSMT_BRAND_TEXT, trim( $product_results['manufacturers_name'] ) );
         } 
         $leading_values .= '[-separator-]' . implode( '[-separator-]', $breadcrumb );
         if ( tep_not_null( $product_results['manufacturers_name'] ) ) { 
           $leading_values .= '[-separator-]' . trim( $product_results['products_model'] . ( KISSMT_HOMEPAGE_TITLE ) );
         }

    Also I have trying to use a pipebar/vertical bar as my separator but without luck, is there any reason why it doesn't seem to work.

    Thanks


  3. There is no "super simple" solution to this .. you would need to open up ..

     

    kiss_meta_tags/modules/product_info.php then change the order that $leading_values is built .. the code that does this is ..

     

          $leading_values = KissMT::init()->entities( trim( $product_results['products_name'] ), $decode = true );
         if ( tep_not_null( $product_results['products_model'] ) ) {  
            $leading_values .= '[-separator-]' . trim( $product_results['products_model'] );
         } 
         $leading_values .= '[-separator-]' . implode( '[-separator-]', $breadcrumb );
         if ( tep_not_null( $product_results['manufacturers_name'] ) ) { 
           $leading_values .= '[-separator-]' . sprintf( KISSMT_BRAND_TEXT, trim( $product_results['manufacturers_name'] ) );
         }

     

    Thanks I was looking at that last night but had to check first before I mess with things.

    I get into it now.


  4. Love the contribution especially category/manufacturers option.

     

    My Qu is where is it that I modify the arrangement the titles that show on my categories and product_info pages so that they suit my industry a bit better.

    Sorry if it was asked before but I couldn't find it.

    All I really want is to change the title on product_info from (product name - category by manufacturer - Desc) to (product name by manufacturer - category at storename (then maybe desc))

    On the categories pages I have (category - desc) to change to (category at store name - desc)

    This is more for the branding side of things more than seo but it all counts.


  5. I finally figured out my issue and Im curious as to know why this is happening.

    I had played around with it on standard installs before and haven't come across this.

    All of my products now show up as they should with master products installed or they seem to be at the moment anyway.

    By removing this

     and p.products_master = '0'

    from this section on /index.php

    //Master Products
    $listing_sql = "select " . $select_column_list . " p.products_id, p.manufacturers_id, p.products_price, p.products_master, p.products_master_status, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price from " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where p.products_status = '1' and p.products_master = '0' and p.products_listing_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '" . (int)$languages_id . "' and p2c.categories_id = '" . (int)$current_category_id . "'";
    // Master Products EOF

     

    Are there any consequences I should know about that Ill run into by leaving it removed.


  6. Hi.

    Im looking for some suggestions on what could be wrong with my install.

    I have just put in Master Products and all products(master, slave and standard) aren't showing at all in their respective categories.

    They all show up as expected in manufacturers lists and new products.

    I have been over my install a few times now and either cant see my mistake or I have a conflicting contribution.

    I have tried removing a few contribs that I thought may have attributed to this behaviour but nothing changes so I assume I have made a mistake.

    Any suggetions would be appreciated.


  7. Hi Guys

    Just wanted to see whether anyone has had success with changing the amount of columns of the new product module on the index page.

    I have changed my from new products to specials but am not having much success in changing the column count.

    I cant tell whether its the css version of OSC or my changing it to specials that is making it not work.

    Any ideas would be appreciated.


  8. I have just installed this contrib and when I go to Admin>Tools>News it shows this error

     

    Fatal error: Call to undefined function tep_reply() in /home/tez/public_html/store/admin/news.php on line 315

     

    And when I click on the test article this error shows up

     

    Fatal error: Call to undefined function tep_get_news_name() in /home/tez/public_html/store/admin/news.php on line 195

     

    I have been looking through it for a while now and I can pick up what the problem is maybe I missed something but each time I go over it I cant find a thing.

    Any help would be appreciated as im super keen to get this going.

    Thanks


  9. If I wanted a contribution so that I could charge 3 different rates depending on the customers postcode, would this be the ideal contribution for me.

    One table Ill have 650 postcodes = $5 postage.

    The second will be 1500 postcodes = $9

    The third I am yet to decide.

    I realise that it will take a while to add them in.

    What are the disadvantages of such large tables in my database.


  10. in admin under configuration >> Maximum Values

     

    Manufacturers Select Size

     

     

    set it to a number higher than the number of manufacturers you have in your site

     

    Sorry I forgot a line of text. I meant like a listed menu like the Categories box so I can get away from the drop down menu.


  11. Yep you were right about that one, turns out a pic I had was 2px too wide but when I added up all the widths and it seemed right but IE doesnt see it the way I do. So I experimented with widths it worked.

     

    But now I have a new one for you lol. Why stick to one shop when your trying to learn.

     

    musclebeach(dot)terryscarr(dot)com

     

    This one has the same problem in IE but with the menu I experimented with the menu width and changed the header to tile across to suit. But I cant seem to work it out.

    The only thing I can seem to work out is I made it to suit an 814px width which works in all but IE and IE only works with an 818px width but then I get the same problem with all the other browsers.

     

    Also I have tried some contributions to make my manufacturers drop down box to look and list like the categories box. But they dont seem to work right. Any Ideas on a contrib or changes I can make to get this.


  12. I am getting this warning after it seemed to work fine for me.

    I turned it off in the admin console just to make sure and now I cant turn it back on or change any of the other values because of it.

    Im assuming because no one else has had this problem that it me.

     

    Warning: Cannot modify header information - headers already sent by (output started at /home/ter32222/public_html/musclebeach/admin/configuration.php:42) in /home/ter48888/public_html/musclebeach/admin/includes/functions/general.php on line 22

     

    Any Ideas.

    Thankyou.


  13. Sorry to be a Help Vampire but I have an issue with my header in Internet Explorer.

    I changed my site width to 800px via the included greyskin Stylesheet as I need just a little extra room and made a new header background to suit.

    It shows up fine in all the main browsers except IE where it has a small white strip to the right of the header.

    I thought it may have been an old cached pic but when I went to BrowserShots.org it still came in all versions of IE.

    I have been trying to figure this out for a few days and searched this via the search function and google but still come up empty handed.

     

    Thanks for any info you can give me.

    Tez...


  14. I have another one for you.

    I am looking to change the font height and style of the category and manufacturer titles within the main column and they dont seem to be in the stylesheet.css I had a look around and cant seem to spot it.

     

    So what I did was added a new style H1 to my stylesheet with the styles I wanted as I notice by viewing the source through my browser that they were wrapped in H1 tags.

    Doing this seems to add the style changes to the title and the price.

     

    Is there a better way to go about this or will this do the job with out any conflicts in the future.

    I have Header Tags SEO aswell dont know if it makes a difference.


  15. Hey Great contrib.

    I have start a fresh store to help with ideas for an existing store.

    But I have run into a prob with Ultimate SEO and this contribution with includes/functions/html_output.php

    As ultimate SEO wants me to replace The HTML href link wrapper function with their own but I noticed that in the html_output.php included with contrib, The HTML href link wrapper function is significantly different to the original.

    How would I go about fixing this.

     

    Sorry if it was already discussed but I had a look through all 49 pages and I must have missed it.

    This is my first real experience at using php.

×