Jump to content

TS153

Members
  • Content count

    45
  • Joined

  • Last visited

Profile Information

  • Real Name
    Terry Scarr
  1. How would one go about drawing out the canonical url of a page. Similar to - <?php echo HTTP_SERVER . $_SERVER['REQUEST_URI']; ?> But for the canonical url. Thanks in advanced
  2. TS153

    ULTIMATE Seo Urls 5 - by FWR Media

    I have noticed with USU 5 that when a customer selects a manufacturer from the dropdown box, once the page has loaded if the customer then goes back to the dropdown box(which should have the loaded manufacturer preselected) and selects "Please Select" the USU 5 error page shows. Is there a way around this to the show the index page for http://www.x.com/index.php?manufacturers_id= I noticed this was bought up before but from memory no solution was posted and seems to be in all sites I have seen with this installed so it isn't just mine. I dont have an issue with doing a custom error page but I just thought that this could be a common selection with customers and would prefer them not to see it unless an error has occured. I tried some htaccess redirects and a few other things but none ended up being a great long term solution. Thanks in advanced
  3. I just re-read what I last wrote and I hope it didnt come across in a bad way. What I meant to say was this is the best I could come up with and if theres a better way Id like to know, and with my limited knowledge Im not yet opened up to what opportunities are available to me.
  4. This is what I got that seems to work for what I want with my non-existent php skills. $leading_values = KissMT::init()->entities( trim( $product_results['products_name'] ), $decode = true ); if ( tep_not_null( $product_results['manufacturers_name'] ) ) { $leading_values .= '[ ]' . sprintf( KISSMT_BRAND_TEXT, trim( $product_results['manufacturers_name'] ) ); } $leading_values .= '[-separator-]' . implode( '[-separator-]', $breadcrumb ); if ( tep_not_null( $product_results['manufacturers_name'] ) ) { $leading_values .= '[-separator-]' . trim( $product_results['products_model'] . ( KISSMT_HOMEPAGE_TITLE ) ); } Also I have trying to use a pipebar/vertical bar as my separator but without luck, is there any reason why it doesn't seem to work. Thanks
  5. Thanks I was looking at that last night but had to check first before I mess with things. I get into it now.
  6. Love the contribution especially category/manufacturers option. My Qu is where is it that I modify the arrangement the titles that show on my categories and product_info pages so that they suit my industry a bit better. Sorry if it was asked before but I couldn't find it. All I really want is to change the title on product_info from (product name - category by manufacturer - Desc) to (product name by manufacturer - category at storename (then maybe desc)) On the categories pages I have (category - desc) to change to (category at store name - desc) This is more for the branding side of things more than seo but it all counts.
  7. TS153

    Master Products - MS2

    I finally figured out my issue and Im curious as to know why this is happening. I had played around with it on standard installs before and haven't come across this. All of my products now show up as they should with master products installed or they seem to be at the moment anyway. By removing this and p.products_master = '0' from this section on /index.php //Master Products $listing_sql = "select " . $select_column_list . " p.products_id, p.manufacturers_id, p.products_price, p.products_master, p.products_master_status, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price from " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where p.products_status = '1' and p.products_master = '0' and p.products_listing_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '" . (int)$languages_id . "' and p2c.categories_id = '" . (int)$current_category_id . "'"; // Master Products EOF Are there any consequences I should know about that Ill run into by leaving it removed.
  8. TS153

    Master Products - MS2

    Hi. Im looking for some suggestions on what could be wrong with my install. I have just put in Master Products and all products(master, slave and standard) aren't showing at all in their respective categories. They all show up as expected in manufacturers lists and new products. I have been over my install a few times now and either cant see my mistake or I have a conflicting contribution. I have tried removing a few contribs that I thought may have attributed to this behaviour but nothing changes so I assume I have made a mistake. Any suggetions would be appreciated.
  9. Thanks, so simple I dont know what I was thinking lol not CSS obviously. productlisting-new was the one I was after. Love the contrib by the way so much easier to work with in general.
  10. Hi Guys Just wanted to see whether anyone has had success with changing the amount of columns of the new product module on the index page. I have changed my from new products to specials but am not having much success in changing the column count. I cant tell whether its the css version of OSC or my changing it to specials that is making it not work. Any ideas would be appreciated.
  11. thanks,I've took over it.and I have posted a new one.

    thanks very much.

  12. Hi guy,

    I saw you posted a problem on NEWS BLOG,Fatal error: Call to undefined function tep_reply() in /xxx/admin/news.php on line 315

    You said you have solved it yourself ,could you tell me how to deal with it?

    great thanks!

  13. TS153

    News Blog V1.0

    Its all good now sorry guys. I made a mistake in my own work and was repeating it when I was looking over it.
  14. TS153

    News Blog V1.0

    I have just installed this contrib and when I go to Admin>Tools>News it shows this error Fatal error: Call to undefined function tep_reply() in /home/tez/public_html/store/admin/news.php on line 315 And when I click on the test article this error shows up Fatal error: Call to undefined function tep_get_news_name() in /home/tez/public_html/store/admin/news.php on line 195 I have been looking through it for a while now and I can pick up what the problem is maybe I missed something but each time I go over it I cant find a thing. Any help would be appreciated as im super keen to get this going. Thanks
  15. If I wanted a contribution so that I could charge 3 different rates depending on the customers postcode, would this be the ideal contribution for me. One table Ill have 650 postcodes = $5 postage. The second will be 1500 postcodes = $9 The third I am yet to decide. I realise that it will take a while to add them in. What are the disadvantages of such large tables in my database.
×