Jump to content

NETcube

Members
  • Content count

    6
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Alan Green
  1. Hi, I was wondering if you would be good enough to give me some guidance on how to get this module working? I have installed it as per the instructions and I have also configured the CPI Admin as recommended The problem I have is that when osc hands over to epdq it is giving the CPI error "Not a valid allowed URL " The problem as I see it is osc is putting the session ID on the end of the checkout_confirmation.php url and therefore it's not matching what epdq has (same url with no sid) The obvious(??) solution is to remove the need for session ID's by forcing cookie usage? but the problem I am having is that if I do that, no matter what cookie settings I put in configure.php it either wont let me log in at all or just comes up with the cookie usage warning page (my browser is set to accept all cookies) here is a copy of the first part of my configure.php define('HTTP_SERVER', 'http://www.craftypastimes.co.uk'); define('HTTPS_SERVER', 'https://thunderbolt.xssl.net/craftypastimes.co.uk'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', 'www.craftypastimes.co.uk'); define('HTTPS_COOKIE_DOMAIN', ''); <- tried lots of different configurations here define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); No matter what I try I simply cant get the session cookies to work, it just omes up with the Cookie Usage warning page (again I say my browser is set to accept all cookies) I would really appreciate some guidance with this Thanks!
  2. NETcube

    Blank checkout_confirmation with Protx Direct 2.3b

    Never mind :-" Seems it's because my client hasn't set up his protx vendor correctly yet, i set it back to "testvendor" and it worked fine
  3. Hi, I have installed this contribution into a clean install of osc and when I try and run some test transactions all goes well until after I enter the dummy card details, it then directs me to the checkout_confirmation.php page, but that page is completely blank I've tried every option in the Admin (Test, Server IP Test, Simulator, Debug, etc) and nothing makes any difference, ive even tried unquoting the curl_setopt lines below, which made no difference either // Uncomment these lines if having problems connecting to Protx server curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, 0); curl_setopt($ch, CURLOPT_SSL_VERIFYHOST, 0); // End of Add Can you shed any light on this please?
×