Jump to content

carmet

Members
  • Content count

    18
  • Joined

  • Last visited

Posts posted by carmet


  1. Hi Jan,

     

    You told me that if I want to use the SPPC, I should use the update one of SPPC 4.2.2 only, no need install 4.2.1 to upgrade 4.2.2 because of big work load. However, I checked that if I only install the SPPC 4.2.2, it is not the full package for new user. It was because I found out that some instructions of SPPC4.2.2 must add after the instruction of SPPC4.2.1. such as below:

    ____________________________________________

    in catalog/admin/includes/functions/general.php

     

    Line 923-925 (this is in function tep_remove_product)

    **AFTER**

    // BOF Separate Pricing Per Customer

    tep_db_query("delete from " . TABLE_PRODUCTS_GROUPS . " where products_id = '" . (int)$product_id . "'");

    // EOF Separate Pricing Per Customer

     

    **ADD**

    // BOF QPBPP for SPPC

    tep_db_query("delete from " . TABLE_PRODUCTS_PRICE_BREAK . " where products_id = '" . (int)$product_id . "'");

    tep_db_query("delete from " . TABLE_PRODUCTS_TO_DISCOUNT_CATEGORIES . " where products_id = '" . (int)$product_id . "'");

    // EOF QPBPP for SPPC

    ______________________________________________

     

    And in my osc, there isn't any ''// BOF Separate Pricing Per Customer....'', how do I add the new installation?? Therefore, should I install the 4.2.1 first and then upgrade to 4.2.2?? Please kindly advice.

     

    Carmet


  2. Hi Jan.

     

    Thanks for your advice. It is because there isn't any table of 'products_groups' in my database. So, I think that maybe I need install the 4.2.1 first. Finally, thanks for your advice.

     

    From the instruction, there is one instruction which show:

    'UPDATE `configuration_group`

    SET sort_order = last_insert_id() WHERE `configuration_group_id` = last_insert_id();'.

     

    After I insert it to database, it shows 'error message' as below:

    ________________________________________________________

    Error

    SQL query:

     

    SET sort_order = last_insert_id( ) WHERE `configuration_group_id` = last_insert_id( )

    MySQL said:

     

    #1193 - Unknown system variable 'sort_order'

    _________________________________________________________

    Sorry about that I am the new user of oscommerce and didn't know any database knownledge, actually, how to 'UPDATE `configuration_group` into the database?? Can you give me advice on it?

     

    Thanks for your attention.

     

    Carmet

     

    Hi Jan,

     

    Sorry, I know how to add it now. Thank you

     

    Carmet


  3. Why do you want to install SPPC just to add the QPBPP version for it (it is a lot of work)?

     

    And if you really want to do that you should install the 4.2.2 version. Not 4.2.1 and then upgrade (more work for the same result).

     

    Hi Jan.

     

    Thanks for your advice. It is because there isn't any table of 'products_groups' in my database. So, I think that maybe I need install the 4.2.1 first. Finally, thanks for your advice.

     

    From the instruction, there is one instruction which show:

    'UPDATE `configuration_group`

    SET sort_order = last_insert_id() WHERE `configuration_group_id` = last_insert_id();'.

     

    After I insert it to database, it shows 'error message' as below:

    ________________________________________________________

    Error

    SQL query:

     

    SET sort_order = last_insert_id( ) WHERE `configuration_group_id` = last_insert_id( )

    MySQL said:

     

    #1193 - Unknown system variable 'sort_order'

    _________________________________________________________

    Sorry about that I am the new user of oscommerce and didn't know any database knownledge, actually, how to 'UPDATE `configuration_group` into the database?? Can you give me advice on it?

     

    Thanks for your attention.

     

    Carmet


  4. QPBPP is about the price breaks too. In principle it is the same functionality for a shop. However, the QPBPP for SPPC is specifically adapted for use with customer groups (a bit more complicated to code). You can't add that version to a shop that doesn't have SPPC (the contribution Separate Pricing Per Customer, #716) installed.

     

    QPBPP for SPPC does have some features that the regular QPBPP does not have (yet) but someone versed in the PHP art wouldn't have that much problems adding that to the regular QPBPP contribution. I haven't taken/found the time for that.

     

    Hi Jan,

     

    Finally, I found out the 'separate_price_v421', and there has some product_groups and customer_groups that I should add into my database. I want to ask one question that, should I need add all the things of v421 first? and then I modify it to upgrade v422. Am I correct?

     

    Hope to get your advice on it.

     

    Thank you so much of your contribution.

     

    Carmet


  5. Hi Jan,

     

    I really want to have your advice. Sorry about that I dont know too much technique on database. After I saw the SPPC, it was very greatful for the price break of the products. If I deleted all the old one and want to add the SPPC, but I really can't find the 'product_groups' in database. How should I do? or I need to combine the QPBPP 1.3.5 and SPPC 4.2.2??? Could you please give me advice? :blush:

     

    Best regards

    Carmet


  6. Hi Jan,

     

    Sorry!!

     

    I just deleted all my old qpbpp_v1_3_5, and download the SPPC_price_break_v2_0. When I wanted add and alter the table in mySql, I have discovered that I didnt have the table of 'product_groups'. How do I alter this table in Database?? Could you have any orginial of 'product_groups' for my updated?? or Should I go anywhere to download this table?? Please kindly advice.

     

    Thanks for your great help.

     

    Carmet :o


  7. hi,

     

    Yesterday I downloaded the qpbpp (version 1.3.5 / osC 2.2 RC2a), after checking the admin page, it is working, however, when I back to the client page for checking, there is nothing on the 'Let's See What We Have Here'. After I checked all of the download files and modification, there is no any wrong. Anyone have any idea on it?

     

    And actually, I looked over the new addon after uploaded, the first step is: If some items has price break, I should add the items on discount category, shouldn't I?? if there is no any price break on some items. then I no need add the it to the discount category. right? Am I misunderstanding on the schedule?

     

    Sorry about that I am a new user and stupid on it. :blush:

     

    Best regards

    Carmet


  8. Hi Jack,

     

    After I click the sitmap. the screen is shown ' HTTP 500', <_< , it can't show the link. and I tried to go back to admin page's sitemap SEO, I thought it may be some links I added before, so it can't show the sitemap. But it can't....... I really dont know how to do..... this is my website link : http://www.idealsource.co.cc/catalog/sitemap.php .... do I need add anythings for support it?

     

    Please kindly give me some advice.

     

    Carmet :(


  9. Hi Jack,

     

    Thanks for your contribution. I uploaded all the files to my site, in admin side, it can workable, however, I can't see the www.mydomain.com/catalog/sitemap.php. I made sure that I followed all the steps of your instruction. And I tried to go back www.mydomain.com/catalog/sitemap_seo_install.php, it said 'Looks like Sitemap SEO is already installed. Aborting...' . On the other hand, from my homepage, I can see the sitemap in the information box. I really no idea where the problem have...... Have you any idea what problem found? Sorry for my stupid!! :blush:

     

    Best regards!!

    Carmet

×