Jump to content

AlecUK

Members
  • Content count

    46
  • Joined

  • Last visited

Everything posted by AlecUK

  1. Hello All, I have successfuly installed osCommerce and am now wanting to customise its default look. To be honest I have not snooped around in the config files yet so am not in the position to understand its workings. I am aware there are 2 contributions which apparently make it easier to customise osCommerce, namely Basic Template Structure and Simple Template System. Both of these contributions claim to do the same thing, i.e. make it easier to customize osCommerce. Can anyone advise which of the 2 is the best? Alternatively might it be better not to use the Contributions and instead just change the existing configuration? :blink: Thanking you in advance, Alec
  2. Hello All, Does a contribution exist that allows the administrator to generate a purchase order (that can be sent to a supplier) from an online order? example: 1) customer Joe Bloggs buys a widget for ?10.00 2) We recieve order 3) We login to oscommerce and generate a purchase order to our supplier Widget Ltd and buy the widget for ?5.00. 4) We then email purchase order and delivery note to Widget Ltd for delivery to customer. A contribution to this affect would reduce the need for us to re enter inormation into out customer relationship management system (Act! 2005) and order progress system (Quotrewerks).
  3. Hi People, All new categories created fail to populate the title, meta description and meta keywords, categories made some time ago are still populated. When looking at the source these section's are all blank. However when creating products it works as normal. This has only started happening recently and I dont know what I have changed to cauise this to happen. An example can be found here: http://www.voipon.co.uk/index.php?cPath=1_61 Could it be somthing i have adjusted in the admin section?? Any pointers would be much appreciated.
  4. Hello People Does any one know of a contribution that will autumatically remove the VAT charge when the customer enters a VAT number and resides within the EU as implemented within Locations / Tax -> Tax Zones?? Basically we charge VAT to all EU countries but we want a contribution that will remove the VAT charge is the customer provides us with a VAT number. Many thanks for any advice,
  5. AlecUK

    EU VAT Contribution???

    surerly there much be other oscommerce store owners within the EU that need to do this?
  6. AlecUK

    Protx VSP Direct - MS2.2 Support

    Hi Brian, Thanks for your response, i followed your instructions but it did not work...still getting 17.5% less of the VAT on the shipping :( Any other suggestions? I assume yours works ok then? Thanks,
  7. AlecUK

    Protx VSP Direct - MS2.2 Support

    Hello People, We have recently changed from using the "protx form" contribution to the "protx direct" contribution for oscommerce on our website here www.voipon.co.uk. The contribution in use is attached and can also be seen here: http://www.oscommerce.com/community/contri...ll/search,protx Protx direct has caused the following problem. The VAT of the shipping cost is not being sent to protx and hence not being charged to peoples credit cards. However, oscommerce is showing the charge to the custmer both onscreen and in the order email. Please see the following example: Products ------------------------------------------------------ 3 x Power over Ethernet Converter () = ?44.97 ------------------------------------------------------ Sub-Total: ?44.97 Express Deliveries (Shipping to GB): ?6.98 VAT 17.5%: ?9.09 Total: ?61.04 However when logging into VSP Admin, ?59.82 is being charged to the card and not the full ?61.04. This shows a difference of ?1.22 which is the equivelent to 17.5% of the shipping cost: 17.5 / 100 x 6.98 = 1.22 ?1.22 + ?59.82 = ?61.04 This is obviously causing us problems and lost revenue especially if the shipping costs are high. There is not that much code in the contribution and im sure someone with a programming background could spot the problem if they had a look at the data being fed to protx. Cheers
  8. AlecUK

    New UPS XML Shipping Module available

    Hi Janz, When i said "i tried that" i was referring that i chnaged the url you mentioned in your thread to the correct non test url. Does this make sense Cheers
  9. AlecUK

    Protx VSP Direct - MS2.2 Support

    just put the contribution in production mode and use a real card, then login to vspadmin and void the transaction :)
  10. AlecUK

    New UPS XML Shipping Module available

    Hi Janz, thanks for the update, i have tried that already with no difference :(
  11. AlecUK

    Protx VSP Direct - MS2.2 Support

    Hello, Found another problem with this script. It does not process the 17.5% vat on my shipping cost like the protx form did. It shows the customer the 17.5% and the order shows the 17.5% VAT but when u check your protx account it does not actually debit the 17.5% of the shipping charge which in my case is ?1.14 (my shipping cost is flat rate 6.50)? Any one else have this and know how to fix it? It also does not send the customer to the successful order page :(
  12. AlecUK

    Protx VSP Direct - MS2.2 Support

    Its very easy if u follow the instructions...15 / 20 minutes and there should be no downtime...
  13. surfalot...thanks for the feedback....i am getting this problem resolved...cheers
  14. AlecUK

    New UPS XML Shipping Module available

    No comments on the feedback i got from ups about the url is use being a test server? Is no one else having the same problems as me with incorrect values and not all the options being displayed?
  15. AlecUK

    New UPS XML Shipping Module available

    Hello, I have been troubleshooting this issue with UPS Online Tools UK and have had the following response: I do not understand why this is happening as my ups configuration is set to production mode However the UPS tech guys suggest im using the test server. Does this need fixing and if so how can i fix it? Thanks for your help.
  16. AlecUK

    Protx VSP Direct - MS2.2 Support

    Hi, when the payment is made the user is returned to the homepage? Can the script be modified so that when payment is made the user is directed to a successful order page??? Thanks,
  17. Surfalot, I did not personally install this contribution...are u suggesting that if the contribution was installed completerly that i would not have this problem? Can you direct me a bit more please to the specific part in install_catalog.txt that im missing? Any help would be much appreciated.
  18. AlecUK

    New UPS XML Shipping Module available

    So is the general consensus UPS online xml tools are inaccurate and buggy? Or can this application be improved, or is it a combination of both? I have noticed that in different circumstances 4 different shipping methods are retrieved but only 2 are displayed an also that the monetery values are different than what i get from the ups website. Does anyone else notice this? alec
  19. Hi, I have checked these files and have not found any reference to "Lets see what we have here" Any other suggestions? thanks for your time.
  20. Hello, Currently my store displays the word "Categories" when some one clicks on a category and "Lets see what we have here" when the product listing comes up. I want to replace "Categories" with the title I gave that page and I also want to do the same with "Lets see what we have here" For example at the following link I want to replace "Categories" with "VoIP IP Telephones" (title of page) http://www.voipon.co.uk/index.php?cPath=1 For example at the following link i want to replace "Let's See What We Have Here" with "Aastra IP Telephones" (title of page) http://www.voipon.co.uk/index.php?cPath=1_50 What changes do I have to make to the code to implement this? Thanks for your help.
  21. AlecUK

    New UPS XML Shipping Module available

    Hi Janz, have followed your advice. I am having trouble getting ups to output value for certain destinations. When i look in my debug i can see ups does respond with a value. However the ups module does not actually display the value on my website nor display any errors, it just displays the following: United Parcel Service (1 pkg x 0.5 kgs total) This is the response i get from my debug from ups: UPS RESPONSE: <?xml version="1.0"?><RatingServiceSelectionResponse><Response><TransactionReference><CustomerContext>Rating and Service</CustomerContext><XpciVersion>1.0001</XpciVersion></TransactionReference><ResponseStatusCode>1</ResponseStatusCode><ResponseStatusDescription>Success</ResponseStatusDescription></Response><RatedShipment><Service><Code>65</Code></Service><BillingWeight><UnitOfMeasurement><Code>KGS</Code></UnitOfMeasurement><Weight>1.0</Weight></BillingWeight><TransportationCharges><CurrencyCode>GBP</CurrencyCode><MonetaryValue>50.79</MonetaryValue></TransportationCharges><ServiceOptionsCharges><CurrencyCode>GBP</CurrencyCode><MonetaryValue>1.00</MonetaryValue></ServiceOptionsCharges><TotalCharges><CurrencyCode>GBP</CurrencyCode><MonetaryValue>51.79</MonetaryValue></TotalCharges><GuaranteedDaysToDelivery></GuaranteedDaysToDelivery><ScheduledDeliveryTime></ScheduledDeliveryTime><RatedPackage><TransportationCharges><CurrencyCode> </CurrencyCode><MonetaryValue> </MonetaryValue></TransportationCharges><ServiceOptionsCharges><CurrencyCode> </CurrencyCode><MonetaryValue> </MonetaryValue></ServiceOptionsCharges><TotalCharges><CurrencyCode> </CurrencyCode><MonetaryValue> </MonetaryValue></TotalCharges><Weight>1.0</Weight><BillingWeight><UnitOfMeasurement><Code> </Code></UnitOfMeasurement><Weight> </Weight></BillingWeight></RatedPackage></RatedShipment></RatingServiceSelectionResponse> This is example is for a shipment going out to malta. Also in the upsxml configuration it asks for the following: Origin State/Province Is this for the states only because i have left mine blank. Janz, just tested your dicount code edit and it works well....has reduced my ups charges by 30%...excellent!
  22. AlecUK

    New UPS XML Shipping Module available

    Many thanks Janz for your response, i also discovered that ie is not a good reader, however firefox works well. If I want to remove the ups na1 option from europe will commenting out the following line remove it from the UPS options or do i have to make a different modification: define('MODULE_SHIPPING_UPSXML_SERVICE_CODE_EU_ORIGIN_65', 'UPS Express NA1'); I guess I should blame UPS but I need to understand whats going on before i appraoch them. I think i need to do some more testing. Again thanks for your time and response,
  23. AlecUK

    New UPS XML Shipping Module available

    Hi Janz, Have not tried the discount yet but will let you know soon when i give ita go. Thanks for your suggestion! However the data the UPS is sending back to me is incorrect. I have provided all the details as per the contribution and my shop is in the UK. The ups module quite often returns UPS Express NA1 and this is only supposed to be for the states. Quite often it also does not provide me with all the options. I have contacted ups (uk) however they are very unhelpful and just suggest that it must be a buggy contribution. Has anyone else got this contribution working well in the UK? Or maybe its somthing i have done? I have also moved hosts recently and get errors when trying to view my debug log, please see below: The XML page cannot be displayed Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later. -------------------------------------------------------------------------------- Invalid at the top level of the document. Error processing resource 'http://www.voipon.co.uk/includes/modules/shipping/upsx... ------------------------------------------ ^ How can this be fixed? Thanks for any help, Alec
  24. AlecUK

    New UPS XML Shipping Module available

    Ooooops...sorry did some searching and can see that this quetion has been asked before. Janz....I can see you have picked out the snippet of code to adjust for dscount. If I wanted a blanket discount of 30% on all returned values how would the new code look?
  25. AlecUK

    New UPS XML Shipping Module available

    UPS XML and dscount Hello All, Have sucessfully installed the UPS xml shipping module but the UPS online tools do not account for the discount that is given to us. We get 30% discount off list pricing on all ups shipments. Is is possible to change the code so that all returned values have less 30% discount? This would make us more competitive in the market. Thanks.
×