Jump to content
Latest News: (loading..)

Studne00

Members
  • Content count

    19
  • Joined

  • Last visited

Everything posted by Studne00

  1. Studne00

    One Page Checkout Support

    In the new Firefox 8.0 version I'm getting some java script errors about updating the Cart and the Payment. I tried several version of OPC including 1.5 verision. i.e: There was an error refreshing the shopping cart, please inform (shop name) about this error.
  2. I find that the <link rel="canonical" href="http://www.example.com/canonical.html"/> should be only in duaplicate page (some info: http://www.google.com/support/webmasters/bin/answer.py?answer=139394). So I tried to install KissMT_Dynamic_Meta_Tags which also using rel="canonical", but the result is same. I still get <link rel="canonical" href="http://www.example.com/canonical.html"/> in every page, in the page without params including.
  3. Hello, I've just installed this great contrib, but I don't know if it's work correctly. The <link rel="canonical" href="http://www.example.com/canonical.html"/> is also visible in the code if I go right to the page without params (the canonical page) - http://www.example.com/canonical.html. Thank you for your comment. Petr
  4. Studne00

    One Page Checkout Support

    Hello. I have a problem with charset in the billing and the shipping address. My website and DB are using windows-1250 charset. I adjusted the checkout.php according to http://forums.oscommerce.com/topic/333292-one-page-checkout-support/page__st__1840__p__1532342#entry1532342. I made a little change. I replaced UTF-8 by "windows-1250" and "cp1250" in the checkout.php. It seems that works for most of the text, but not for the billing and the shipping address. You can see that in the picture. Please, does anybody know where and how to make more changes to show the characters correctly even if I'm using windows-1250 charset?
  5. Studne00

    Flat shipping doesn't show

    I've noticed that if I let the flat.php alone in the shipping modules saction in admin. I can see this module in checkout_shipping.php now, but there is still no fee for this shipping. In properly working module a value of the fee is displayed in the checkout_shipping.php. I see no value there. I really don't know what to do :-(
  6. Studne00

    Flat shipping doesn't show

    Hi, I don't know why, but flat shipping doesn't work. I can't see it in checkout_shipping.php. I tried to set it with blank tax class and shipping zone and also with assignment them in admin. Then I tried item shipping modul. In this case I see it as a payment module in checkout_shipping.php, but without a fee in checkout_confirmation.php even if there is adjusted the fee in admin. Please, can you help me with this problem? I'm hopeless at this.
  7. Studne00

    OSC-Affiliate

    As I said, I'm not good coder, but the code that I have added into general.php changes "&" in URL to "&" only, no more. I have done one more change. It depends on what language you're using in your store, let us say the ID of the language. In affiliate.sql are these 2 lines: INSERT INTO affiliate_payment_status VALUES (0, 1, 'Pending'); INSERT INTO affiliate_payment_status VALUES (1, 1, 'Paid'); The bold numbers are language ID. If you're using english in your store, it's probably without changes. It will be better if you'll check that. Get into your database and check the "languages" table. There you'll find what ID is used for your store language. The same ID insert to the "affiliate_payment_status table" table. My language has ID=4, so the change is: INSERT INTO affiliate_payment_status VALUES (0, 4, 'Pending'); INSERT INTO affiliate_payment_status VALUES (1, 4, 'Paid'); I'm working with 2.8 version + bug fixes from 12th Dec and 27th Dec.
  8. Studne00

    OSC-Affiliate

    I'm sorry. My english is not so good. What do you want to say by this? Thanks.
  9. Studne00

    OSC-Affiliate

    Hi marcgenou, yes, I do. However, I just found the solution of my problem :rolleyes: Problem was in URL with ultimate SEO url. In schopping_cart.php was URL with affiliate parameters: www.mysite.com/shopping_cart.php?ref=1&affiliate_banner_id=1. It is necessary the "&" to replace by "&". So I added this row $url = str_replace('&', '&', $url); into catalog/includes/function/general.php before header('Location: ' . $url); and it works for me. Now every order with affiliate link is recorded to the affiliate_sales table in the database.
  10. Studne00

    OSC-Affiliate

    I just tried 2.5a version + bug fixes that was recommended by Vger, but result is same. I also noticed that www.mysite.com/checkout_process.php giving me this warning: Warning: reset() [function.reset]: Passed variable is not an array or object in C:\www\www4\includes\classes\navigation_history.php on line 130 Warning: Variable passed to each() is not an array or object in C:\www\www4\includes\classes\navigation_history.php on line 131 Warning: reset() [function.reset]: Passed variable is not an array or object in C:\www\www4\includes\classes\navigation_history.php on line 130 Warning: Variable passed to each() is not an array or object in C:\www\www4\includes\classes\navigation_history.php on line 131 Warning: Cannot modify header information - headers already sent by (output started at C:\www\www4\includes\classes\navigation_history.php:130) in C:\www\www4\includes\functions\general.php on line 33 It should redirect me to login.php page instead of this warning. navigation_history.php on line 130: reset($parameters); navigation_history.php on line 131: while (list($key, $value) = each($parameters)) { Whole code: function filter_parameters($parameters) { $clean = array(); reset($parameters); while (list($key, $value) = each($parameters)) { if (strpos($key, '_nh-dns') < 1) { $clean[$key] = $value; } } return $clean; } general.php on line 33: header('Location: ' . $url); I guess that this problem makes no records in affiliate_sale table, because it's needed to have this code: require(DIR_WS_INCLUDES . 'affiliate_checkout_process.php'); in checkout_process.php. Could someone help to fix that, please. I'm not good in php. Thank you.
  11. Studne00

    OSC-Affiliate

    Check this step in installation. In application_top.php in the admin/includes directory enter at the end of the file before ?>: // Include OSC-AFFILIATE require(DIR_WS_INCLUDES . 'affiliate_application_top.php');
  12. Studne00

    OSC-Affiliate

    Have you tried any older version and works for you? Thanks.
  13. Studne00

    OSC-Affiliate

    I checked the database and in affiliate_sale table isn't any record. I don't know why :( Please, can you give me some advice how to solve it?
  14. Studne00

    OSC-Affiliate

    I have similar problem, but I don't see records even in admin/affiliates. When I tested it earlier on localhost, it worked. I only see the impresions and the clickthroughs now, they works (in admin and in catalog/affiliate_affiliate.php). Since the testing on localhost I installed several more contributions, for example: ultimate SEO url, unique order number, discount coupon etc.
  15. Hello, I have installed Price sensitive discount contribution http://addons.oscommerce.com/info/204. Also I'm using Purchase without account contrib http://addons.oscommerce.com/info/355. I need the discounts were active for registered customers only. Could you help me with that? Petr
  16. Studne00

    pdf invoices for admin only

    Nobody knows? Please.
  17. Studne00

    pdf invoices for admin only

    Hi. Thanks for the great contribution. It works fine. Does anybody know where to set encoding for Central Europe (cp1250)?
×