Latest News: (loading..)

mrgreg

Members
  • Content count

    31
  • Joined

  • Last visited

About mrgreg

  • Birthday 01/11/1961

Profile Information

  • Real Name
    Greg
  • Gender
    Male
  • Location
    Ft Lauderdale, FL
  1. LOL b. I feel your pain. All part of learning. Not alone in your troubles, perhaps you should share your cure so that those that happen along behind you will have less hair to loose. Half is a lot. Perhaps it will take that number down to a quarter ;)
  2. Hmmm... Silly question: Where exactly on your index page are the incorrect prices showing up? Inherently the source of these prices would be in boxes I think. Column presentations then would be drilled into via these boxes. Is it possible that what you are referring to on the index page is actually a box of sorts pulling stuff in, appearing as being 'the index' page? Perhaps you should post your index page here (for starters). Then perhaps better understanding and direction can be provided. Bear in mind, I am a noob. But perhaps myself or someone else will recognize a potential issue...
  3. Hi, I am guessing that the only change has been in your agitation level. Unfortunately that which can be offered on the MB has not changed I don't think. Did you compare the files on the site with those in the original package? At least some of the suspect files? The fact that it works for you in one or more places but not in others could indicate isolated edit issues. The add-on does work perfectly from the get go if installed properly... Is the store 1) Live. 2) modded beyond rolling back to an initial state (if your store is not heavily modded it might be better for you to copy over for SPPC)? I also noticed an installer posted today. IT IS NOT FOR MODDED STORES THOUGH... Greg
  4. "Someone need to look over the app for these issues." Sounds like you have already. How about sharing it in the contributions area? Speaking of which... We do (2) in town, one day events a week (same place), and (1) out of town, four day event a month (different places). The four day event is sporadically scheduled and knocks out one weekly event a month. Warehouse pick-ups are always welcomed but not a preferred or predominant means. I patched the 'drop down' event selector functionality and a store pick-up delivery option into my shipping choices so as to pass the event and date(s) through the entire order process. It is dynamically tied to the Events Calendar so as to eliminate duplication. Manage the calendar, event pick-up dates / locations stay managed as well. It is rough yet and requires a little polishing, but if anybody is interested I will focus on getting at least what I have posted. At least some instructions. I would like to tie it all together better, particularly getting the actual functionality of the drop down selector into the shipping module. It does all work though now. Also, if you are noticing that your events are not showing past midnight the day of, remove the time variables from the queries so that it looks something like this ... . " where start_date >= '" . date('Y-m-d') .
  5. "Module usps.php not working without configurations, mayby after correct configurationa all will working OK." Add-on seems to work fine over v2.2 RC 2a, however, it does not appear to work out of the box with USPS (usps.php ). Anybody tackle this yet?
  6. Hi Don, I am a noob myself- stumbling through the activities to get a site up for a friend... Having acknowledged that, here is what I might do (offered with no understanding of your environment). I can't re-create your issue and I use Authorize.net as well. ---> Assuming all is well and proper <--- , try this: 1. Make sure you are operating on the latest and greatest Authorize.net API. My particular flavor is here: http://addons.oscommerce.com/info/6562 Also, Authorize.net will only work over a secure (SSL) connection I think. 2. checkout_confirmation.php uses this: if (is_array($payment_modules->modules)) { $payment_modules->pre_confirmation_check(); You might try replacing the corresponding OnePage code with this just for a test. (onepage_checkout.php, lines 547, 548 I think) 3. Perhaps it is a $'GLOBALS' issue? http://addons.oscommerce.com/info/2097 See post by CMOTD dated 25 Sep 2007 4. In the future be aware of add-ons that are locked (no community input), buggy out of the box, and ultimately would require money to get them working. I have disabled the mod until I have time to iron out the wrinkles myself... At such time I will post those ironed wrinkles here. I do like the check-out presentation it offers. Regards, Greg
  7. Hi Don, I have a modded admin, but it should be under configuration... Did you make the proper ../admin mods and run the DB update (below)? INSERT INTO configuration_group (configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible) VALUES (7575, 'One Page Checkout', 'Settings for one page checkout', 16, 1); ALTER TABLE configuration CHANGE configuration_value configuration_value TEXT NOT NULL; INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Enable One Page Checkout', 'ONEPAGE_CHECKOUT_ENABLED', 'True', 'Enable one page checkout?', 7575, 1, NULL, now(), NULL, 'tep_cfg_select_option(array(\'False\',\'True\'),'); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Default Address Country', 'ONEPAGE_DEFAULT_COUNTRY', '223', 'Default country for new address and for checking out wihtout account', 7575, 2, NULL, now(), NULL, 'tep_cfg_pull_down_country_list('); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Account Creation', 'ONEPAGE_ACCOUNT_CREATE', 'false', 'if user does not enter password, do you want to auto-create their account and email password in order confirmation?', 7575, 3, NULL, now(), NULL, 'tep_cfg_select_option(array(\'true\', \'false\'),'); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Show Custom Right Column', 'ONEPAGE_SHOW_CUSTOM_COLUMN', 'true', 'Show custom right column', 7575, 4, NULL, now(), NULL, 'tep_cfg_select_option(array(\'true\',\'false\'),'); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Require Login', 'ONEPAGE_LOGIN_REQUIRED', 'false', 'Require customer to be logged in to proceed through checkout', 7575, 5, NULL, now(), NULL, 'tep_cfg_select_option(array(\'true\', \'false\'),'); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Show Oscommerce Columns', 'ONEPAGE_SHOW_OSC_COLUMNS', 'true', 'Show default oscommerce left and right columns', 7575, 6, NULL, now(), NULL, 'tep_cfg_select_option(array(\'true\',\'false\'),'); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Custom Colum Box #1 Heading', 'ONEPAGE_BOX_ONE_HEADING', '100% Private Secure SSL Transaction', 'Custom Colum Box #1 Heading', 7575, 15, NULL, now(), NULL, NULL); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Custom Colum Box #1 Content', 'ONEPAGE_BOX_ONE_CONTENT', 'Your shopping cart transaction is taking place on an encrypted SSL webpage, meaning it is secure and safe. We respect all of your private information and none of it will be shared with anyone in anyway.', 'Custom Colum Box #1 Content', 7575, 16, NULL, now(), NULL, 'tep_cfg_textarea('); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Custom Colum Box #2 Heading', 'ONEPAGE_BOX_TWO_HEADING', 'Ordering Information', 'Custom Colum Box #2 Heading', 7575, 17, NULL, now(), NULL, NULL); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (NULL, 'Custom Colum Box #2 Content', 'ONEPAGE_BOX_TWO_CONTENT', '<b>Processing Time</b><br>We will process your order as quickly as possible. Typical processing time for orders shipped ground is 1 – 2 days. For expedited shipping (2 day or overnight) we make every effort to ship the order the same day if ordered before 2pm.<br><br><b>Order Tracking</b><br>After your order is placed, you can login anytime 24/7 to view the status of your order. When your order is shipped, you will receive a shipment notification with a tracking number.', 'Custom Colum Box #2 Content', 7575, 18, NULL, now(), NULL, 'tep_cfg_textarea(');
  8. Hi Johnny and All- Have just installed this mod and observed the same behavior. Customer name is not showing up in the orders table. Likewise in the order detail view. Additionally, the telephone number and email address are not present either. Has anybody addressed this issue? Oscommerce supports the scenario in which "Customer details", "Shipping details", and "Billing details" can be three separate entities (an issue in itself). My assumption is that this was an oversight by Itexperts (the author)...
  9. Hi Victor, I had both problems with both versions myself. Emphasis on "I"... 1) The server info (test server) and API from USPS was different than that in v3~. Plus I was waiting for the production access. While waiting, I decided to go to v4~. 2) In my haste I missed an edit. Fixed. I phoned USPS and was granted access to the production server. All is well now.
  10. You may wish to use something like WinMerge (http://sourceforge.net/project/showfiles.php?group_id=13216) to compare what is on your site and what was initially distributed in the package. Sounds like you may have missed or otherwise botched an edit. The posts on the previous page address this. Try starting with ../catalog/index.php. Beyond that. look to the core file mods... Greg
  11. Brollox appears to be trying to get up and running period. Not sure his issue is just the 'index page' or any other form of selective price reflection... I am also not sure why you would want to reflect group prices in one place and not in another, but if you have basic, core functionality then selecting where to show pricing is simply a matter of enabling such in the appropriate files. Again though, are you certain that is what you are really trying to accomplish? What about specials. new products, product listing, etc? I am simply curriuos... I have added things that required me to 1) initially disable showing prices. Or 2) coded for SPPC appropriately. Not sure there other choices when all is said and done. The PHP Noob, Greg
  12. B, I am a novice myself... If that posted is /catalog/index you would be missing some edits I think. I would also add (or repeat Jan's point) that there are numerous edits in numorous (many) files. 6 total in catalog/index alone... I see 4 in your code. Look above that which you posted for starters. Hope that points you in the right direction- Greg
  13. Perhaps Jan's advice to peek at application_top.php can help? Namely the redirect... // performed by the 'buy now' button in product listings case 'buy_now' : if (isset($HTTP_GET_VARS['products_id'])) { if (tep_has_product_attributes($HTTP_GET_VARS['products_id'])) { tep_redirect(tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $HTTP_GET_VARS['products_id'])); } else { $cart->add_cart($HTTP_GET_VARS['products_id'], $cart->get_quantity($HTTP_GET_VARS['products_id'])+$_POST[list_quantity]); } } tep_redirect(tep_href_link($goto, tep_get_all_get_params($parameters))); break;
  14. Hi Jan, Yes, you hit it- well kind of. It does boil down to a brain fart on my part for certain. Of course I might have mentioned my use of 'quantity' boxes initially... I had modified application_top.php to support quantity boxes (the 'else' of the attributes 'if' for the other readers). I also re-activated product reviews tonight- that one was quick and easy to diagnose and fix on the heels of new products. ...The pain us noobs bring on ourselves. Now, where did I read this? "Note- Even simple cut & paste editing of files requires a certain degree of understanding and focus..." Oops Thanks for the help!
  15. Hi all... I have decided to use a 'What's New' box and recall reading in this thread an issue in which the the cart would not update as expected from products_new.php. E.g. hit <add to cart> and the page behaves as expected except that nothing is added to the cart. This code: <td align="right" valign="middle" class="main"><?php echo '<a href="' . tep_href_link(FILENAME_PRODUCTS_NEW, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $products_new[$x]['products_id']) . '">' . tep_image_button('button_in_cart.gif', IMAGE_BUTTON_IN_CART) . '</a>'; ?></td> Generates this link (it's a local dev site): http://localhost/Speed%20Demon/products_ne...561d7c84b254006 This is the only page that exhibits this behavior... Am I brain farting here? :blink: Any ideas or clues? Thanks, Greg