Jump to content

Thare

Members
  • Content count

    15
  • Joined

  • Last visited

Profile Information

  • Real Name
    Terry
  • Gender
    Male
  1. Thare

    SiteMonitor

    I know how 2 find my way around install and tweak a few things but I know nothing about code :'( Thanks Jack for your help and this great contribution. I searched the entire Topic for help and it appears that the original Warning: array_merge() [function.array-merge] error has not yet been resolved. The patch/s given to fix the original error simply created other unrelated error/s causing further confusion instead of actually fixing the original error. :blink: Eye suspect many who have Site Monitor installed are simply overlooking the issue and have said nothing or they have // CLOSED // line 66 or removed it.
  2. Thare

    SiteMonitor

    I examined all image folders including the shop images on that installation. They all contained images only. I have today freshly reinstalled osCommerce and the only application currently loaded on it is Site Monitor. I am now back with the original error messages at Site Monitor Admin. Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/Mysite/public_html/admin/sitemonitor_admin.php on line 66 Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/Mysite/public_html/admin/sitemonitor_admin.php on line 66 It would be great to solve this one so I will not install any more for now.
  3. Thare

    SiteMonitor

    Only have installed the basic security Appz so my installation is more or less a default installation. I searched all /images/ folders for non image files. The results I got are :-> public_html/admin/images/.htaccess public_html/admin/images/graphs/dummy public_html/admin/includes/javascript/spiffyCal/images/spiffcal.cur public_html/admin/includes/javascript/spiffyCal/images/spiffcal2.cur public_html/admin/includes/javascript/spiffyCal/images/spiffcal3.cur public_html/admin/includes/languages/images/buttons/Thumbs.db There are no php files only image files in the folders.
  4. Thare

    SiteMonitor

    I removed and step by step reinstalled but still got the original Error Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /location/sitemonitor_admin.php on line 66 Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /location/sitemonitor_admin.php on line 66 I tried the last two code fixes again $a1 = glob(DIR_FS_CATALOG . DIR_WS_IMAGES . '*.php'); $a2 = glob(DIR_FS_CATALOG . DIR_WS_IMAGES . '*.txt'); $invalidFiles = array_merge($a1, (array)$a2); Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/Mysite/public_html/admin/sitemonitor_admin.php on line 68 $a1 = glob(DIR_FS_CATALOG . DIR_WS_IMAGES . '*.php'); $a2 = glob(DIR_FS_CATALOG . DIR_WS_IMAGES . '*.txt'); $invalidFiles = array_merge((array)$a1, (array)$a2); WARNING: Your images directory contains non-image type files which is, generally, not correct. The php used here is V5.2.14 is this OK ? I will keep trying to get Site Monitor running correctly because even on this new installation I have had "Hackers" knocking on the front door allready trying to get in to install :angry: and I would like to prevent them and protect my site as best I can.
  5. Thare

    SiteMonitor

    Jack here is the html of the error <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr class="messageStackError"> <td class="messageStackError"><img src="images/icons/error.gif" border="0" alt="Error" title=" Error " /> ERROR_IMAGES_HAS_PHP</td>IMAGES_HAS_PHP</td> </tr> <tr class="messageStackError"> <td class="messageStackError"><img src="images/icons/error.gif" border="0" alt="Error" title=" Error " /> </td> </tr> <tr class="messageStackError"> <td class="messageStackError"><img src="images/icons/error.gif" border="0" alt="Error" title=" Error " /> </td> </tr> </table>
  6. Thare

    SiteMonitor

    Sorry for the confusion. The #1234567890 on the right hand side of your name is what I was referring to as the forum article which is also called the Posted Topic? http://forums.oscommerce.com/index.php?showtopic=221438&view=findpost&p=1563468 Error.gif ERROR_IMAGES_HAS_PHP Error.gif Error.gif When I goto admin in osCommerce and click on admin in Site Monitor The Error exactly as shown above is displayed above the osCommerce logo in Administration. The three error words on the left come from /images/icons/error.gif I am not sure if any of that makes any sense but thats the exact result I am receiving.
  7. Thare

    SiteMonitor

    Changed that as directed above Jack and it now shows the same error received from using article #1567836 Error ERROR_IMAGES_HAS_PHP Error Error Error is on color background
  8. Thare

    SiteMonitor

    Hi Jack Thanks for your valued contributions absolutely fantastic and much appreciated. I changed the line as suggested above and the result at osCommerce admin is now-> Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/MYSITE/public_html/xyz_admin/sitemonitor_admin.php on line 66 So the new code killed two of infamous warnings from line 66 and replaced them with the one above. I know how 2 find my way around install and tweak a few things but I know nothing about code :'(
  9. Thare

    SiteMonitor

    Some help please with this would be appreciated Eye repaired these ERRORs With the suggested FIX in article #1567836 -> Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /location/sitemonitor_admin.php on line 66 Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /location/sitemonitor_admin.php on line 66 With the suggested FIX in article #1567836 to repair sitemonitor_admin.php at line 69 with $invalidFiles = array_merge((array)glob(DIR_FS_CATALOG . DIR_WS_IMAGES . '*.php'),(array)glob(DIR_FS_CATALOG . DIR_WS_IMAGES . '*.txt')); At Site_Monitor > ADMIN I now have: Error ERROR_IMAGES_HAS_PHP Error Error Any ideas please :'(
×