Rebellion1986

Members
  • Content count

    42
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About Rebellion1986

Profile Information

  • Real Name
    NM
  1. It seems that this hasn't resolved the problem on my website, It was working correctly for a few days but it seems the error has came back, any suggestions?
  2. OK! it seems this error has started to come back regardless of SEO URLS switched on or off! any sugesstions?
  3. Thank you FWR Media. what else would need modifying? this would be very helpful to those who would use these type of payment checkouts. I have enabled the SEO URLS module and set [Output W3C valid URLs (parameter string)? False] Is this correct? Also is there anyway in leaving the cart intact while the rest of the website has SEO URLS enabled? Regards, Rebellion.
  4. I have resolved this issue on my website please read you may have the same problem. AH! I finally resolved the problem! SEO URL's is incompatible with this module. I checked the URL before I checked out and I saw that the redirected URL was different to the outgoing URL. SEO URLs must modify the URL all the time, this is why most of my customers were redirected to another page! If anyone is presented with the 5006 error and they have SEO URLs Installed, you may want to uninstall the module and test again. This means bad for my SEO as some of my pages have google page rank 1, so I will have to try and see if the new update of SEO URLs is compatible with this module, thanks anyway for the help!
  5. AH! I finally resolved the problem! SEO URL's is incompatible with this module. I checked the URL before I checked out and I saw that the redirected URL was different to the outgoing URL. SEO URLs must modify the URL all the time, this is why most of my customers were redirected to another page! If anyone is presented with the 5006 error and they have SEO URLs Installed, you may want to uninstall the module and test again. This means bad for my SEO as some of my pages have google page rank 1, so I will have to try and see if the new update of SEO URLs is compatible with this module, thanks anyway for the help!
  6. I purchased a SSL certificate while I had this problem with my sagepay form hoping the server module would resolve the redirection URL error unfortunately it did not. I resolved the 5999 error by reinstalling the server module however even by using the iframe module i still get the 5006 module.
  7. Hello Tigergirl, Normal gives me this error code: HTTP Status Code: 500 HTTP Status Message: The request was unsuccessful due to an unexpected condition encountered by the server. Error Code : 5006 Error Description : Unable to redirect to Vendor's web site. The Vendor failed to provide a RedirectionURL. Low give me this error code: HTTP Status Code: 408 HTTP Status Message: The client failed to send a request in the time allowed by the server. Error Code : 5999 Error Description : The Session is invalid or has expired. The form module works but like i said some customers keep getting redirected to the "please try again" checkout confirmation page. The transaction goes through successfully, we both receive confirmation emails, but so many people keep retrying their cards that i have to refund 5+ transactions a day! furthermore I have to send emails or phone customers to tell them about this problem.
  8. Hello Tigergirl, I have tried the changes you suggested, but they make no effect, its still having the ! next to the SSL symbol. If i set the Sagepay server to low then I get this error: HTTP Status Code: 408 HTTP Status Message: The client failed to send a request in the time allowed by the server. Error Code : 5999 Error Description : The Session is invalid or has expired.
  9. I am now getting a new error Bah, one error after another! HTTP Status Code: 500 HTTP Status Message: The request was unsuccessful due to an unexpected condition encountered by the server. Error Code : 5006 Error Description : Unable to redirect to Vendor's web site. The Vendor failed to provide a RedirectionURL.
  10. Hello tigergirl, I didn't use those instructions, I basically logged into my hosting and copied my dedicated IP address to my (Valid IP Addresses for this Account) Sage-pay account. It now allows me to checkout using Sage-pay server do I still have to contact sage-pay to notify them about my new dedicated IP?
  11. Sagepay Form; I am sure that the www. is necessary. Sagepay Server: The error is concerning the Static IP address you had a similar problem that you mentioned in an earlier post but I dont know how you resolved the issue, apologies it was error 4020.
  12. <?php define('HTTP_SERVER', 'http://www.just-herbs.co.uk'); define('HTTPS_SERVER', 'https://www.just-herbs.co.uk'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', 'www.just-herbs.co.uk'); define('HTTPS_COOKIE_DOMAIN', 'www.just-herbs.co.uk'); define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); define('DIR_WS_HTTP_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', 'Location/html/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DB_SERVER', ''); define('DB_SERVER_USERNAME', ''); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', ''); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'mysql'); ?> If I use sagepay server contribution i get the 4220 error, I hear that you resolved this problem, I purchased a dedicated IP for this but I am still experiencing the issue.
  13. Thanks, I modified the SSL (https wasn't input) although Sage-pay Form does not require SSL. Since last week I have reinstalled a fresh copy of OSCOMMERCE on WAMP copied all the cart files over to my live store and I am still experiencing the same problem. Most customers are taken to checkoutconfirm.php after they have purchased an item and they are provided with an error; there was a problem with there order please try another card (which they then do). We both receive an email notifying that the transaction has been successful. The Sage-pay unique reference ID is shown like: 20091115133740-156- there are digits missing, the reference number should look like 20091114053407-155-42997. The orders with the Reference ID missing are not displaying when logging into my admin section. This is really driving my patience up the wall as I have literally revamped my checkout process to stock layout and I am still getting problems. Sage-pay are no help because they are basically saying that its my success URL although some people are taken the the success page (the orders with the full reference ID) but most are taken back to checkoutconfirm.php. If I dont get this resolved soon I am going to switch to pay-point. Any additional help will be greatly appreciated. Kind Regards.
  14. Hello guys, I am experiencing a problem when integrating OPC. Fatal error: Call to a member function pre_confirmation_check() on a non-object in user/html/includes/classes/onepage_checkout.php on line 644 Please help out. Regards, Rebellion.
  15. Can anyone help? I have to refund so many transactions everyday for a week now, and have contacted every customer to inform them of the problems. I have also confirmed that they are receiving a success email. The scenario basically goes like this: -Customer adds products to basket and continues to checkout. -Goes to the sagepay form and input their details (Details are passed to checkout). -Once entered the user hits confirm and are taking to checkout_confirmation.php where they are notified that the order has been unsuccessful. -Both the customer and myself recieve a sucessful transactions and this is verified by loggin into sagepay. I have the 4 Page checkout module installed although I cannot find this module on contributions to uninstall it. Unfortunately I cannot find my backup! so I am kicking myself for that, although I doubt that this is the problem. I just purchased a SSL Certificate to allow me to use SAGE PAY Direct and I have more problems. Firstly I was receiving errors which was due to the Anti-XSS contributions (you are not suppose to be here, go away). So I uninstalled this add-on and after inputting my credit details I am always taken to Checkout_Confirmation.php error page, this is for all cards tested. Can someone please help me out. Regards. Rebellion.