Jump to content

VeganKalle

Members
  • Content count

    4
  • Joined

  • Last visited

  1. VeganKalle

    Ajax Buy Now

    It's even worse than before. I just noticed that the "new" version doesn't work in IE either, whereas the old one did. Is anyone able to help me get this working again? My sales have gone down remarkably, so I disabled the ajax shopping cart for now which is annoying for customers with other browsers who are used to the convenience of not scrolling all the way down after adding a product to the shopping cart.
  2. VeganKalle

    Ajax Buy Now

    Hi, unfortunately the new ajax_sc.js file doesn't work either. Where the old one didn't put anything in the cart but only displayed the "working"-icon, the new one adds to the cart (you can see the added product after reloading the page) but still only shows the "working"-icon. So it seems that there is nothing coming back to tell it the adding of the product was successful. I am a total noob regarding ajax and javascript in general so debugging the whole thing would take ages for me. Did someone have similar problems with this new version and FF4 and was able to fix it? Thanks in advance, Kalle
  3. VeganKalle

    [CONTRIBUTION] CCGV (trad)

    Something more regarding the non-display of the order totals. If I activate order_total_modules->process(); in the codeblock below then I get totals displayed. But is this correct? if (MODULE_ORDER_TOTAL_INSTALLED) { //$order_total_modules->process(); echo $order_total_modules->output(); } Kalle
  4. VeganKalle

    [CONTRIBUTION] CCGV (trad)

    Hello, I just installed the latest version of CCGV(trad) (November 16th 2008) and face two problems right now (using osC 2.2 RC2a): In checkout_confirmation.php I don't get the order totals displayed. I think this must have something to do with the repositioned lines but I can't find the problem. When I try to submit the order - ignoring that there are no order totals displayed and no matter whether I want to redeem a voucher or not - I get thrown back to checkout_payment.php with the message that I didn't choose a payment method. That is because in these lines // Line edited for CCGV if ( (is_array($payment_modules->modules)) && (sizeof($payment_modules->modules) > 1) && (!is_object($$payment)) && (!$credit_covers) ) { tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL')); } the two conditions (!is_object($$payment)) && (!$credit_covers) are always opposite to each other, even though I think the code is logically correct I don't understand why the two conditions have the values they have. If someone needs more information to help me solve my problem, then please tell me what you need to know. Thanks in advance. Kalle EDIT: Fixed some typos.
×