Latest News: (loading..)

SRU Computers

Members
  • Content count

    22
  • Joined

  • Last visited

About SRU Computers

Profile Information

  • Real Name
    Steve McDermott
  1. I have an install problem in catalog/admin/categories.php I have already installed the 'categories images box' mod & I'm now getting a syntax error when I try to enter the catalog section in my site admin - error is Parse error: syntax error, unexpected ',' in /catalog/admin/categories.php on line 84 Code changes for the 'categories images mod' are: // Start Categories images box $categories_description_front_array = $_POST['categories_description_front']; $sql_data_array = array ('categories_name' => tep_db_prepare_input ($categories_name_array[$language_id] ), 'categories_description_front' => tep_db_prepare_input ($categories_description_front_array[$language_id] ) ); // End Categories images box Code changes required for 'Header tags SEO mod' are: FIND (around line 72) $sql_data_array = array('categories_name' => tep_db_prepare_input($categories_name_array[$language_id])); REPLACE with /*** Begin Header Tags SEO ***/ $sql_data_array = array('categories_name' => tep_db_prepare_input($categories_name_array[$language_id]), 'categories_htc_title_tag' => (tep_not_null($categories_htc_title_array[$language_id]) ? tep_db_prepare_input($categories_htc_title_array[$language_id]) : tep_db_prepare_input($categories_name_array[$language_id])), 'categories_htc_desc_tag' => (tep_not_null($categories_htc_desc_array[$language_id]) ? tep_db_prepare_input($categories_htc_desc_array[$language_id]) : tep_db_prepare_input($categories_name_array[$language_id])), 'categories_htc_keywords_tag' => (tep_not_null($categories_htc_keywords_array[$language_id]) ? tep_db_prepare_input($categories_htc_keywords_array[$language_id]) : tep_db_prepare_input($categories_name_array[$language_id])), 'categories_htc_description' => tep_db_prepare_input($categories_htc_description_array[$language_id])); /*** End Header Tags SEO ***/ How should I combine these? I've tried various ways of doing this & the best that I can figure out is: $categories_description_front_array = $_POST['categories_description_front']; $sql_data_array = array ('categories_name' => tep_db_prepare_input($categories_name_array[$language_id]), 'categories_description_front' => tep_db_prepare_input($categories_description_front_array[$language_id])), 'categories_htc_title_tag' => (tep_not_null($categories_htc_title_array[$language_id]) ? tep_db_prepare_input($categories_htc_title_array[$language_id]) : tep_db_prepare_input($categories_name_array[$language_id])), 'categories_htc_desc_tag' => (tep_not_null($categories_htc_desc_array[$language_id]) ? tep_db_prepare_input($categories_htc_desc_array[$language_id]) : tep_db_prepare_input($categories_name_array[$language_id])), 'categories_htc_keywords_tag' => (tep_not_null($categories_htc_keywords_array[$language_id]) ? tep_db_prepare_input($categories_htc_keywords_array[$language_id]) : tep_db_prepare_input($categories_name_array[$language_id])), 'categories_htc_description' => tep_db_prepare_input($categories_htc_description_array[$language_id])); Line 84 is this one: 'categories_description_front' => tep_db_prepare_input($categories_description_front_array[$language_id])), Can anybody help?
  2. I have just installed this mod (v2.1.0) on OSCommerce 2.2 RC2a & it works exactly as it should. Many thanks for your work on this Todd. ;)
  3. After giving this problem some thought - the reason for this mod not working on 'v2.2 RC2a' is that I uploaded the pre-modified files that are included with the download. The mod is dated 2005 & the pre-modified files would have been intended for an earlier version of OSCommerce. I have tried manually installing this mod, copying & pasting from the instruction file included with the download. I can now access my site again & subject to successful testing, I'll upload a new version of this mod.
  4. I can't find a support thread for this mod. I have just installed 'Shipping Address Match v1.0' http://addons.oscommerce.com/info/3169 My site's mainpage now displays FATAL ERROR: register_globals is disabled in php.ini, please enable it! Where is my php.ini file & will enabling register_globals cause any problems (security, etc) ? FYI: I'm using OSCommerce v2.2 RC2a My server is using PHP version 5.2.6, MySql version 5.0.67 & Apache version 2.2.9
  5. Excellent thought Les - I've just spent the last 3 days trying to work out why my menu's wouldn't work, then I discovered your post from 2 years ago!