Jump to content

ccakes

Members
  • Content count

    23
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Cathy
  1. Hi - Hoping someone knows of a contribution that lets the clients once logged in with a product ordered, upload a file that automatically renames the file according to the order number onto our server. We supply prints of images, and we need clients to upload their images at time of ordering. Currently we have them replying to our order confirmation emails. Any suggestions would be great. Thanks.
  2. ccakes

    QBI Quickbooks Import

    REGISTER GLOBALS DISABLED My host has register global (variables) disabled therefore I was wondering if anyone knew if this would have an effect on the QBI contribution. I have installed it, it seems without any trouble. However when I attempt tp set up the qbi export it simply keeps refreshing itself. If you hit the other tabs in the qbi screen again it simply just refreshes. I have searched the forums but alas, to no avail. Any ideas? Thanks in advance.
  3. Hi Joe Applied your fix, still getting the 2x entry on coupon. Would you be able to post your ot_coupon.php, as the one I used from the current version is a bloodbath of comment outs and still not fixing the issue. Thanks in advance. Cathy
  4. Hi There My host has register global (variables) disabled therefore I was wondering if anyone knew if this would have an effect on the QBI contribution. I have installed it, it seems without any trouble. However when I attempt tp set up the qbi export it simply keeps refreshing itself. If you hit the other tabs in the qbi screen again it simply just refreshes. I have searched the forums but alas, to no avail. Any ideas? Thanks in advance.
  5. http://forums.oscommerce.com/index.php?sho...43entry733943 This has the answer, worked for me and I have reg globals disabled. Hope it helps.
  6. It makes me feel a load better. I am going nutts. I have these contributions installed - -ship date -CVV(which doesnt work now as gobals have been turned off on my server) -EFT payment contribution -Cash on Delivery module is active. These are the only one's that I think affect the processing payment. Do you have any of the above installed? Are register globals on your server turned on or off? My site is quite modified - but can't see how the other mod's could affect the payment process. Appreciate your reponse, it may help me work out why this is happening if anything. Cheers, Cathy
  7. I am back again because this bugger of thing is doing silly things. So I can keep helping you, but no-one can help me :( In your admin/modules/order_total in your admin panel, make sure you have you have your sort orders set to the followoing: Discount Coupons 9 Gift Vouchers 740 Low Order Fee Shipping 3 Sub-Total 1 Tax 2 Then you will see a little - thing come up in your coupon/gift voucher box on your payments_ which says'tick to use gift voucher balance amount' - you then tick it and it applies the gift voucher to the total. It's all bout the sort orders. Can you let me know if your coupons are working. I am finding i have to enter the coupon code twice for it to register in the shopping cart box to the right. No-one seems to be able to help me - and I am seriously lacking in php knowledge to mess with _POST vars. Cheers,
  8. Wondering if anyone can help! I have used contribution and after debugging all the nasties that came with the latest compile - I have got it all working - except - When one enters a coupon code - it says "congrats you have redeemed" on top - however it doesn't redeem. You have to enter it again and then it redeems. Redeem code has to be entered twice at checkout_payment stage for it to register. Then the coupon in the shopping cart box appears and you know its finally worked. Would this have to do with my db settings/or admin settings on coupons. Any help would be greatly appreciated!!! I am really under the pump to make sure it works. Cheers,
  9. The code is repeated in both files - previously declared. Delete the following out of your general.php and then you will find it wont repeat. I think it has happened because so many people are working on the contribution and are doing a bit of doubling up. You will find the same error happening in your admin as well. // Create a Coupon Code. length may be between 1 and 16 Characters // $salt needs some thought. function create_coupon_code($salt="secret", $length = SECURITY_CODE_LENGTH) { $ccid = md5(uniqid("","salt")); $ccid .= md5(uniqid("","salt")); $ccid .= md5(uniqid("","salt")); $ccid .= md5(uniqid("","salt")); srand((double)microtime()*1000000); // seed the random number generator $random_start = @rand(0, (128-$length)); $good_result = 0; while ($good_result == 0) { $id1=substr($ccid, $random_start,$length); $query = tep_db_query("select coupon_code from " . TABLE_COUPONS . " where coupon_code = '" . $id1 . "'"); if (tep_db_num_rows($query) == 0) $good_result = 1; } return $id1; } //// // Update the Customers GV account function tep_gv_account_update($customer_id, $gv_id) { $customer_gv_query = tep_db_query("select amount from " . TABLE_COUPON_GV_CUSTOMER . " where customer_id = '" . $customer_id . "'"); $coupon_gv_query = tep_db_query("select coupon_amount from " . TABLE_COUPONS . " where coupon_id = '" . $gv_id . "'"); $coupon_gv = tep_db_fetch_array($coupon_gv_query); if (tep_db_num_rows($customer_gv_query) > 0) { $customer_gv = tep_db_fetch_array($customer_gv_query); $new_gv_amount = $customer_gv['amount'] + $coupon_gv['coupon_amount']; // new code bugfix $gv_query = tep_db_query("update " . TABLE_COUPON_GV_CUSTOMER . " set amount = '" . $new_gv_amount . "' where customer_id = '" . $customer_id . "'"); // original code $gv_query = tep_db_query("update " . TABLE_COUPON_GV_CUSTOMER . " set amount = '" . $new_gv_amount . "'"); } else { $gv_query = tep_db_query("insert into " . TABLE_COUPON_GV_CUSTOMER . " (customer_id, amount) values ('" . $customer_id . "', '" . $coupon_gv['coupon_amount'] . "')"); } } //// // Get tax rate from tax description function tep_get_tax_rate_from_desc($tax_desc) { $tax_query = tep_db_query("select tax_rate from " . TABLE_TAX_RATES . " where tax_description = '" . $tax_desc . "'"); $tax = tep_db_fetch_array($tax_query); return $tax['tax_rate']; } Just make sure you delete out the repeated code in the general.php only. Hope this helps.
  10. ccakes

    Register Globals Support

    I am getting the same issue. I am running the debuggin in application_top that the contributions suggests for the contribution and getting this answer: ---------- GET goto -> '/home/mysite/public_html/catalog//images' But because I havent fixed any of my contributions I am not quite confident in adjusting the GET variables on the page??? Anyones help would be appreciated.
×