Jump to content

westerngecko

Members
  • Content count

    13
  • Joined

  • Last visited

Profile Information

  • Real Name
    Steve Raffaele
  1. westerngecko

    SiteMonitor

    Odd, I'm not doing anything out of the ordinary with this contrib? I've implemented most of the changes as per the sticky "Secure your site" thread so maybe this contrib is conflicting with another security change. I'm also getting duplicate log entries for every scan. Anyone else getting duplicate emails?
  2. westerngecko

    SiteMonitor

    I was having a few problems with this contrib that I would like to share. I think I was having the same problem as westindiestrader back in October. I was getting “Failed to open file sitemonitor_reference.php” when I clicked on the Delete Reference File “update” button. I've gone through a number of security processes and contribs prior to loading this contrib and I think the locking down of my admin directory had a lot to do with the problems I was having... I had to chmod my admin folder, sitemonitor_log.txt and sitemonitor_configure.php to 0777 before I could get the contrib to work. I had locked and renamed my admin folder for obvious reasons but the contrib seemed to be able to detect the new admin folder and had it set correct in the Admin screen. I've since gone back and re-secured my admin folder and the contrib seems to continue to work OK. I’ll know better once things stabilize and I make more changes to my store. I hope this helps someone in the future... I’m also having the two emails and duplicate log entry problem mentioned above... Anyone?
  3. 35.0 cm x 25.0 cm x 8.0 cm These are the (LxWxH) dimensions of a box I have entered into the Canada Post "Add / Modify / Delete Boxes" screen under my Canada Post "Sell Online" account. http://sellonline.canadapost.ca/servlet/MerchantBoxServlet I'm not sure if you call this the frontend or the backend part? When I look inside the mod I'm not seeing where the item sizes are being added up. I see it looping through the items and building the quote for CP. I then see the return result looping for each package and constructing the list of packages on the check out page. CP must be doing the shipping calculation? I have never seen more than one box in my shipping calculation even when I tell the mod to ship two products with "Ship Item in it's original box." selected? It always seems to pick the smallest box I have in the "Add / Modify / Delete Boxes" screen.
  4. I don't know if this is related but I've been using this mod for almost a year and my needs have been very simple. I've been shipping small items in envelopes and I've noticed that sometimes the mod would not detect that a larger size of envelope was required. It wasn't a big deal as the shipping cost was very similar. Recently, I've added some larger size items to my store and now I'm finding that the calculation for what size box/envelope to use it totally out to lunch. I have an item that is 0.30 kg, 40.00 cm x 25.00 cm x 20.00 cm and the mod is telling me that it can fit the product into an envelope that has a capacity of 1.000 kg and dimensions of 35.0 cm x 25.0 cm x 8.0 cm? If I tell the cart to double the order to a quantity of 2 neither the total weight or the shipping container changes. Here is what happens when I change the qty's... item = 0.30 kg, 40.00 cm x 25.00 cm x 20.00 cm qty 1 = envelope, total weight = 1.16 kg WRONG S/B using my 41.0 cm x 31.0 cm x 21.0 cm box qty 2 = envelope, total weight = 1.16 kg WRONG S/B using 2 of my 41.0 cm x 31.0 cm x 21.0 cm boxs qty 3 = envelope, total weight = 1.16 kg WRONG S/B using 3 of my 41.0 cm x 31.0 cm x 21.0 cm boxs qty 4 = envelope, total weight = 1.16 kg WRONG S/B using 4 of my 41.0 cm x 31.0 cm x 21.0 cm boxs qty 5 = box (30.0 cm x 24.0 cm 20.0 cm), total weight = 2.4 kg STILL WRONG and now it's using my small box I'm finding this extemrly frustrating as this is just one of the many products I'm having problems with. I'm at the point where I'm considering other cart systems that allow me to intercept an order and calculate the shipping manually. I use PayPal for payments and I'm wondering if there is a way to HOLD an osCommerce order until I have a chance to manually calculate the shipping and add it to the order? Anyone?? Thanks, Steve Western Gecko My Store
  5. Does it use the same login information I've entered in the module to get the actual shipping amount and box size? This is working OK... When I manually log into... http://sellonline.canadapost.ca/servlet/LogonServlet I usually copy and paste my login credentials from the osCommerce CP Module screen so I'm pretty sure they're correct in the module.
  6. I checked with my host and port 30000 is open. I have no idea why the Label part of this contrib is not working? Anyone?? Don't make me go in there as I know enough about php to be dangerous! BTW, I'm using 2.2.1/4.1...
  7. Yes, that's the way the contrib works without the Label Module. The Label Module is the one that allows you to pay online and generate a label to attach to the package for shipping. At least this is the way I think it works as I have not been able to get the Label part working. The base of the contrib will calc the CP postal cost and put it on the customers order. You can choose to ship via a different method if you like.
  8. I'm using the Canada Post 2.0/4.0 module to calculate shipping with Canada Post and it seems to be working OK to calc the shipping amounts but the labels don't seem to be working. I get the following error message when clicking the submitt button on the "Canada Post Automated Labels" screen... Step 2. Error: Failed check in /home/.sites/147/site57/web/catalog/admin/includes/languages/english/ship_canadapost.php at line 9. This most likely means that Canada Post has changed their user interface. You need to update your Canada Post Automatic Shipping Labels module. In reading this thread it looks like most of these issues involve the version of libcurl and compiling with ssh2. I've had my host fix this up fopr me but I'm still getting the same error message. Here is how my cURL is setup... cURL Information = libcurl/7.18.2 OpenSSL/0.9.7a zlib/1.2.1.2 libidn/0.5.6 libssh2/0.17 The "Canada Post Automated Labels" screen doesn't seem to be showing the proper information for the shipment. "Total Items Weight" = 0.000 with the comment "Change this to the Total Package Weight." The package dimensions are also wrong. It shows dimensions that I have not even setup on the CP site? The only thing I can think of is opening Port 30000...but I would assume that the shipping calculations wouldn't work if this port was blocked? Thanks, Steve
×