Latest News: (loading..)

altoid

Members
  • Content count

    1,395
  • Joined

  • Last visited

  • Days Won

    12

altoid last won the day on January 21

altoid had the most liked content!

About altoid

  • Birthday 09/24/1950

Profile Information

  • Real Name
    Steve
  • Gender
    Male
  • Location
    Hollidaysburg, Pennsylvania
  • Interests
    Depends on what day, or even time it is.
  1. @@burt Gary, I lost track of where the php7 project is for Edge but in Github I managed to pull John's branch into my local branch (after dealing with a couple conflicts), the using the zip from that I ran a fresh install a "live" test shop using php 7.1. Hopefully what I have there is Edge up to the latest as of this date, then John's php7 work on top of that. Install went fine, no errors showing. A quick look around the test shop..no errors appeared but more looking needs done. FYI on that
  2. @@burt I can test, but it'll have to be on a uniserver test shop as my live shop is still way back from being caught up on Edge
  3. cannot find anything other than UTF-8 in tables and/or appropriate files. I'll look at PP configuration and if nothing shows there...work on the PP app install. Thanks
  4. @@MrPhil @@mcmannehan @@Gergely Morning and thanks for the responses. Here is some info in response. Info: Version 2.3.4 BS (about 3/4 along the way from Gold to Edge) All table collation was and is utf8_unicode_ci Checking in table_orders I see for this customer customers_street_address: Bivackgränden 21 delivery_street_address: Bivackgränden 21 The customers customers_address_format_id is 1 Now looking at other format ids I see they seem to change from country to country. In my database table, it seems all the "1s" are mostly non US english speaking countries, but I do see Russia and Norway in there too. Page Source for some ON index page it is: charset="utf-8" on account.php it is: charset="utf-8" for address_book_process.php it is charset="utf-8" I only have English language activated on this shop. This situation is viewable to me on the admin side in orders.php and apparently is carried over to PayPal where in the payment notice I see the character situation in the shipping address. I have not yet install the PP App on this shop. I am using the stock PP Express module. Version: 3.0 (online status) API Version: 112 Thanks
  5. For a customer from Sweden, in his customer information address line it shows this: Bivackgränden 21 But in the address line in his shipping information shows this: Bivackgränden 21 Any ideas what's going on there? Thanks
  6. @@raiwa Found it admin/includes/header.php Got there from the original instructions it looks like.
  7. @altoid I am updated from Github. Regarding that duplicate message, I don't see anything in admin/includes/template_top.php Going through that again..when ordering a Value 8 MB card, where there is only one in inventory when completed over on the admin side when on the index.php page, I see just one notice: Warning: There are 1 sick products in the database. Please visit the QTPro doctor. It appears only with the catagories.php page, I see two notices now: Warning: There are 1 sick products in the database. Please visit the QTPro doctor Warning: There are 1 sick products in the database. Please visit the QTPro doctor. Seems something specific to categories.php?
  8. @@raiwa I'll update with what you advised and check things out on the test shop. Regarding my repo, I apologize, I got backed up and haven't kept that up to date. I'll do that with files from your repo which should get it up where it needs to be. Thanks for working on the QT Pro modification > BS. It'll surely help folks out.
  9. @@raiwa Using the files from the github, I completely wrote over existing files from new and modified files in qtpro-5.0-BS-master and then reinstalling, I see this happed during a trial purchase: Adding a Value Model with 8 mb to the cart Model Memory Price Qty. Value 4 mb $299.99 1 Value 8 mb $349.99 1 Noting there's just one of those in stock. On the shopping cart page when I update the quantity to 2 and refresh this message appears. Matrox G200 MMS*** - Memory 8 mb - Model Value Products marked with *** dont exist in desired quantity in our stock. You can buy them anyway and check the quantity we have in stock for immediate deliver in the checkout process. Continuing through the checkout process... checkout_shipping > checkout_payment > checkout_confirmation Showing: 2 x Matrox G200 MMS - Memory: 8 mb - Model: Value I get to checkout_success and done. In admin I see this message: Warning: There are 1 sick products in the database. Please visit the QTPro doctor. QT Pro Doctor says: You currently have 28 products in your store. 3 of them have options with tracked stock. In the database we currently have 0 trash rows. 1 of the producks with tracked stock is sick. Sick products in the database: Product with ID 1: The summary stock calculation is wrong. Please take a look at this products stock. Clicking products stock I see duplicate warnings at the top: Warning: There are 1 sick products in the database. Please visit the QTPro doctor Warning: There are 1 sick products in the database. Please visit the QTPro doctor. Noting stock for that Value 8 MB Value 8 mb -1 Below I click on: Automatic Solutions Avaliable: Set the summary stock to: 14 QT Pro Dr is happy now but in stock for that item stock shows: Model Memory Quantity Value 16 mb 5 Premium 16 mb 6 Value 4 mb 1 Premium 4 mb 2 Value 8 mb -1 That's it for now
  10. @@raiwa Are the most up to date files on the github repo?
  11. @@raiwa That languages issue was because I didn't uninstall that module before I updated the module file. An uninstall and reinstall fixed that. Testing adding product with options for Model Memory Price Qty. Value 4 mb $299.99 1 Matrox G200 MMS - Memory 4 mb - Model Value In shopping cart, when I change the number order to 4 and refresh.. I do not get a notice of ordering more than is in stock. I am able to click Checkout. Ran a test checkout, completed successfully with 4 x Matrox G200 MMS - Memory: 4 mb - Model: Value In admin stock shows -3
  12. update to beta 5 With these settings, Show Out of Stock Attributes True Mark Out of Stock Attributes Right Display Out of Stock Message Line True Prevent Adding Out of Stock to Cart True Use Actual Price Pull Downs False Here's what I see for the various displays for Product Info Attribute Display Plugin with memory of 8 mb out of stock for both models: Base: 8 mb shows, no out of stock message and I am able to add to cart multiple_dropdowns 8 mb shows, with out of stock message. When trying to add to cart this popup shows: The combination of options you have selected is currently out of stock. Please select another combination. sequenced_dropdowns 8 mb does not show single_dropdown 8 mb shows with out of stock message. Trying to add that to cart gives pop up notices. single_radioset 8 mb shows with out of stock message. Trying to add that to cart gives pop up notices. In the edit mode for qt pro options..looks like a language mix up: Admin Stock Warnning ENGLISH Definición de idioma usado en admin QT Pro Stock Out of the edit mode I see: Admin Stock Warnning ENGLISH Warning: There are %s sick products in the database. Please visit the QTPro doctor Clicking that link, I get a page with this error on it: Bad RequestYour browser sent a request that this server could not understand. That's it for now
  13. Will work on this in the next day or so.
  14. @@raiwa I am at beta 3 right now, so maybe beta 4 will fix things. But I am getting mixed results on the product info page when I select different options in the QTPro options module. Depending on the display I choose I am sometimes seeing different results EX when Show Out of Stock Attributes is negative With Product Info Attribute Display Plugin set to single_dropdown and single_radioset I see the 8 mb memory although the value is zero With multiple_dropdowns it's hidden Anyway, I'll get to beta 4 and see what that does. It's nice to see the affected core files reducing with each release.
  15. @@raiwa I installed beta 2 and notwithstanding any mistakes, here's what I see: - WARNING_SICK_PRODUCTS in /admin/qtprodoctor.php Did I miss a language define somewhere? - Just an FYI, but in php 7 for various files I am seeing this type error: Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP php 5.6 is OK - in configuration, admin/configuration.php?gID=888001 for QT pro, it seems at least some of the settings are not used now and this is done now in the module setting instead? - for and item I have one of the option values set to zero. Example, Memory 4 mb =2, 8 mb=0 and 16 mb 06. In the content module I have this setting: Show Out of Stock Attributes False Yet in the product display, the 8 MB still shows. How is that supposed to show? Then over in the stock report, 8 MB is not showing at all for that product, where as 4 and 16 are. I was thinking perhaps it would be better to show at zero than not showing at all.. That's it for now.