Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

altoid

♥Ambassador
  • Content count

    1,571
  • Joined

  • Last visited

  • Days Won

    13

Everything posted by altoid

  1. altoid

    USPS in OScommerce 2.3

    Before 2 Jan I had my 3.2.1 shop (a work in progress) having its USPS correctly operating. On that day my shipping went blank during test purchases. I found that this fix worked for me: This fix is based off of this post number 748 See "My Link" below My link grapesmuggler said: My quick fix for USPS domestic rates was to just strip out all the new characters on the $type variable before it builds the shipping quotes array. I have a heavily modified usps.php modules file so I cannot show you exactly where, but basically find where the quotes array is built from the USPS response and add this code: Mine looks like this: list($type, $cost) = each($uspsQuote[$i]); so I added this after: $type = str_replace('<sup>®</sup>', '', $type); $type = str_replace('<sup>™</sup>', '', $type); $type = str_replace('**', '', $type); This removes the everything that was added by USPS that was causing errors on my site. It also fixes the international issue (response had added a ** to the end of the title). grapesmuggler's fix got me back my shipping for both domestic and international first class and priority shipping options. This is for 3.2.1 only.
  2. altoid

    USPS Methods 4_3_2 2011 Jan 2 Issue

    In addition to my post #1 add this code to the usps.php module file and it will allow your admin side to show the shipping title correctly....if you look closely toward the end of each code snippet you will see the change with the "**" part. Please see post #1 to help you decide if this may or may not apply to the method you are using. If you try it B A C K U P somewhere around line 256 (in my file anyway), changed this: tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Int\'l Shipping Methods', 'MODULE_SHIPPING_USPS_TYPES_INTL', '', 'Select the international services to be offered:', '6', '15', 'tep_cfg_select_multioption(array(\'Global Express Guaranteed (GXG)\', \'Global Express Guaranteed Non-Document Rectangular\', \'Global Express Guaranteed Non-Document Non-Rectangular\',\'USPS GXG Envelopes\', \'Express Mail International\', \'Express Mail International Flat Rate Envelope\', \'Priority Mail International\', \'Priority Mail International Large Flat Rate Box\',\'Priority Mail International Medium Flat Rate Box\',\'Priority Mail International Small Flat Rate Box\',\'Priority Mail International Flat Rate Envelope\', \'First-Class Mail International Package\', \'First-Class Mail International Large Envelope\'), ', now())"); to this: tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Int\'l Shipping Methods', 'MODULE_SHIPPING_USPS_TYPES_INTL', '', 'Select the international services to be offered:', '6', '15', 'tep_cfg_select_multioption(array(\'Global Express Guaranteed (GXG)\', \'Global Express Guaranteed Non-Document Rectangular\', \'Global Express Guaranteed Non-Document Non-Rectangular\',\'USPS GXG Envelopes\', \'Express Mail International\', \'Express Mail International Flat Rate Envelope\', \'Priority Mail International\', \'Priority Mail International Large Flat Rate Box\',\'Priority Mail International Medium Flat Rate Box\',\'Priority Mail International Small Flat Rate Box\',\'Priority Mail International Flat Rate Envelope\', \'First-Class Mail International Package**\', \'First-Class Mail International Large Envelope\'), ', now())");
  3. altoid

    USPS Methods 4_3_2 2011 Jan 2 Issue

    My apologies, but I am not that code savy to respond, perhaps someone with more coding knowledge could answer. My shop where it's working is a v2.2 RC2a shop. Thanks
  4. altoid

    USPS Methods 4_3_2 2011 Jan 2 Issue

    Hi there, in my case my shipping would not work with the code : code] //end new code $service = $regs[1]; [/code] To get it to work, I had to comment out the //$service = $regs[1]; That code is what I copied as noted above from this post: I did try the code both ways in my shop, but only the commented out code worked. I wish I knew code better to explain why it works but the code in that post is what I am using and it's working. Thanks
  5. altoid

    [Contribution] - USPS Methods

    I offered up what worked for me for method 4-3-2 over here It works for me after several days testing. But please read my signature line comments, I am not an expert in this stuff.
  6. altoid

    Is USPS shipping module down

    Thanks for taking the initiative to make the phone call on that Dan. All I have to do now is put my trust in the government to fix something. :)
  7. altoid

    Is USPS shipping module down

    I get the same message on a couple of my stores. The stuff in the middle <sup>&reg;</sup> appears to have something to to with the html code for the "®" character? So instead of picking up the character it's picking up the html code instead.
  8. Robert, I see in the documentation KISS FileSale is to work with all versions. Does that include 2.3.1? Thanks....
  9. altoid

    Header Tags SEO

    Jack, I applied this code modification by Goring_Gap and it seems to have taken care of the issue.
  10. altoid

    Header Tags SEO

    Jack, I have fckEditor installed and enabled in HT SEO. After I update the Header Tags Categories Description in the edit mode, I get this right above the fckEditor window: " style="display:none" /> That only occurs in the edit window/mode and only if I actually edit a HT category description. I am guessing it's a coding error somewhere; I've looked through my admin/categories.php file and can't seem to find the cause. Can you assist? Thanks
  11. altoid

    SiteMonitor

    That's a good observation. I am far from an expert on this but regardless of the cause, I think excluding those directories is the way to go for those using PHPIDS. So far so good for me anyway.
  12. altoid

    SiteMonitor

    I am using PHPIDS and had a similar situation. See this thread in the PHPIDS forum, that should help explain.
  13. altoid

    SiteMonitor

    OK, just double checking as the tech guy theorized it was a code issue. I was surprised I could change the settings with a php.ini because I did read your earlier post on shared server restrictions. But the tech guy said that wasn't a problem with them. Even the php_info page he set up for me verified the change was made. I will work with the tech guy further on this. In the meanwhile, I think I have a work around with this. I exclude 'images', run the code and it doesn't time out. I then remove the 'images" exclusion, run the code and it runs with no time out. Thanks for the response and Happy Holidays.
  14. altoid

    SiteMonitor

    Jack, I am dealing with the 30 second timeout issue when attempting to delete the reference file. Reading back through the thread I found that time outs are server set. My tech support helped me set up a php.ini file to override the 30 second time out. After installation we verified the max_execution_time was reset to 90 seconds. But when I run the delete reference file, I still get a 30 second timeout error. Guidance please. Thanks
  15. altoid

    SiteMonitor

    Jack, catching up on this from last September. I just moved my second store to my new host, and the installation and functioning of Site Monitor is just fine. Now that I moved two shops from the old host (where I could not get Site Monitor to work beyond the 2.4 level) to the new host (where upgrading to 2.7 went easily), it appears to me that the problem was something within the host. I have noticed a couple other differences in how osC works on the new host, so it's apparent to me osC shops don't necessarily work the same from one host compared to another. I wish I had the technical background to figure this out but I don't so I can only report observations. Anyway, Site Monitor 2.7 up and running on both shops now. Thanks
  16. Thanks for responding, Honey Pot states the IP is from the USA and there is no associated bad behavior from this IP. Perhaps the PHPIDs alert was for a benign reason after all. It is curious that the action that started this was from an account history inquiry on the site. That only should happen when a customer inquires of his/her own purchasing history. Thanks again and I will look into KISS FileSafe.
  17. I had some activity in my shop last evening that has PHP IDS installed. If you could help me understand the results I'd appreaciate that. Apparently the url that caused PHPIDS was /account_history_info.php?order_id=496 Two actions occurred there: REQUEST.alpha and COOKIE.alpha The "impact" scored 37. Based on what occurred then, the visitor was taken to /banned.php What caused that to happen involves a lot of text, I am not sure what is appropriate to put here though. It starts with: 2648453f7149000089e4f34c29c9050065560000, RANDOM_ID=1f29b62ae4d14ab48b19062cba0bafa5, SiteDisplayed=&languageDisplayed=, in the middle is: LANCOMEAUTH=D5145B2191FB89DC157786991E8D2AC7EDB670CA5BB67F39E61410624922A5296624DE4EB756DF14DBD5598D570820A2AF5EA61225A055934ED2DC508120B9D5F8A8E4459F5C1FDDDEAD9D372460122DC08E796835DFE92355DEEEC19FEA9BD71F6A81575477F8C35E0BF9B461B0BF163AE85B07C229322A453479BE64D59443F7DAAEED57CCC74B97541E4EA79A25085A8A246A82CE61DB1C3E6D6279404BC0, UDMID=841451712, NETMIND_PERMSID=1539218442-1291756643 I have not seen anything like this before so on the side of caution I put the IP on the banned list. The vistor came back a couple hours later and tried to access "/" with the same input and was taken to banned.php again. I ran Site Monitor after I noticed this activity and no files in the shop were reported as modified in any way. Can you help me understand what the visitors intention was? Thanks
  18. Based on what I read here, I have modified my banned.php file accordingly because the code change above is apparently a better way. I hope I correctly understood what the concept. I tested in my shop after modification and the banned.php activates when appropriate. Thanks
  19. altoid

    Header Tags SEO

    I just tried and the download is working now.
  20. Rob, if you mean different osC shops use the same email address as the shop address, yes. I have my shops set up that way. When a sale comes in I can tell the origin becaue the shop's name is included in the notification email.
  21. altoid

    Skip Registration?

    There are a couple I know of. I was using Purchase Without Account very successfully. But later I added Sam's Anti-hacker Account Mods which does several things but includes a seamless checkout process that doesn't interrupt the process to force a create an account.
  22. altoid

    SiteMonitor

    I applied the modification, Site Monitor runs fine and I clicked around in Admin with no problems. Thanks again.
  23. altoid

    SiteMonitor

    Jack, I was not having that problem, but should I apply the recommended change as well? I am running your latest version. Thanks
  24. altoid

    Site Monitor

    Hope, for using Cron Jobs with Site Monitor or other add ons that can be run by a Cron Job, you have to do that on your web host site. Go to your site hose's cPanel and look around for the Crons. Sometime's it's called an advanced feature. Hosts handle Cron Jobs different from one another sometimes. Some hosts don't offer them at all. Get in contact with support from your host and ask if htey can handle a Cron Job in the format you gave.
  25. Here's some good help on setting up PayPal standard. and here's some SSL help.
×