Jump to content

Shane Harrrison

Members
  • Content count

    12
  • Joined

  • Last visited

Profile Information

  • Real Name
    Shane Harrison
  1. Hi All I thought I'd add it as my error although the same was an field from the database. This can be found within the contribution date 30 Dec 2008 ALTER TABLE `products_attributes` ADD `options_values_model_no` INT( 11 ) NOT NULL DEFAULT '0' AFTER `options_values_price` ; Just add this into your database and always remember to backup. Regards. Shane.
  2. Shane Harrrison

    [Contribution] SEO-G

    Hi all. Not sure if this is normal or not. maybe problem file, root.php maybe problem line. 154 require(basename($osc_parse['path'])); I'm currently creating a website and this contribution seems to work fine for me in all but one sollution. I have just created a .htpasswrd file for the admin section, Since this I now get an error message if I fail to sucessfully log in after three time. Is this because it is looking for a folder and not a file? Warning: require(admin) [function.require]: failed to open stream: No such file or directory in /home/gellymold/rjavtest.com/root.php on line 154 Fatal error: require() [function.require]: Failed opening required 'admin' (include_path='.:/usr/local/php5/lib/php:/usr/local/lib/php') in /home/gellymold/rjavtest.com/root.php on line 154 If I login within the three attempts, everything works without a hitch. Is there anyway of creating a re-direct if the login is unsucessful? Just hate seeing these things I've seen in this tread someone else having an issue with this line of coding require(basename($osc_parse['path'])); and they corrected it with line 136 from $tmp_array = array_merge((array)$HTTP_GET_VARS,$tmp_array); to $tmp_array = array_merge((array)$_GET,$tmp_array); This has altered nothing that I can see, but I also see that under this line of text I see this // Synchronize global arrays. $HTTP_GET_VARS = $_GET = $tmp_array; unset($tmp_array); // Synchronize query string variables does this need any modifcations? Regards. Shane.
  3. Hi All and thankyou to the people who have made this contribution work it looks great. Athough everything is working I have seem to have a problem with the size of the pop-up window. Standard image 100 x 80 on the pop-up is shows 82 x 43. It seems to be <!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"> causing the problem. I know you can change it to one of the others, but this seems to disable one of the other jquery programs I have installed. Please view the problem. Please also excuse the site and check out one of the product pages. It's a test site. http://www.rjavtest.com/ Regards. Shane.
  4. Shane Harrrison

    BBC News style scrolling text

    Thank you for your quick reply. Unfortunately I'm quite new to PHP and only have a very limited knowledge. I understand you regarding the first part of the coding but this is as far as I know. I can see it works as the tables are removed and it has populating the array on the webpage, but it also brings a fatal error see below. This part I'm lost on and I'm guessing this is where it's failing. then echo the $scrollingtext appropriately I've tried a few combination and found that the closed I can get to this self populating is just the text in the coded line Just: $0.00. I'll include all the code which the array is collecting the data from (the new_product.php) this file is located in the modules directory. Not that clear in the first message. I was half asleep. [color="#FFFACD"] if ( (!isset($index_fp_category_id)) || ($index_fp_category_id == '0') ) { $index_fp_query = tep_db_query("select p.products_id, ifp.index_fp_title, ifp.valid_from_date, ifp.status, ifp.index_fp_id, if(s.status, s.specials_new_products_price, p.products_price) as products_price from " . TABLE_PRODUCTS . " p left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id, " . TABLE_INDEX_FP . " ifp, " . TABLE_PRODUCTS_DESCRIPTION . " pd where ifp.status = '1' and p.products_id = ifp.products_id and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' order by ifp.valid_from_date DESC limit " . MAX_RANDOM_SELECT_INDEX_FP); } else { $index_fp_query = tep_db_query("select distinct p.products_id, ifp.valid_from_date, ifp.index_fp_title, ifp.status, if(s.status, s.specials_new_products_price, p.products_price) as products_price from " . TABLE_PRODUCTS . " p left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id, ifp.index_fp_id, " . TABLE_INDEX_FP . " ifp, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c, " . TABLE_CATEGORIES . " c where p.products_status = '1' and p.products_id = ifp.products_id and p.products_id = pd.products_id and pd.language_id = '" . (int)$new_products_category_id . "' and ifp.status = '1' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' order by ifp.valid_from_date DESC limit " . MAX_RANDOM_SELECT_INDEX_FP); } $row = 0; $col = 0; $scrollingtext = array() ; while ($index_fp = tep_db_fetch_array($index_fp_query)) { $scrollingtext[$row][$col] = array('text' => '<li><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $index_fp['products_id']) . '">' . $index_fp['index_fp_title'] . ': Just ' . ($currencies->display_price($index_fp['products_price'], tep_get_tax_rate($index_fp['products_tax_class_id']))) . '</a></li>'); $col ++; // if ($col > 2) { // $col = 0; // $row ++; // } } new contentBox($scrollingtext);[/color] The above is the old style which is still part of the same page below. I have also copied the fatal error message. [color="#ADD8E6"] // $scrollingtext = array() ; // while ($index_fp = tep_db_fetch_array($index_fp_query)) { // $scrollingtext .= '<li><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $index_fp['products_id']) . '">' . $index_fp['index_fp_title'] . ': Just ' . ($currencies->display_price($index_fp['products_price'], tep_get_tax_rate($index_fp['products_tax_class_id']))) . '</a></li>' . "\n"; // } // seems to be the error point new $scrollingtext();[/color] [color="#FFFF00"]//Fatal error: Class 'Array<li><a href="http://www.rjavtest.com/lethal-weapon.html">Action Comedy: Lethal Weapon: Just £34.99</a></li> <li><a href="http://www.rjavtest.com/courage-under-fire.html">Drama: Courage Under Fire: Just £29.99</a></li> <li><a href="http://www.rjavtest.com/frantic.html">Thriller: Frantic: Just £35.00</a></li> <li><a href="http://www.rjavtest.com/fire-down-below.html">Action: Fire Down Below: Just £29.99</a></li> <li><a href="http://www.rjavtest.com/hewlett-packard-laserjet-1100xi.html">Printer: HP LaserJet 1100: Just £499.99</a></li> <li><a href="http://www.rjavtest.com/beloved.html">Beloved: Just £54.99</a></li> <li><a href="http://www.rjavtest.com/die-hard-with-a-vengeance.html">Action: Die Hard With A Vengeance: Just £39.99</a></li> <li><a href="http://www.rjavtest.com/blade-runner-director-s-cut.html">Science Fiction: Blade Runner: Just £30.00</a></li> <li><a href="http://www.rjavtest.com/a-bug-s-life.html">Animation in /home/catalog/includes/modules/tickets.php on line 55 [/color] Has anyone any ideas. Regards. Dragondust
  5. Shane Harrrison

    [Contribution] SEO-G

    Hi All I've just installed the SEO-G installation into a clean OSCommerce platform. Seem to have had a few problems before it worked. It's been a long week. But all sorted now apart from one thing. When I tried to use the search and advanced search options, neither is working, it is as if the form is incomplete. Has anybody had this problem before? On another note. I have been trying to see if I can include the phrase /product/ and /brand/ into the products and manufacturers link. Has anybody been able to achieve this. if so please can someone point me in the right direction so I can modifiy them. e.i. from .somewebsite.com/some-shiny-product. to .somewebsite.com/product/some-shiny-product. I know there is another contribution which works this way which I'm currently using, but I've been unsucessful in adapting this for google xml sitemap feeds. getting fedup with the manual convertion when you have over 500 to do :blink: . If anybody can help if some tells me that this contribution has the same problems I would very much appreciate it. Shane
  6. Shane Harrrison

    googlebase

    Hi All. I'm trying to enable the googlebase contribution for url_rewrite & nemmit_sef html tags I've been enable to add the main url name with the title name and html tag at the end, but I'm really struggling with the inputting with in the title name. The google base contribution I'm using is googlebase 1 2 1, I think. Below is how the googlebase contribution is now delivering the link, but what is required is Now: http://www.ourwebsite.co.uk/product/a very small product.html would need for the correct link: http://www.ourwebsite.co.uk/product/a-very...ll-product.html So far section of the coding I have changed are: Line: 113* if(SEO_ENABLED=='false'){ $productURL = 'product_info.php'; $productParam = "products_id="; }else{ $htmltagrj = '.html'; $urlProducthtml = HTTP_SERVER.'/product/'; $productURL = HTTP_SERVER.'/product/'; line 147: SELECT concat( '" . $productURL . "' ,products.products_id) AS product_url, products_model AS prodModel, products_weight AS weight, products_description.products_head_title_tag AS ean, products_description.products_head_keywords_tag AS ckeywords, manufacturers.manufacturers_name AS mfgName, manufacturers.manufacturers_id, products.products_id AS id, products_description.products_name AS name, products_description.products_description AS description, products.products_quantity AS quantity, products.products_status AS prodStatus, FORMAT( IFNULL(specials.specials_new_products_price, products.products_price) * " . $taxCalc . ",2) AS price, CONCAT( '" . $imageURL . "' ,products.products_image) AS image_url, products_to_categories.categories_id AS prodCatID, categories.parent_id AS catParentID, categories_description.categories_name AS catName FROM (categories, categories_description, products, products_description, products_to_categories) line 248: $output = "link\ttitle\tdescription\texpiration_date\tprice\timage_link\tgenre\tid\tC:keywords\tean\tweight"; line 329: $output .= $urlProducthtml . $row->name . ".html" . "\t" . preg_replace($_strip_search, $_strip_replace, strip_tags( strtr($row->name, $_cleaner_array) ) ) . "\t" . preg_replace($_strip_search, $_strip_replace, strip_tags( strtr($row->description, $_cleaner_array) ) ) . "\t" . $feed_exp_date . "\t" . $row->price . "\t" . $row->image_url . "\t" . $catIndex[$row->prodCatID] . "\t" . $row->id . "\t" . preg_replace($_strip_search, $_strip_replace, strip_tags( strtr($row->mfgName, $_cleaner_array) ) ) . "\t" . $row->ean . "\t" . $row->weight . $WeightUnit; If you need to see the entire code please drop me a PM. Any help would be much appreciated. Regards. Shane.
  7. Shane Harrrison

    APR Calculator

    Thanks Burt. Thought it was my in experience. Regards. Shane.
  8. Shane Harrrison

    APR Calculator

    Hi All I'm quite green to PHP and to OScommerce so this could be my inexperience. I'm in throws of creating an apr calculator for our website. I have a working version which will calculate an apr of 19.9% under £1000 and as we have to set a figure which this is not available at I have also set a minimum for this reason. But here the problem side. Because of the legal side of advertising apr's you have to show all the information. Interest, Amount repayable and total amount repayable. Now as i said the calculator works fine upto £1000. But I feel it's the format of £1,000.00 that is causing the problem and it may be may in experience showing. Please have a look at my coding. <?php if ($product_info['products_price'] < 299.99){ echo ''; } else { $calamount = ($product_info['products_price']); $calapr = 0.03629639; $calperiod = 36; $calmon = $calamount * $calapr; $mon = number_format($calmon, 2, '.', ','); echo '<br />Or £' . $mon . ' a month.'; $calcost = $calmon * $calperiod; $number = number_format($calcost, 2, '.', ','); echo '<br />Total Charge £' . $number . '.'; $calint = ($number - $product_info['products_price']); $formatted2 = number_format($calint, 2, '.', ','); echo '<br />Interest £' . $formatted2 . '.'; } ?> Looking on php.net it seems that it could be this but I'm green and would like a little more informationnumber_format Now as I said the £1,000.00 is I feel causing the problem. anything upto £999.99 works fine so I feel comer is causing the problem. and if this is the reason has anybody seen how this has been resolved. I look forward to anybodies comments. Regards. Shane.
×