Jump to content

Enzio_Ferrari

Members
  • Content count

    71
  • Joined

  • Last visited

Profile Information

  • Real Name
    Jan Forrest
  • Location
    Rotherham, South Yorkshire (civilisation)
  • Interests
    Sex, money, sex, Rock & Roll, sex, wimmin, that kind of thing!
  • Website
  1. I have been struggling when adding "Size" Attributes to some of my clothing ranges. Mostly they show in the 'proper' order in the drop-down menu in which I want them - Small, Medium, Large, etc. as you go down the list. Some of them, though, insist on setting out in a random order - XL, Small, Large, Extra Small or similar. I've tried going back into Admin/Attributes and editing them, but it only works half the time! Any ideas?
  2. Enzio_Ferrari

    Website Payments Standard

    This was my way of 'curing' the problem: It may not be to everyone's taste! ... The other day the whole site just stopped responding. Every effort to enter was met with an IE "Error 500". Obviously my first attempts were to try and find an error in several of the central .php files by opening them with with the edit facility in my FTP app. When that didn't work I tried replacing them, first from my backup and then from the original OsC download. Penultimately I resorted to reloading my whole backup folder. No Joy! BUGGER!! That left me with the last resort :rolleyes: I junked the whole installation (including all my products and their attibutes) and started from scratch. Now everything works! Even PayPal!! I can only assume that either I made an error in my original setup or, possibly, a file or two had become corrupted during the first upload. Many find this fix a little too drastic, having already spent far too many hours modding their shops and even more time adding categories, products and attributes. I wouldn't blame them. Even so, if you're still in the early stages of building your online shop it might be worth a punt :P
  3. Enzio_Ferrari

    Website Payments Standard

    US$, CAN$, AUS$, Euros€, and, of course, GBP£. I've also set My (PayPal) Profile to accept other currencies and then convert them to real £money£. Strangely the two payment options come up as different currencies ... Credit/Debit card payments are shown as € and PayPal Account payments as US$ but both with a zero amount requested. I hesitate to say this situation is urgent, but I've got a customer eager to spend serious money and I don't think he'll hang arond for weeks while I (or rather you) sort this out! Thanks so far.
  4. Enzio_Ferrari

    Website Payments Standard

    I'm definitely getting closer! After reloading most of the files from a recent backup I can get through to the PayPal login/payment page. BUT ... there are two problems 1) The 'Confirm Shipping Address' page does not forward to 'Checkout_Payment.php' so I have to enter the url manually into the address bar. 2) When I get to the PayPal page it converts real money (£) into Monopoly money ($)(€) or just as a zero amount in any of them. The odd thing is that I've removed all other currencies from my site and set up PayPal to automatically convert payments in any other currency into £!
  5. Enzio_Ferrari

    PayPal Express issues

    I've been trying to get that one working for days. How did you do it?
  6. Enzio_Ferrari

    Website Payments Standard

    Never mind. I've got it back again!
  7. Enzio_Ferrari

    Website Payments Standard

    BUGGER! Despite not changing anything the whole site has crashed about 10 minutes ago ... :o Every page shows dozens of errors and I cannot login to admin at all. Wipe it and start again? :blink:
  8. Enzio_Ferrari

    Website Payments Standard

    Nearly there, Satish. Thanks again. The ordinary checkout button stll keeps me on the 'confirm shipping address' page. Forcing the _payment page leads to a blank page for both payment options. But now the 'checkout with PayPal' button drops me back to the same page with a red banner and "security header is not valid".
  9. Enzio_Ferrari

    Website Payments Standard

    I'm getting closer - but not by much! I've activated Express Checkout with sort order of 1. Now I get both the ordinary Checkout button and the Pay With PayPal button. The ordinary button still takes me to the 'confirm shipping address' page but no further. The PayPal button gives these errors: "Notice: Use of undefined constant MODULE_PAYMENT_PAYPAL_EXPRESS_TEXT_TITLE - assumed 'MODULE_PAYMENT_PAYPAL_EXPRESS_TEXT_TITLE' in /customers/dye-subli.com/dye-subli.com/httpd.www/catalog/includes/modules/payment/paypal_express.php on line 23 Notice: Use of undefined constant MODULE_PAYMENT_PAYPAL_EXPRESS_TEXT_PUBLIC_TITLE - assumed 'MODULE_PAYMENT_PAYPAL_EXPRESS_TEXT_PUBLIC_TITLE' in /customers/dye-subli.com/dye-subli.com/httpd.www/catalog/includes/modules/payment/paypal_express.php on line 24 Notice: Use of undefined constant MODULE_PAYMENT_PAYPAL_EXPRESS_TEXT_DESCRIPTION - assumed 'MODULE_PAYMENT_PAYPAL_EXPRESS_TEXT_DESCRIPTION' in /customers/dye-subli.com/dye-subli.com/httpd.www/catalog/includes/modules/payment/paypal_express.php on line 25 Notice: Undefined index: osC_Action in /customers/dye-subli.com/dye-subli.com/httpd.www/catalog/ext/modules/payment/paypal/express.php on line 69" If I then force access to the '_payment' page I have 2 radio buttons for the two PayPal options: Express and credit/debit card. Both give an Error 500. If this is a problem with a language file is there likely to be any repercussions from reloading some of them from the original files or a backup I made several days ago?
  10. Enzio_Ferrari

    PPExpress Shipping missing in Euro and Dollar Purchase

    "Best guess": You've set GBP as the Zone on the PP Express module and/or in Admin/Shipping. You may have to set up more Zones to handle shipping to other countries (Zones).
  11. Enzio_Ferrari

    Website Payments Standard

    Just been going through the various options in Admin and came to the "Backup Database" and got an error that indicates that the database is tied to CubeCart. Possibly because I tried out that one before removing it and installing OsCommerce. Question: Am I going to have to tear down the whole installation (including the database) and start again from scratch? :o
  12. Enzio_Ferrari

    Website Payments Standard

    Well, that got a lot of error responses which I've manged to eliminate by removing an extra 'configure.php' that had crept into /catalog/includes/local/ :rolleyes: Thanks :) But now, with the downloaded version 1.4 of PayPal Standard, when I add something to a cart I get "Notice: Use of undefined constant MODULE_PAYMENT_PAYPAL_IPN_TEXT_TITLE - assumed 'MODULE_PAYMENT_PAYPAL_IPN_TEXT_TITLE' in /customers/dye-subli.com/dye-subli.com/httpd.www/catalog/includes/modules/payment/paypal_ipn.php on line 22 Notice: Use of undefined constant MODULE_PAYMENT_PAYPAL_IPN_TEXT_DESCRIPTION - assumed 'MODULE_PAYMENT_PAYPAL_IPN_TEXT_DESCRIPTION' in /customers/dye-subli.com/dye-subli.com/httpd.www/catalog/includes/modules/payment/paypal_ipn.php on line 23" but the item still shows in the cart! Then it still will not go past the address page. If I revert to version 1.0 there are no error messages at all, but it also keeps displaying the 'confirm shipping address' page when I try to checkout.
  13. Enzio_Ferrari

    Website Payments Standard

    Am I looking for a variable called "force_error" and where is it to be found?
  14. Enzio_Ferrari

    Website Payments Standard

    The site is situated at http://www.dye-subli.com As stated I have set up a couple of dummy accounts and 'bought' things with both - each item 'bought' then shows in the Shopping Cart but after confirming the shipping address and clicking on 'Continue' the same page just keeps on cycling round again. I've installed and activated the embedded PayPal Website Standard payment module (and uninstalled all the others) with the following varaibles: Version: 1.0 Enable: True E-Mail Address: My PayPal email addy Zone: None Preparing Order Status: Default Acknowledged Order Status: Default Server: Live Method: Sale Page Style: PayPal Next few: Left Blank OpenSSL Location: /usr/bin/openssl
  15. Enzio_Ferrari

    Website Payments Standard

    Although I've got my site and the shopping cart working I just can't get the embedded PayPal Website Payments Standard to go past the 'Confirm Shipping Address' page :huh: Even though I've set up a dummy account and 'bought' things with it, Oscommerce's 'Reports/Products Purchased' and 'Reports/Customer Orders-total' indicate no sales at all. Neither do 'Customers/Customers/Orders' and Customers/Orders'! A bugger, innit? :unsure: Any hints, tips, ideas, suggestions all gratefully received, chums :wub:
×