Jump to content

Stephan (VS)

Members
  • Content count

    109
  • Joined

  • Last visited

Everything posted by Stephan (VS)

  1. Stephan (VS)

    Business Management plugin for osCommerce

    When it's out I'm definitely making custom back-end skins for myself, I'll release them as soon as I've played around a bit with the up & coming Beta. I mainly gonna be focussing on making it mobile friendly for people who like to run admin off Tablets & Mobile phones. If possible could the configuration section also set a limit of the amount of records (IE. Products, Customers, etc.) per page? Maybe add a Webcam plugin, to remotely view the shop's facilities via the admin section or for video staff meetings. Great job on the Plugin, it can make a lot of people's lives a lot easier. Regards, Stephan
  2. Stephan (VS)

    Business Management plugin for osCommerce

    When it's out I'm definitely making custom back-end skins for myself, I'll release them as soon as I've played around a bit with the up & coming Beta. I mainly gonna be focussing on making it mobile friendly for people who like to run admin off Tablets & Mobile phones. If possible could the configuration section also set a limit of the amount of records (IE. Products, Customers, etc.) per page? Maybe add a Webcam plugin, to remotely view the shop's facilities via the admin section or for video staff meetings. Great job on the Plugin, it can make a lot of people's lives a lot easier. Regards, Stephan
  3. Stephan (VS)

    Ultimate Seo Urls 5 Pro

    I to fix this error: [b]Warning[/b]: aPage_Modules::stripPathToLastNumber: Incorrect path value of presented in [b]/home/google/public_html/google/includes/modules/ultimate_seo_urls5/abstracts/page_modules.php[/b] on line [b]313[/b] [color="#000000"][b]1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND cd.language_id = 1' at line 1 SELECT cd2.categories_name AS pName, cd.categories_name AS cName FROM categories c LEFT JOIN categories_description cd2 ON c.parent_id = cd2.categories_id AND c.parent_id = cd2.categories_id AND cd2.language_id = 1, categories_description cd WHERE c.categories_id = cd.categories_id AND c.categories_id = AND cd.language_id = 1[/b][/color] Don't delete all your categories :lol:
  4. Stephan (VS)

    jQuery - Ultimate Product Pack

    I'm having an issue with the main image popup-link in the product info page. I know it's because I Installed it wrong on a modified Contribution shop, I've redone categories.php & product_info.php twice but i'm making the same mistake ...>_< When I Mouseover the main image the link just point to the catalog/images directory where all the additional images work perfectly The values are correct in the database Could someone who knows how the contrib create the links please throw me a bone?:blink: Linux Server OScommerce RC2 SEO URLS 22d_9 Auto Backup Install V3.0 Customer Add Product 1.4.3 CKE Editor 3.2.1 Backup All Store Files V1.1 Dynamic sitemap v4 21 SEO_Assistant V 2.0
  5. Stephan (VS)

    Customer Add Product

    >_< -"DOH"
  6. Stephan (VS)

    Customer Add Product

    When I follow the Instructions on line 157 [size="2"]## Find: $products_count = 0; if (isset($HTTP_GET_VARS['search'])) { $products_query = tep_db_query("select p.products_id, pd.products_name, p.products_quantity, p.products_image, p.products_price, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p2c.categories_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' and p.products_id = p2c.products_id and pd.products_name like '%" . tep_db_input($search) . "%' order by pd.products_name"); } else { $products_query = tep_db_query("select p.products_id, pd.products_name, p.products_quantity, p.products_image, p.products_price, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' and p.products_id = p2c.products_id and p2c.categories_id = '" . (int)$current_category_id . "' order by pd.products_name"); } ## To replace by: $products_count = 0; if (isset($HTTP_GET_VARS['search'])) { $products_query = tep_db_query("select p.products_id,p.customer_id,c.customers_firstname,c.customers_lastname, pd.products_name, p.products_quantity, p.products_image, p.products_price, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p2c.categories_id from " . TABLE_PRODUCTS . " p,".TABLE_CUSTOMERS." as c, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where p.products_id = pd.products_id and c.customers_id = p.customer_id and pd.language_id = '" . (int)$languages_id . "' and p.products_id = p2c.products_id and pd.products_name like '%" . tep_db_input($search) . "%' order by pd.products_name"); } else { $products_query = tep_db_query("select p.products_id,p.customer_id,c.customers_firstname,c.customers_lastname, pd.products_name, p.products_quantity, p.products_image, p.products_price, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status from " . TABLE_PRODUCTS . " p, ".TABLE_CUSTOMERS." as c , " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where p.products_id = pd.products_id and c.customers_id = p.customer_id and pd.language_id = '" . (int)$languages_id . "' and p.products_id = p2c.products_id and p2c.categories_id = '" . (int)$current_category_id . "' order by pd.products_name"); }[/size] The products stop showing up on the Admin side's categories & products listing (categories.php) Is it safe to skip this step? Linux Server OScommerce RC2 SEO URLS 22d_9 Auto Backup Install V3.0 Customer Add Product 1.4.3 CKE Editor 3.2.1 Backup All Store Files V1.1 Dynamic sitemap v4 21 SEO_Assistant V 2.0
  7. Stephan (VS)

    FCK WYSIWYG HTML editor

    Jenica,,, what browser are you using? FireFox 3.6? I tried everything to fix my issue, When I went in using IE 6.0 Everything started working fine.. Give it a trie and let me know.
  8. Stephan (VS)

    FCK WYSIWYG HTML editor

    Something like this: /var/www/vhosts/amazon.com/httpdocs/catalog/userfiles/
  9. Stephan (VS)

    FCK WYSIWYG HTML editor

    I'm having the same issue on my one site wil post if I find it but that's not a priority now... 2.7's been the latest one for a while, I think they renamed FCK Editor to CKEditor or somethin, but anyway, Your using this Contribution Right? Check your "images" directory permissions are set to 777, Check fck's config.php file, (Elmer Fudd Voice) <- This is veeeery importan, I'd start here. Make sure it's in "catalog/admin/fckeditor" and remember to change your admin folder later for security, Alter "/admin/categories.php" to change the Textarea Check /admin/includes/functions/html_output.php and the tips: in catalog/admin/fckeditor/fckconfig.js change line 153 from: FCKConfig.FontSizes = 'smaller;larger;xx-small;x-small;small;medium;large;x-large;xx-large' ; To: FCKConfig.FontSizes = '8;10;12;14;16;18;20;24;28;32;36;42;50;58;66;smaller;larger;xx-small;x-small;small;medium;large;x-large;xx-large' ; To add extra, but still standard fonts, change line 152 from: FCKConfig.FontNames = 'Arial;Comic Sans MS;Courier New;Tahoma;Times New Roman;Verdana' ; To: FCKConfig.FontNames = 'Arial;Arial Black;Comic Sans MS;Courier New;Tahoma;Times New Roman;Verdana;Georgia;Impact;Palatino Linotype;Trebuchet MS' ;
  10. Stephan (VS)

    "Dynamenu" for osCommerce

    I have a quick question... How can I put an image to the left of Dynamenu? I've tried pasting "<img align="top" src="images/addons/dmbackright.png" width="8" height="32" border="0" alt="Menu" /> " All over the place but I think I'm missing something. I Can get it on the right but no luck sofar with left.. Below is an image, RED where I'd like to put it, Orange what I have succeeded in sofar:
  11. Stephan (VS)

    FCK WYSIWYG HTML editor

    I want to customise the default toolbar for FCKeditor to make it 99% safe, I want to allow the max features available but close any possible security holes. Which tools may be harmfull to my site? :o (like images, flash etc?) (the file I need to edit:) FCKConfig.ToolbarSets["Default"] = [ ['Source','DocProps','-','Save','NewPage','Preview','-','Templates'], ['Cut','Copy','Paste','PasteText','PasteWord','-','Print','SpellCheck'], ['Undo','Redo','-','Find','Replace','-','SelectAll','RemoveFormat'], ['Form','Checkbox','Radio','TextField','Textarea','Select','Button','ImageButton','HiddenField'], '/', ['Bold','Italic','Underline','StrikeThrough','-','Subscript','Superscript'], ['OrderedList','UnorderedList','-','Outdent','Indent','Blockquote'], ['JustifyLeft','JustifyCenter','JustifyRight','JustifyFull'], ['Link','Unlink','Anchor'], ['Image','Flash','Table','Rule','Smiley','SpecialChar','PageBreak'], '/', ['Style','FontFormat','FontName','FontSize'], ['TextColor','BGColor'], ['FitWindow','ShowBlocks','-','About'] // No comma for the last row. ] ; FCKConfig.ToolbarSets["Basic"] = [ ['Bold','Italic','-','OrderedList','UnorderedList','-','Link','Unlink','-','About'] ] ;
  12. Stephan (VS)

    FCK WYSIWYG HTML editor

    Thanx Spooks, I fixed da problem. I'm a bit tired so I just made a pretty picture of what & where to do :D Problem: When editing & previewing the product the fckeditor works fine, :) when viewing / going back to edit page the description is one long text string. :( Solution: Delete the Strip Html & php code from functions. in bluesuadeshoes/platapus/includes/function/database.php (where bluesaudshoes is your catalog folder & platapus is your admin folder, YOU DID CHANGE YOUR ADMIN FOLDER RIGHT? Line 132-136 (mine) change function tep_db_input($string, $link = 'db_link', $skip_stripping = false) { // Strip HTML and PHP tags from string if (!$skip_stripping) $string = strip_tags($string); to function tep_db_input($string, $link = 'db_link') { // Strip HTML and PHP tags from string // if (!$skip_stripping) $string = strip_tags($string); Thanx again Spook you really help alot of us out there. May we star a "become a fan" thing for spooks on facebook? :D
  13. Sorry to bother on Christmas eve :sweating: Is it possible to call out a specific image from the blob? :huh: I want to use say image 3 alone on the review box instead of the default product_image Current Value: a:6:{i:0;s:15:"DEMO001-02L.jpg";i:1;s:15:"DEMO001-03L.jpg";i:2;s:15:"DEMO001-04L.jpg";i:3;s:15:"DEMO001-05L.jpg";i:4;s:15:"DEMO001-06L.jpg";i:5;s:15:"DEMO001-07L.jpg";.... (I use to use additional images and just replace product_image with product_image_sm_1) ^_^ This is as far as I got: $random_select = "select r.reviews_id, r.reviews_rating, p.products_id, p.products_image_array, pd.products_name from " . TABLE_REVIEWS . " r, " . TABLE_REVIEWS_DESCRIPTION . " rd, " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = r.products_id and r.customers_id != 2 and r.reviews_id = rd.reviews_id and rd.languages_id = '" . (int)$languages_id . "' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' and r.approved = '1' "; $info_box_contents[] = array('text' => '<div align="center"><a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS_INFO, 'products_id=' . $random_product['products_id'] . '&reviews_id=' . $random_product['reviews_id']) . '">' . tep_image(DIR_WS_IMAGES . $random_product['products_image_array'], $random_product['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a></div><a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS_INFO, 'products_id=' . $random_product['products_id'] . '&reviews_id=' . $random_product['reviews_id']) . '">' . $rand_review_text . ' ..</a><br><div align="center">' . '</div>'); (We use image 3 as the pic of us reviewing the product)
  14. Stephan (VS)

    FCK WYSIWYG HTML editor

    Sorry about the tripple posting. :blush:
  15. Stephan (VS)

    FCK WYSIWYG HTML editor

    I'm also having the problem on the product edit page where the preview is perfect but loses the modifications once I press the UPDATE button. I've installed it working on a fresh oscommerce installation working fine, I tried using the fresh's categories file aswell to the same effect. The problem must be in some file other edited? :huh: Could it be because of my Database's Collation? I've tried all off the FCK as well as the tinymce (I prefer FCK) editors and keep getting the issue. <_< If someone who knows more about this and what could be causing this could point me in the right direction, I'd really appreciat it. :( PS. I also noteced on my backups from a couple of months ago the default textarea does not allow new rows, it makes all the text a long rong and the "enter"-command a space.
  16. Stephan (VS)

    "Dynamenu" for osCommerce

    To anyone new or those deciding to use this contribution, I highly recommend it. It's one of the good' ones. I'm using it with 1080 Categories and it's working beautefully. :lol: To everyone else, here's mine if you're looking for ideas: ;) Link to the live shop Tips for the new users: 1- Backup and change the variables stylesheet.css in dm_categories and get use to how it works. Read the Install instructions and double check, this forum is waaay to full of repeated support questions. <_< 2- Get the spacing right, make it look nice on 1024*798 and bigger resolutions as well on widescreens. 3- New look? use .PNG files to ad some transparency 4- You can also change the background of the categories to make a small button on the left that changes or whatever. 5- Change the background & font of the category this mouse hovers over to make it suit your site. 6- I added a darker line top & bottom to give the list a ½ 3D-like look for example. Also... Please remember the ***CODE*** // Output the footer for Dynamenu for osCommerce echo $GLOBALS['dmfooter']; ***CODE*** Code in your footer.php file. Some (older) useful posts: ---------------------------------------------------------------------------- To make Categorie links point to external websites: Posted by: Synd Nov 1 2006, 12:08 PM Thanks a ton, here's a pretty IF statement to do it... QUOTE $output .= str_repeat(".", $level+$lvl_adjust).'|'.$divide_subcats_text.'||'.$this_title.'|'.$menu_icon_file.'|'.$this_selected.'|'.$this_expanded."\n"; $this_subcat_count = 1; $lvl_adjust ++; } if($cPath_new == "cPath=29") { $this_title .= ".php"; $output .= str_repeat(".", $level+$lvl_adjust).'|'.$val.'|'.tep_href_link($this_title).'|'.$this_title.'|'.$menu_icon_file.'|'.$this_selected.'|'.$this_expanded."\n"; } else { $output .= str_repeat(".", $level+$lvl_adjust).'|'.$val.'|'.tep_href_link(FILENAME_DEFAULT, $cPath_new).'|'.$this_title.'|'.$menu_icon_file.'|'.$this_selected.'|'.$this_expanded."\n"; } [/size] Posted by: nate_02631 Nov 1 2006, 01:26 PM Not bad... I would have gone a slighly different way, creating a $linkvar and assigning the link portion of the $output to "blah" if a match or to the usual tep-link... if not, and then stick that var in output... A good programming practice is DRY - "Don't Repeat Yourself" ;-) Posted by: nate_02631 Oct 28 2006, 05:44 PM QUOTE (gerard @ Oct 17 2006, 10:37 AM) Is there anyway off excluding certain cPath links and sub links from being produced in the menu? I have a menu item called logs, which cPath=25 and I would like it not to show in the menu, it also has a sub menu called wet logs cpath=25_35 Look in the tep_make_cat_dmbranch function, where the categories are being parsed... Just before the $output is assigned, I think you could add something like CODE if ($GLOBALS['cPath_set'][0] == '25') continue; Assuming cat #25 is a "root" category. Otherwise, change the the zero to 1, 2, etc... depending on what sublevel the category is on... Haven't tried it, but something along those lines... ---------------------------------------------------------------------------------- Can someone please just help me with something that's been bugging me? <_< In the 2nd picture I have a level 2 subcategory containing cables. (/catalog/index.php?cPath=1_72) I want to add a dummy subcategory to other level 3,4 & 5 subcategories like "Displays", "Networking", "etc" that displays the main Level 2 "Cables" subcategory. In a nutshell: When I hover my mouse over "Hardware" -> "Displays" -> "Cables" (cPath=1_179_193) it shouldn't display "cPath=1_179_193" but rather "cPath=1_72". Not the level 4 subacategory "Cables" but rather level 2 subcategory "Cables" Ive downloaded this topic and read, and read and came upon a ½ working solution: :blink: In dm_categories: ***CODE*** $this_subcat_count = 1; $lvl_adjust ++; } if($cPath_new == "cPath=1_179_193") { $this_title .= "index.php?cPath=1_72"; $output .= str_repeat(".", $level+$lvl_adjust).'|'.$val.'|'.tep_href_link($this_title).'|'.$this_title.'|'.$menu_icon_file.'|'.$this_selected.'|'.$this_expanded."\n"; } else { $output .= str_repeat(".", $level+$lvl_adjust).'|'.$val.'|'.tep_href_link(FILENAME_DEFAULT, $cPath_new).'|'.$this_title.'|'.$menu_icon_file.'|'.$this_selected.'|'.$this_expanded."\n"; } if ((isset($table[$key])) AND (($maxlevel > $level + 1) OR ($maxlevel == '0'))) { $output .= tep_make_cat_dmbranch($key,$table,$level + $lvl_adjust,$maxlevel); } } // End while loop return $output; } ?> ***CODE*** Which will only work if the last "Cables" category (193) didn't have any subdirectories. As it is now it will take me to category 72 but still shows 193's subcategories. <_< I realy would like a way for it to show 72's subcategories.
  17. Stephan (VS)

    [Contribution] Mindsparx admin

    Soz, here is a screenshot of the above mentioned post http://v-s.co.za/picture_library/problem_infobox.jpg
  18. Stephan (VS)

    [Contribution] Mindsparx admin

    This is regarding Mindsparx Specials & Star Product I Redid my shop from scratch 3days ago but something went wrong after adding Mindsparx Specialst & Star Product , the Index page keeps placing them a box (.infoBoxContents). <_< I'm sure it's something stupid I'm missing / misplaced. :blush: This is a snippet from Index.php <td><table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <img src="images/Sunline.png" width="1040" height="3"> </tr> <tr> <td> <?php include(DIR_WS_MODULES . FILENAME_STAR_PRODUCT);?><br /> <?php include(DIR_WS_MODULES . MINDSPARX_SPECIALS);?><br /> <?php include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ?><br /> </td> </tr> <?php include(DIR_WS_MODULES . FILENAME_UPCOMING_PRODUCTS); ?> </table></td> </tr> </table></td> <?php } ?> <!-- body_text_eof //--> Sorry for bothering you with this, but I'm @ my 4th cup of coffee on this :(
  19. Stephan (VS)

    "Dynamenu" for osCommerce

    Great Contribution works perfectly on my old Site. Now on a new version I installed AJAX shoppin cart that I believe also uses JavaScript. But since I installed Dynamenu the /catalog/shopping_cart.php doesn't show my cart, ie. it only displays "What's In My Cart?" with the continue shopping & checkout buttons. Any1 know how to fix this? AJAX alters only catalog/shopping_cart.php by replacing it with their version. My Dynamenu only alters Header with: include(DIR_WS_BOXES . 'dm_categories.php'); and only the Footer with: echo $GLOBALS['dmfooter']; Dynamenu still works 100% when Ajax stops working. Dynamenu FTW! It worked 100% before dynamenu and when I change the Header edit to "<?php //include(DIR_WS_BOXES . 'dm_categories.php'); ?>" AJAX works perfectly. Mode 0 & 1 Bugs out, but 3 & 4 works perfectly with AJAX.
  20. Stephan (VS)

    AJAX Shopping Cart

    Great Contribution works perfectly on my Site. But since I installed Dynamenu the /catalog/shopping_cart.php doesn't show my cart, ie. it only displays "What's In My Cart?" with the continue shopping & checkout buttons. Any1 know how to fix this? Dynamenu only alters Header with: include(DIR_WS_BOXES . 'dm_categories.php'); and only the Footer with: echo $GLOBALS['dmfooter']; It worked 100% before dynamenu and when I change the HEader edit to "<?php //include(DIR_WS_BOXES . 'dm_categories.php'); ?>" it works perfectly.
  21. Stephan (VS)

    [Contribution] Mindsparx admin

    Yawn oh cool I'l check that, I fixed it! :lol: The problem was my google contribution I think. <_< When I use national capp only it doesn't work. When I got my International cap for this month and used that no problems since. :)
  22. Stephan (VS)

    [Contribution] Mindsparx admin

    I'm encountering a problem with the new enhanced fly-out menu. Only Administrators (one without more than 1 option) works whereas the rest simply don't show. Where the admin link goes to: http://localhost/catalog/admin/administrators.php all the others link to: http://localhost/catalog/admin/index.php# <_< but here's the kicker, when I tried later Friday night they worked fine again but Saturday again till now nothing. :blink: I assume it's something to do with my database since i've been adding product VIA ecxel. :huh:
  23. Stephan (VS)

    [Contribution] Mindsparx admin

    YAY Works perfectly, thanks Janne I'l do the update tonight and make the skin adjustment. PS any colour/theme you'd prefer?
×