Jump to content

multimixer

♥Ambassador
  • Content count

    4,733
  • Joined

  • Last visited

  • Days Won

    72

Everything posted by multimixer

  1. multimixer

    [Contribution] Define Content 1.x Support

    I just want to say that this one is a real great thing ! Thank you very much Todd !
  2. multimixer

    Multiple categories per product..

    You have the option to "duplicate" or to "link" the product. (Kyriaki proi alli douleia den exoume ? :)
  3. Hi Sam I added the contribution and all shop disappeared :( I will search why and give it an other try. Anyway, I restored the store and no problem, the only thing that remain is the product listing option in the configuration of admin. How to remove this?
  4. multimixer

    [Contribution] Additional Images Module

    I have both installed and it works perfect !
  5. multimixer

    Dynamic SiteMap

    What kind of changes STS users should do? I just installed version v3.5.6 and everything looks fine, no problem at all, .xml files are getting updated
  6. multimixer

    Header Tags SEO

    Hi again Jack and Bill If somebody has to say thank you here, then its me, you do all the great job, me (and the others) have just to find out how it works. I found out that the problem was with STS, in real with me, in the moment I was writing to bill that "no, I've just the default template enabled" i had an other look and tam tam, the product template was enabled without the headertags code of course. And I was expecting it to work :( I'm happy that it was just my stupidness ! And thank you for the programs and the great support, it sounds like not real all
  7. multimixer

    Header Tags SEO

    Hi Jack, I'm also trying my skills with the great thing you did here, but, of-course, some problems ! I installed HeaderTagsSEOV3 on an existing store (with STS) and everything looks fine. I can change titles, descriptions and keywords on all files (index.php, specials.php, products_new.php etc) exept one: The file product_info.php. Here I get permanently the default store name. In the same time I'm getting the message :" Found Missing Tags: Products table has 3 items with missing meta tag information" I think I did everything correctly: 1) I ran "add missing pages" 2) I did "fill tags" getting a confirmation message 3) When going to "categories/products", viewing the product info there, I can see that all tags (title, description, keyword) are filled in. 4) The "test" shows me Missing Code in File The Header Tags head code for the index.php file cannot be found. The Header Tags head code for the product_info.php file cannot be found. The Header Tags head code for the product_reviews.php file cannot be found. The Header Tags head code for the product_reviews_info.php file cannot be found. The Header Tags head code for the product_reviews_write.php file cannot be found. The Header Tags head code for the specials.php file cannot be found. But I think thats ok, because of STS What I try to do, and fail, is 1) I go to page control and choode "product_info.php" 2) I fill out the fields (with all possible combinations of the "include" part I still get the default store name. When pressing on "view result" the page title is yellow with the default store name, both other fields are red and empty Reading the previous posts here 1) I unistalled and reinstalled everything 2) I replaced the file header_tags.php 3) I replaced my admin/includes/categories.php with the one in the package No result Where can the problem be?
  8. multimixer

    [Contribution] Define Content 1.x Support

    Hi Todd. After additional images, I installed aso the "define content" and everything is great, thank you very much. Now an issue with the contribution "HeaderTags SEO V3", in file /includes/header.php 1) According to their instruction the line <td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'store_logo.png', STORE_NAME) . '</a>'; ?></td> needs to be replaced by <?php /*** Begin Header Tags SEO ***/ ?> <td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'store_logo.png', (tep_not_null($header_tags_array['logo_text']) ? $header_tags_array['logo_text'] : STORE_NAME)) . '</a>'; ?></td> <?php /*** End Header Tags SEO ***/ ?> 2) This line don't exist anymore in my header.php, because the lines <table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr class="header"> <td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'store_logo.png', STORE_NAME) . '</a>'; ?></td> <td align="right" valign="bottom"><?php echo '<a href="' . tep_href_link(FILENAME_ACCOUNT, '', 'SSL') . '">' . tep_image(DIR_WS_IMAGES . 'header_account.gif', HEADER_TITLE_MY_ACCOUNT) . '</a> <a href="' . tep_href_link(FILENAME_SHOPPING_CART) . '">' . tep_image(DIR_WS_IMAGES . 'header_cart.gif', HEADER_TITLE_CART_CONTENTS) . '</a> <a href="' . tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL') . '">' . tep_image(DIR_WS_IMAGES . 'header_checkout.gif', HEADER_TITLE_CHECKOUT) . '</a>'; ?> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="1"> are replaced because of define content by <?php // BOF: Define Content ?><?php echo tep_get_defined_content('Page Header'); ?><?php // EOF: Define Content ?> 3) Because I want to use both contributions, I lest the "Define content" line as it was and I added <table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr class="header"> <?php /*** Begin Header Tags SEO ***/ ?> <td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'store_logo.png', (tep_not_null($header_tags_array['logo_text']) ? $header_tags_array['logo_text'] : STORE_NAME)) . '</a>'; ?></td> <?php /*** End Header Tags SEO ***/ ?> <td align="right" valign="bottom"><?php echo '<a href="' . tep_href_link(FILENAME_ACCOUNT, '', 'SSL') . '">' . tep_image(DIR_WS_IMAGES . 'header_account.gif', HEADER_TITLE_MY_ACCOUNT) . '</a> <a href="' . tep_href_link(FILENAME_SHOPPING_CART) . '">' . tep_image(DIR_WS_IMAGES . 'header_cart.gif', HEADER_TITLE_CART_CONTENTS) . '</a> <a href="' . tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL') . '">' . tep_image(DIR_WS_IMAGES . 'header_checkout.gif', HEADER_TITLE_CHECKOUT) . '</a>'; ?> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="1"> into the "header definition" og define content in the admin panel Because I don't really know how all this works, I'm just trying to discover it, my question is if I did correctly or what i did is just a stupidness
  9. multimixer

    contribution for multiple images ?

    I think there are more than one. I used "additional images v.2.1.0" that works great.
  10. multimixer

    [Contribution] Additional Images Module

    Now I can confirm that everything works perfectly. ! There is absolutely no problem with STS in any configuration. For people who use the RC2a version of osc, just don't change the /includes/classes/boxes.php file
  11. multimixer

    [Contribution] Additional Images Module

    I just reinstalled, and everything works fine. A strange thing: In the moment I change the includes/classes/boxes.php all the store disappears. Right now all files are changed except this one, and it works. Should I leave it in this way? What I do wrong exactly there? No problem with STS, I've just the default template, no index page and no product page template. I don't know if adding this templates, but i think it will be ok
  12. multimixer

    [Contribution] Additional Images Module

    I just wonder why do you need a rolover function on the popup picture. Yu can have the product info pictures small (+rolover if you want) and you can make the popup as big as you like
  13. multimixer

    [Contribution] Additional Images Module

    I know the line is different in RC2a, like other lines too. I didn't know what exactly to merge-replace. Anyway, I unistalled everything again and will give it a new try What you mean is to merge ONLY the "//BOF:Additional image" code in ALL files that have to be changed, and nothing else, right? I hope there are no compatibility issues with RC2a, also not with STS that I've installed already, because I know that I'm not able to fix them ! Thank you for the reply surfalot, and for the contribution !
  14. multimixer

    [Contribution] Additional Images Module

    Hi I just added the additional images module and think that I did everything correctly 1) I uploaded the files to upload 2) I installed he database 3) I edited the files to edit using files comparison In the admin panel everything looks fine, all options are available. When going to the shop, I'm getting the message "Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory" When uncommenting // check if register_globals is enabled. // since this is a temporary measure this message is hardcoded. The requirement will be removed before 2.2 is finalized. if (function_exists('ini_get')) { ini_get('register_globals') or exit('Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.'); } I'm getting an empty page What to do now? I'm using osc version 2.2rc2a I hope somebody can help, because I'm really confused and know that I did something wrong
×