Jump to content

brett

Members
  • Content count

    98
  • Joined

  • Last visited

  1. brett

    Multi-Stores Multiple Shops Support

    so if anyone's interested: I got the featured_products contribution working with this by created seperate featured tables in the database [ie yankees_featured, redsox_featured, cubs_featured] and dropped identical structures into each of them. Then I went through each store's catalog and altered the appropriate places where it calls for TABLE_FEATURED to the according featured table. the only problem with this is that you have to hard edit the URL to go to the respective store's admin area to make changes. i guess that you have to do that with everything though... if you have any questions, let me know. i'm not a pro, but gettin closer. thanks for the freaking awesome contribution. I think I will use this in the future for other stores I create and so-on. you guys are awesome. -brett
  2. brett

    Multi-Stores Multiple Shops Support

    hmm, interesting. so what i did was DELETE the yankees_configuration table, then recreate just the STRUCTURE of the table. Then i went into the admin on osC, went to stores, deleted the yankees store. Then I added the yankees store again, with the URL and set it to yankees_configuration and default table option selected. The errors I was having were magically fixed. It's because the contrib needs to create the table values itself rather than allowing the user to input them manually using phpmyadmin or anything like that. Now all i have to do is get the featured_products contrib working :) ....I haven't even started that yet. let me know if anyone is interested in the updated files to work with featured_products. I should have it fixed up in a few days. Thanks for the awesome contrib... once again, my career is saved :) =brett=
  3. brett

    Multi-Stores Multiple Shops Support

    hey sam, from what i've gathered, this is a slight bug in the contrib. the contrib is setup to create a NEW table, but since you've already created it in mySQL it doesn't know what to do. I have a similar problem and I'm just going to overlook it right now since it doesn't really have any functionality problems. the contrib is still great and works well for most people, so i'm gonna stick with it too... hopefully i can work it out soon. anyway, on to my question: check this out: http://www.proteamshop.com/catalog http://www.proteamshop.com/yankees I cant get products to show up in the yankees site, but they will show up in the /catalog/ site if i enable them. Does anyone have any ideas? thanks in advance~ =brett=
  4. brett

    Multi-Stores Multiple Shops Support

    hey peter, thanks for the help. I figured it out later that i needed to create a new configuration table that wasn't YANKEES_CONFIGURATION = yankees_configuration, but rather CONFIGURATION = yankees_configuration. but now, i get the most interesting error of all~! 1064 - You have an error in your SQL syntax near 'EXPECTED_PRODUCTS_SORT limit MAX_DISPLAY_UPCOMING_PRODUCTS' at line 1 select p.products_id, pd.products_name, products_date_available as date_expected from products p, products_description pd where to_days(products_date_available) >= to_days(now()) and p.products_id = pd.products_id and pd.language_id = '1' order by EXPECTED_PRODUCTS_FIELD EXPECTED_PRODUCTS_SORT limit MAX_DISPLAY_UPCOMING_PRODUCTS [TEP STOP] .......i think this is because of my featured products mod. any ideas?
  5. brett

    Multi-Stores Multiple Shops Support

    Hey All, I am pretty sure I did mostly everything correctly, but it's obvious I didn't. Every time I try to type in the store config table under admin>catalog>stores, I get the following error. Any ideas? 1064 - You have an error in your SQL syntax near 'TO yankees_configuration' at line 1 RENAME TABLE TO yankees_configuration [TEP STOP] Thanks, =brett=
  6. hey all, as some of you know, i've had a horrrrrrible time with the easy populate contrib. It worked for awhile, but then stopped working. I got into mySQL and figured out that it's probably because the way the database looks... easy pop didn't like it much. here's the deal~ along the top of the spreadsheet it has 4 rows of tags... here's an example: v_products_name_1 v_attribute_values_price_1_10 v_attribute_values_name_1_21_1 v_attribute_values_id_1_33 then begins the data in the column below that.... THEN, the other weird thing about this is that there are dates listed in the data for the products. These columns have no header tags. I dont know what the heck is going on, but I need to fix this before I can continue. Anyone have any thoughts? I can email or PM you with my database. I can reward accordingly. thanks, -brett
  7. Hello All, For some reason I can't download the complete or the model/attributes databases. the other ones are all okay and i'm led to believe that it's because they dont contain the attributes... does anyone have any ideas why this is? I can't figure it out. thanks in advance~ =brett=
  8. brett

    Products Description Hack

    and it's fixed.... thanks for the help Henry... and thanks especially to Terry for giving me the conceptual help. www.seattleteams.com/catalog ciao! =brett=
  9. so, i think my version of easy pop is messed up. i'm trying to edit my database, but i can't DL it to edit anything.... i've got 900 products and it just gets stuck as it DLs off the site. is there a timeout issue or something that i am not compensating for? ...i know 900 isn't alot, but it sure feels like it after it trys to download for awhile. thanks in advance~ =brett=
  10. brett

    Products Description Hack

    sorry about that... i should've guessed with the cute little kitty ;) girl coders are awesome, by the way! -brett
  11. I have just installed the products description Hack and I'm trying to create two DIFFERENT classes rather than the current single class in css for the PRODUCT_LIST_NAME and PRODUCT_LIST_DESCRIPTION ....here's the piece of code that groups both of them together: $lc_params .= 'class="productListing-desc"'; if ($column_list[$col] == 'PRODUCT_LIST_DESCRIPTION') { $list_box_contents[$cur_row][] = array('align' => $lc_align, 'params' => $lc_params, 'text' => $lc_text, 'desc_flag' => 'true'); } else { $list_box_contents[$cur_row][] = array('align' => $lc_align, 'params' => $lc_params, 'text' => $lc_text); } that "params" is called for both the title and description, thus forcing both of them to have the same style. does anyone have any idea how to make them different? obviously, I have defined in the stylesheet a new class called "product_name" I saw one person who did it, but he hasn't gotten back to me.... any help will be appreciated and/or rewarded. thanks in advance~ =brett=
  12. does anyone know how to differentiate the styles of the description from the title??? That way we could have a bold product title and a smaller description. Right now it looks to be tied to the productListing-data class, how do you make it separate and what do you have to change? ideas would be great! thanks!
  13. nope, that is not my problem at all. infact, my problem is because i dont have a large amount of that code and it's not because I have edited it out. my categories.php file was unedited going into this install, but strangely i'm still missing a few lines of code that should supposedly be there. I even cross-referenced it against a brand new .zipped up categories.php file that i got from the site.... still the same. pllleeeeeaaase help! thanks, =brett=
  14. hey!!! Anyone out there? I'm still desperately in need of the admin/categories.php file. I will gladly help out anyone who emails me at brett@contextdesigns.net with anything I can. thank you sooo much, I'm truly sorry to ask for your time, but I imagine it'd only take a few simple moments. thanks! =brett=
  15. can anyone send me a working example of their admin/categories.php file? i can't seem to get this thing working. a tough contrib for sure! thanks!!! brett ps: email is brett@contextdesigns.net
×