Jump to content

angryquaker

Members
  • Content count

    155
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Russ
  • Location
    Ohio
  • Website
  1. beti.rabiaa@hotmail.com

    Hello.

    My Name is Betty Rabia i was impressed when i saw your profile at oscommerce.com and l will like you to email me back to my in box so that i can send you my picture for you to know who i am .i belive we can establish a long lasting relationship with you.In addition,i will like you to reply me through my private email box (beti.rabiaa@hotmail.com) This is...

  2. Go to the contributions section, search on "gift voucher," "gift card," and so forth. You'll find several add-ons that will allow you to do something close to what you wish to do, however, I don't think any of them will automatically credit anyone for signing up a new account. I could be wrong on that, there may be one that will. At worst, the customer would need to wait for you to manually add the gift card or voucher, or whatever you decide to use. If it were me getting $100 worth of free stuff, I can't say I'd mind terribly waiting overnight. heheh You didn't mention the URL of the site where you're doing this promotion. ;) Namasté, Russ
  3. angryquaker

    Header Tags SEO

    Thanks, Jack. I bet you're right, other languages hadn't crossed my mind, as I only use English. And spot-checking some products, they all seem to have a correct title, meta keywords and descriptions, so that must be it. I'm still getting some duplicate tag warnings on Google, but that appears to be due to product listing pages that are sorted in different ways. I didn't realize Google would do that when crawling the site. I'll have to look into blocking those pages or something, as I definitely don't want to get kicked off Google for spamming keywords or some such. Namasté, Russ
  4. angryquaker

    Header Tags SEO

    I'm having some difficulty filling tags automatically, or I'm misunderstanding something somewhere. I've run the "Fill Tags" several times, and I've manually added some tags via admin->categories->product edit. So, whenever I go to the "Page Control" page, I still get the red error message up top saying Found Missing Tags: Products table has 78 items with missing meta tag information.Categories table has 26 items with missing meta tag information. In "Page Control" for product_info.php, I have Category checked, sort order 1; Product checked, sort order 2; Root checked, sort order 10. Running "Fill Tags" with "fill only empty tags" goes really quick, and then returns about 78 products with "The name for this item is missing." So do I need to go thru and manually tag every product? Or am I missing something somewhere else? I don't think I've even listed 78 products, 39 sounds closer, and 26 is twice the number of categories that I have. I just counted. I don't get it. Thanks. Namasté, Russ EDIT - Looking at the "headertags" table in phpMyAdmin, I see that most of the pages are listed 3 times, some are listed twice. What did I do? And what should I do to fix it?
  5. angryquaker

    osC reCaptcha

    Whoops. This post was originally regarding a reCaptcha box not appearing on the contact_us page, but in looking again, I discovered that I'd inserted the code from the install instructions in the wrong place. I moved the code to the correct location, everything's peachy now. My mistake, I apologize for cluttering the thread for this excellent add-on. Namasté, Russ
  6. angryquaker

    OSC Socializer v1.0

    Nice add-on, I like it. However, the only way to close the pop-up as it is, is by clicking the actual "CLOSE" button in the top right. I know somewhere, I've seen coding to make a pop-up close when clicked inside or outside, and of course, we wouldn't want to close this one onClick inside (other than the X), but I would like to make it close if clicked outside the window. I didn't bookmark where I saw that coding, and don't recall where it was, and I'm absolutely not qualified to try coding it myself. I did go ahead and try, and I failed miserably and broke the whole thing. LOL Anyway, what code would I add in what spot, to make the Socializer window close if the user clicks outside the window? Any takers? Namasté, Russ
  7. angryquaker

    Header Tags SEO

    OK...I started over with the index page, followed the install instructions, and now I have products appearing again. By cracky, I think I've got it now. I was having some trouble getting the tags to show up, but I think I have that sorted now. Thanks, Jack, for being so patient with me, and for providing all these awesome stuffs for us newbs. I think Ultimate SEO URLs is going to be next on my list, hopefully I won't need to ask 437 questions on that one. ;) Namasté, Russ
  8. angryquaker

    Header Tags SEO

    OK. I've gone back over my installation, re-uploaded the files from the install package, re-read every text file included in the package, and I'm still having problems. Chief among the problems is that my products don't show up when a category is clicked, except for a couple categories now. Most vexing, indeed. Here's a link to my site again: http://www.utopiawellness.com If you click on "Spa Sessions," the page loads with no Title, Keyword, or Description tags, but the Description text that was input from admin/categories appears at the top, followed by the social bookmarks. Between this description and bookmarks, there should be three (3) products, but there are none. All my category pages display this same behavior, with a couple exceptions. "Detox/Cleansing" doesn't have any products added yet, so there shouldn't be any products showing, and there are none. However, "Weight Loss" shows the two products that should be there, and "Wellness Supplements" shows some products, as well as the sub-categories that should be there. BUT, if you click any of those sub-cats to see all the products of a particular brand, it reverts to the same format as "Spa Sessions," no meta tags, no products, just the heading and social bookmarks. In the Trace Minerals sub-cat, there are no products yet, so it should display the message stating that "There are no products in this category," but it doesn't. The two remaining categories don't have sub-cats, and behave the same as "Spa Sessions." Everything in admin appears (to me) to be functioning properly, no error messages, no SQL tep_stops nor anything of that nature. I followed the instructions in "HowToOperate.txt," fill all tags, etc, but still have the same results on the catalog pages. I am completely befuddled. I have no idea why this would be happening, or how to go about making it right. I am somewhat surprised that in almost a year of use, and over 80 pages of thread, no one else has experienced the same issue(s). Seems to be just my luck (or ignorance), I guess. I've tried to describe the issue(s) as thoroughly as possible, if there's other information I should provide, just let me know. At this point, I'm willing to do whatever it takes to get this functioning properly. Please advise. Namasté, Russ
  9. angryquaker

    Header Tags SEO

    Ok, so I am stupid. :blink: Be that as it may, I understand that changing the categories.php in admin doesn't change anything on the "live store" side. What I don't understand is why my products would all disappear from their live category pages. I started installing this package on Friday, didn't have time to do anything with it over the weekend, and honestly don't think I even checked any "live" pages in the interim to see if anything was happening. I waited until this morning, when I thought I was done installing, to start checking things. I shouldn't do these things unless I have time to just sit down and go, start to finish. At any rate, I will go back over the install step by step to see if I've missed something. It's obvious now that I have missed something, and likely more than one thing. I did just check a few files to make sure I didn't get one of the various header_tags.php files in the wrong folder, for instance, but haven't found a culprit thus far. I will keep double checking my installation, just thought someone might know an obvious answer to why my products all went somewhere other than where they should be. I searched this thread, too, thinking that if my products disappeared, someone else's might have as well, but I didn't find any such posts. I apologize for being so thick-headed, and appreciate any further assistance. Namasté, Russ PS - The Site In Question is "live," but thank heavens, has not been actively promoted as yet. That's why I haven't set up a "test bed" site, or installed XAMP or similar for testing. I should probably do that, too, tho. I didn't forsee having so many problems, but then again, no one expects The Spanish Inquisition. <_<
  10. angryquaker

    Header Tags SEO

    Geez, I'm starting to feel like a simpleton. For whatever reason, the categories.php file included in the RC2 is working in my admin section just fine. All my add-ons appear to be functioning as normal. But now I notice that on the live site, no products are showing up when a category is selected. http://www.utopiawellness.com For instance, if you click on "Hemi-Sync CDs," 12 products should show up, but they don't. Also, the "default" title, description and keywords are showing in the source, after I put in a custom description in admin/categories. The "Header Tags Category Description" shows up at the top of the page, followed by the Social Bookmark links, but no products. None of the code to display the products shows up in the source, either. If I go directly to a product's info page, the meta tags are like: <title>products new home - Fat Grabbers</title> <meta name="Description" content="products new description - Benefits: •Helps decrease the body's absorption of fat. •Helps maintain cholesterol levels that are already within the normal range. Fa" /> <meta name="Keywords" content="products new keywords1,keywords2 , Fat Grabbers" /> Please tell me I've overlooked something relatively simple, and that I'm not completely stupid. I feel fairly stupid at this point. LOL Namasté, Russ
  11. angryquaker

    Header Tags SEO

    OK, then I guess I could try going from a different angle. Rather than modifying my categories file with the HTSEO stuff, I'll use the file included with HTSEO, and add the modifications that I had before, one at a time, and see how that goes. Sound logical? Namasté, Russ EDIT: I'm still seeing the other add-ons in the Categories section, Specials By Category, Define Mainpage, Online Gift Cards, etc, all show up and appear to be working. Is that normal, or does it sound like I'm putting a categories.php in the wrong place?
  12. angryquaker

    Header Tags SEO

    Thanks, Jack. I installed the categories.php from the RC2 folder in the install package, and I no longer get the error message previously referenced. Should I just leave that file there as it is, or do I need to continue troubleshooting my modified categories.php? In my previous post, I should have said there is no difference between my categories.php and the one from the install package AT LINE 728. There are many other differences, due to other add-ons, I'd presume. Namasté, Russ
  13. angryquaker

    Header Tags SEO

    I was able to fix the first error in my categories.php file, now I'm getting a new one. In the admin side, if I click on "Catalog," the URL it tries to go to is: www . utopiawellness.com/admin/categories.php?selected_box=catalog I seem to recall reading that if the URL includes categories.php, I've done something wrong. The new error message is: Parse error: syntax error, unexpected '}' in /home/utopiawe/public_html/admin/categories.php on line 728 Lines 698-740: <?php } ?> <tr> <td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td> </tr> <tr> <td class="main"><?php echo TEXT_PRODUCTS_WEIGHT; ?></td> <td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_input_field('products_weight', $pInfo->products_weight); ?></td> </tr> <!-- gift card modification //--> <tr> <td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td> </tr> <tr> <td class="main"><?php echo TEXT_PRODUCTS_GIFT_CARD; ?></td> <td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . tep_draw_checkbox_field('gift_card', '1', ($pInfo->products_gift_card == '1') ? true : false) . TEXT_PRODUCTS_GIFT_CARD_INFORMATION; ?></td> </tr> <!-- end of gift card modification //--> </table></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td> </tr> <tr> <td class="main" align="right"><?php echo tep_draw_hidden_field('products_date_added', (tep_not_null($pInfo->products_date_added) ? $pInfo->products_date_added : date('Y-m-d'))) . tep_image_submit('button_preview.gif', IMAGE_PREVIEW) . ' <a href="' . tep_href_link(FILENAME_CATEGORIES, 'cPath=' . $cPath . (isset($HTTP_GET_VARS['pID']) ? '&pID=' . $HTTP_GET_VARS['pID'] : '')) . '">' . tep_image_button('button_cancel.gif', IMAGE_CANCEL) . '</a>'; ?></td> </tr> </table></form> <?php /*** Begin Header Tags SEO ***/ ?> <?php } elseif ($action == 'new_product_preview') { [color="#FF0000"]<--- line 728[/color] if (tep_not_null($HTTP_POST_VARS)) { $pInfo = new objectInfo($HTTP_POST_VARS); $products_name = $HTTP_POST_VARS['products_name']; $products_description = $HTTP_POST_VARS['products_description']; $products_head_title_tag = $HTTP_POST_VARS['products_head_title_tag']; $products_head_desc_tag = $HTTP_POST_VARS['products_head_desc_tag']; $products_head_keywords_tag = $HTTP_POST_VARS['products_head_keywords_tag']; $products_url = $HTTP_POST_VARS['products_url']; } else { $product_query = tep_db_query("select p.products_id, pd.language_id, pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_desc_tag, pd.products_head_keywords_tag, pd.products_url, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'"); $product = tep_db_fetch_array($product_query); /*** End Header Tags SEO ***/ In WinMerge, there is no difference between my file, and the "stock" categories.php file from the install package (RC2 version). If I remove the closing bracket "}" on line 728, then I get a T_ELSEIF error on the same line. Additionally, using the "Test" feature in HTSEO, the following errors are shown: Permissions Error: Permissions settings for the /home/xxxxxx/public_html/includes/header_tags.php file appear to be incorrect. Change to 755. NOTE: Disregard if on Windows server. (**This file is set to 755, I just double-checked, and I'm on a Linux/Apache server). Missing Code in File The Header Tags head code for the product_reviews.php file cannot be found. The Header Tags head code for the product_reviews_info.php file cannot be found. The Header Tags head code for the product_reviews_write.php file cannot be found. The Header Tags head code for the specials.php file cannot be found. Language Mismatch Error: Language ID 1 in default Header Tags table does not exist in the shops languages. Language ID 1 in default Header Tags table does not exist in the shops languages. Thanks in advance for any further insight as to what I'm screwing up here. I'm rotten at coding, however, I'm quite adept at copy & pasting. If needed, I can provide any further snippets, just say the word. Namasté, Russ
  14. angryquaker

    Header Tags SEO

    I just installed this add-on, and get this error when going to the Categories page in admin: Parse error: syntax error, unexpected T_DOUBLE_ARROW in /home/utopiawe/public_html/admin/categories.php on line 279 I've never used WinMerge, but I just DLed it to give it a whirl. Meanwhile, here's the chunk of code referenced by the above error: lines 270-294 $languages = tep_get_languages(); for ($i=0, $n=sizeof($languages); $i<$n; $i++) { $language_id = $languages[$i]['id']; $sql_data_array = array('products_name' => tep_db_prepare_input($HTTP_POST_VARS['products_name'][$language_id]), 'short_desc' => tep_db_prepare_input($HTTP_POST_VARS['short_desc'][$language_id]), 'products_description' => tep_db_prepare_input($HTTP_POST_VARS['products_description'][$language_id]), 'products_url' => tep_db_prepare_input($HTTP_POST_VARS['products_url'][$language_id])); /* Header Tags SEO */ 'products_head_title_tag' => ((tep_not_null($HTTP_POST_VARS['products_head_title_tag'][$language_id])) ? tep_db_prepare_input($HTTP_POST_VARS['products_head_title_tag'][$language_id]) : tep_db_prepare_input($HTTP_POST_VARS['products_name'][$language_id])), 'products_head_desc_tag' => ((tep_not_null($HTTP_POST_VARS['products_head_desc_tag'][$language_id])) ? tep_db_prepare_input($HTTP_POST_VARS['products_head_desc_tag'][$language_id]) : tep_db_prepare_input($HTTP_POST_VARS['products_name'][$language_id])), 'products_head_keywords_tag' => ((tep_not_null($HTTP_POST_VARS['products_head_keywords_tag'][$language_id])) ? tep_db_prepare_input($HTTP_POST_VARS['products_head_keywords_tag'][$language_id]) : tep_db_prepare_input($HTTP_POST_VARS['products_name'][$language_id]))); /*** End Header Tags SEO ***/ if ($action == 'insert_product') { $insert_sql_data = array('products_id' => $products_id, 'language_id' => $language_id); $sql_data_array = array_merge($sql_data_array, $insert_sql_data); tep_db_perform(TABLE_PRODUCTS_DESCRIPTION, $sql_data_array); } elseif ($action == 'update_product') { tep_db_perform(TABLE_PRODUCTS_DESCRIPTION, $sql_data_array, 'update', "products_id = '" . (int)$products_id . "' and language_id = '" . (int)$language_id . "'"); } } I've got my admin/categories page, and the one from the HTSEO package (RC2) open in WinMerge now, but I'm not the reason for the error. I did have to modify the installation slightly in a couple spots, to acommodate the Short Descriptions add-on, perhaps that's it? I'll continue poking around, if anyone sees the problem, I'd appreciate any help. I don't really understand any of this coding stuff outside the HTML, and I'm nice and rusty on that, to boot! :) Namasté, Russ
  15. angryquaker

    "Dynamenu" for osCommerce

    I commented out the bit with the original cat box, thus: /* if ((USE_CACHE == 'true') && empty($SID)) { echo tep_cache_categories_box(); } else { include(DIR_WS_BOXES . 'categories.php'); } */ then added the dm box with the include line as you indicated. This seemed to get rid of the original cat box, and displayed the dm menu in its place. I didn't notice any changes on other parts of the site as a result. However, I had problems with the dm menu which caused me to forego it, at least for now. Wish I could be of more assistance, and good luck to you. Namasté, Russ
×