Jump to content

jrd1mra

Members
  • Content count

    25
  • Joined

  • Last visited

  1. jrd1mra

    Header Tags SEO

    I hope that jack doesnt mind me answering this, as I actually ran into the same problem. It doesnt have a thing to do with Header Tags SEO. The short of it is, you have to use robots.txt with wildcards which will prevent those urls from being spidered, also you should be able to tell your sitemap program not to include urls with certain substrings in the sitemap. PM me for more details, so this thread can stay about HTC In the long run, it wont hurt you either way... Its really not anything to stress too bad over.
  2. jrd1mra

    Header Tags SEO

    Yes, I had overlooked adding the header_tags to include for the content templates. It works now what about header_tags_seo.txt file? Is that just a list of keywords related to my store which I need to create and upload?
  3. jrd1mra

    Header Tags SEO

    If I am understanding you correctly you uploaded the files for RC2 as they are AFTER you installed STS4. If you have anything other than the default you must updated teh pages manually. Also try and see if your store works when you turn off STS. that way you can pinpoint the problem.
  4. jrd1mra

    Header Tags SEO

    Hi, I installed this contribution and my shop runs STS. I have gone over the code edits twice and am still running into the same problem. The problem is that on my product_info pages the title tag is not being updated by Header Tags SEO. All of my other pages have been updated by HTSEO using teh fill tags or custom title updates. I just cant seem to get the product_info.php file to get updated. I tried filling the tag and tried manually writing a title through HTSEO backend. The header tags code is on the page in the same place as the code on all of the other pages. So I am lost as to why it will not work... When i run the test module for HTSEO this is the result I get: Missing File Error: Cannot find file D:/[path]/www/store/backend/includes/header_tags_seo_words.txt. Missing Code in File The Header Tags head code for the index.php file cannot be found. The Header Tags head code for the product_info.php file cannot be found. The Header Tags head code for the product_reviews.php file cannot be found. The Header Tags head code for the product_reviews_info.php file cannot be found. The Header Tags head code for the product_reviews_write.php file cannot be found. The Header Tags head code for the specials.php file cannot be found. 1. the header_tags_seo.txt file, I could not find that anywhere in the installation... My other title tags filled fine w/o it however. 2. The missing code errors... The code is on the pages I need it to be (index.php and product_info.php) 3. This confuses me because as I said, using HTSEO to fill the index.php info is working just fine, but it is not working on the product_info.php Now I have a little bit of an odd set up in my shop... The index.php is actually the products_new.php code. In other words I just erased all the code from index.php and replaced it with the code from products_new.php BEFORE I installed HTSEO. I am assumiong this doesnt have anything to do with my problem since the code on index.php is pulling the titles from HTSEO. Can you think of why this problem with product_info.php is happening?
  5. I had this same problem and I found a "duct tape" fix. I am no programming expert but this worked for me. It removes your shipping zone exclusions completely so if you need to use that part of this contribution this fix will not work for you. This is what I did: open: admin\includes\languages\english\coupons_exclusions.php around line 42 find: //shipping zone exclusions case 'zones' : $heading_available = 'This coupon may be used in these shipping zones.'; $heading_selected = 'This coupon may <b>not</b> be used in these shipping zones.'; break; //end zone exclusions Replace with: /*** //shipping zone exclusions case 'zones' : $heading_available = 'This coupon may be used in these shipping zones.'; $heading_selected = 'This coupon may <b>not</b> be used in these shipping zones.'; break; //end zone exclusions **/ open: catalog\includes\classes\discount_coupons.php Around line 71 find: //shipping zone exclusions $check_user_query = tep_db_query($sql = 'SELECT dc2z.geo_zone_id FROM '.TABLE_DISCOUNT_COUPONS_TO_ZONES.' dc2z LEFT JOIN '.TABLE_ZONES_TO_GEO_ZONES.' z2g USING( geo_zone_id ) WHERE ( z2g.zone_id='.$delivery['zone_id'].' or z2g.zone_id = 0 or z2g.zone_id IS NULL ) AND ( z2g.zone_country_id='.$delivery['country_id'].' or z2g.zone_country_id = 0 ) AND dc2z.coupons_id="'.tep_db_input( $code ).'"' ); if (tep_db_num_rows( $check_user_query ) > 0 ) { $this->message( ENTRY_DISCOUNT_COUPON_ERROR ); //display the error message //use this to debug exclusions: //$this->message( 'Shipping Zones exclusion check failed' ); } //end shipping zone exclusions Replace with: /*** //shipping zone exclusions $check_user_query = tep_db_query($sql = 'SELECT dc2z.geo_zone_id FROM '.TABLE_DISCOUNT_COUPONS_TO_ZONES.' dc2z LEFT JOIN '.TABLE_ZONES_TO_GEO_ZONES.' z2g USING( geo_zone_id ) WHERE ( z2g.zone_id='.$delivery['zone_id'].' or z2g.zone_id = 0 or z2g.zone_id IS NULL ) AND ( z2g.zone_country_id='.$delivery['country_id'].' or z2g.zone_country_id = 0 ) AND dc2z.coupons_id="'.tep_db_input( $code ).'"' ); if (tep_db_num_rows( $check_user_query ) > 0 ) { $this->message( ENTRY_DISCOUNT_COUPON_ERROR ); //display the error message //use this to debug exclusions: //$this->message( 'Shipping Zones exclusion check failed' ); } //end shipping zone exclusions ***/ Open admin\coupons.php around line 293 find: '<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS_EXCLUSIONS, 'cID='.$cInfo->coupons_id.'&type=zones') . '">' . tep_image_button('button_shipping_zone_exclusions.gif', IMAGE_SHIPPING_ZONE_EXCLUSIONS, 'hspace="2" vspace="2"') . '</a> ' Replace with: /** .'<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS_EXCLUSIONS, 'cID='.$cInfo->coupons_id.'&type=zones') . '">' . tep_image_button('button_shipping_zone_exclusions.gif', IMAGE_SHIPPING_ZONE_EXCLUSIONS, 'hspace="2" vspace="2"') . '</a> ' **/ This just comments out the code which executes the shipping zones script. Thats what I did and I do not receive the sql syntax error any longer. . I actually dont receive it after I fix the catalog\includes\classes\discount_coupons.php file. The rest of the code is simply to remove the shipping zones from view so that It is not used since removing the code in the discount_coupons.php file breaks that portion of the module. I hope this helps, use at your own risk it has not been extensively tested. This contribution is OK. It does not work out of the box for most people. I suggest that it be removed as the original creator has obviously given up on it.
  6. jrd1mra

    [Contribution] STS v4

    I figured out the problem, I was not including $optionnames$ $optionchoices$ in my product_info Content template. I assumed since I only had one option, that would be windows/english that it was unnecessary. It turns out without it it would not provide the download link. Once I added them the problem was fixed. Also your thread you suggested above about downloadable products should be included in the OScommerce user guide. That makes the set up of virtual products simple and easy. No where in that guide does it say that you need to select an option and option value in order for downloads to work properly. Your product is great, I am now ready to go live!
  7. jrd1mra

    [Contribution] STS v4

    I had a similar problem and I renamed all of my download folders, made sure the new name was reflected in the config file, made double sure that the two renamed folders , formerly pub and download were set to have read and write permission (777 on apache). I also renames all of my download files to a short one word file name like file1. ext file 2.ext. All of my downloads worked fine after that. They are all over 150 MB. Also, make sure whatever user you are using to test has an empty cart and no orders before each test. I have posted a new problem above however that seems to be related to the product_info template, maybe Bill will be able to shed some additional light on this
  8. jrd1mra

    [Contribution] STS v4

    Hello Bill, I am having a problem with virtual products and STS Product_info templates. I installed osCommerce rc2.2 uploaded all my virtual products and verified they were able to be purchased and downloaded, I then installed STS 4.5.8 created an index.php.html and a default.php.html template and it works with the downloadable products as well until I ask it to use templates for the product_info.php pages. Once the use product_info templates option in the STS Module is activated I Can not download my products... It seems to treat them as if they were niot virtual products, it asks me for shipping information and never offers a download link once the purchase is complete. I use a default template globally and I created a content template, named it product_info.php.html and placed it in sts_templates/[mytemplate]/content folder. Thanks in Advance
  9. jrd1mra

    Easy question

    try <table style="background-image:url(/images/image.gif) repeat;"> or give the table an id <table id="main"> and then place #main {background-image:url(/images/image.gif) repeat;} in your style sheet
  10. jrd1mra

    [Contribution] STS v4

    Thanks for your help bill. I did see that in the manual but after seeing how easy it was to edit the other content sections I thought I was reading it wrong. I have been a little confused trying to wrap my head around installing and configuring oscommerce and three contributions with no previous experience with oscommerce.
  11. jrd1mra

    [Contribution] STS v4

    I use one template file for my whole site. I figured out how to change the look of the product_info $content placeholder Now, is there any way to create a template for the $content placeholder of the store index.php.html template? or do I have to edit the index.php file manually? Thanks in advance for your help
  12. jrd1mra

    [Contribution] STS v4

    I posted the below in the general section and did not geta response, I was wondering if there is a way to do the following with STS. I simply want to make the index.php page display exactly how the products_new.php page displays. Since I only have 12 products this would be ideal. I also have been trying for a few hours now to make it work and am lost... Thanks Hello, I am almost done with my template. All that I want now is to change how the index page displays products. as a mater of fact i want it to look exactly like the new products page. I am only going to have 12 products, with no categories so this look works for me. I want www treatmentsolutionsnetwork.com/store to look like www treatmentsolutionsnetwork.com/store/products_new.php Any ideas?
  13. jrd1mra

    [Contribution] STS v4

    Thanks! That was exactly what i was looking for. I am showing three products so i just put $randombox three times, I am sure you have a way to set the script to show x number but this worked for me.
  14. jrd1mra

    [Contribution] STS v4

    I am using latest version of STS with HTC on oscommercev2.2rca I am only selling 12 products so I have not set up any category/manufaturer besteseller or all that jazz. All that I currently have is the $whatsnewbox. What I would like is simply to display 3 or 4 random selections of my products in that box. When I use the $whatsnewbox I only get one product. I was looking for a template placeholder which will display a Specific product or a random product. Any ideas on how to do this?
  15. jrd1mra

    [contribution] Simple Template System (sts)

    IGNORE, I am going to post in the sts v4 forums as thats the version I have. Soory I need to read better.
×