Jump to content

meanrabbit

Members
  • Content count

    12
  • Joined

  • Last visited

Profile Information

  • Real Name
    meanrabbit
  1. I ran this SQL query and the imaze size shows in admin under Images INSERT INTO `configuration` VALUES (200, '200', 'INFO_SMALL_IMAGE_WIDTH', '100', 'The pixel width of small images', 4, 20, NULL, '', NULL, NULL); INSERT INTO `configuration` VALUES (201, '275', 'INFO_SMALL_IMAGE_HEIGHT', '80', 'The pixel height of small images', 4, 21, NULL, '', NULL, NULL); The problem is it is not available on the product entry page in admin, is there a way to create a new imaze size and have it appear as an image selection field in the product entry page so the value can be used to replace the $small_image size used by osCommerce by default I am using additional images and there seems no way to create a different size product page main image This makes no sense to me, I have tried every combination I must be missing something If anyone has run in to this issue, please let me know how you solved your product page display image issues Thanks
  2. Thanks for a 'ludicrous speed' reply! Following the instructions worked well :)
  3. Not 100% sure this is due to the contrib, but shortly after installing I noticed I now get this error in admin when attempting to insert a new manufacterer Fatal error: Call to undefined function: tep_get_manufacturer_description() in /hsphere/local/home/compuexp/shop.teknmotion.com/catalog/admin/manufacturers.php Any insight would be greatly appreciated Everything else is working perfectly Thanks!
  4. I have been trying to find a graceful way of using a larger image for the main product pic with 'Additional Image Contribution' code below (or another way?) on the product page instead of pulling the $small_image for the main product image, I would like to display the medium size image (or a 200x275px image) through the Image configuration through admin using that setting to set size Or really anyway possibe -even hard coded into the code below I tried changing every variable below, and could not fiqure it out // Light Box J Query with ultra Pics 2.08 Add on BOF $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, p.products_image_med, p.products_image_lrg, p.products_image_sm_1, p.products_image_xl_1, p.products_image_sm_2, p.products_image_xl_2, p.products_image_sm_3, p.products_image_xl_3, p.products_image_sm_4, p.products_image_xl_4, p.products_image_sm_5, p.products_image_xl_5, p.products_image_sm_6, p.products_image_xl_6, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'"); // Light Box J Query with ultra Pics 2.08 Add on EOF <!-- Light Box J Query with ultra Pics 2.08 Add on BOF --> <?php $small_image = $product_info['products_image']; $popup_image = $product_info['products_image_med']; if ($popup_image == '') $popup_image = $small_image; echo '<a href="' . tep_href_link(DIR_WS_IMAGES . $popup_image) . '" target="_blank" rel="prettyOverlay[gallery]" title="' . $product_info['products_name'] . '">' . tep_image(DIR_WS_IMAGES . $small_image, $product_info['products_name'], ULT_THUMB_IMAGE_WIDTH, ULT_THUMB_IMAGE_HEIGHT, 'hspace="1" vspace="1"') . '<br/>' . tep_image_button('image_enlarge.gif', TEXT_CLICK_TO_ENLARGE) . '</a>'; ?> <!-- Light Box J Query with ultra Pics 2.08 Add on BOF --> HELLLLLLP! :) Thanks!!
  5. Hi, I installed this fine contrib below and it overwrote and corrected the issue Product Listing Enhancements, Thumbnails & Manufacturer Headings V1.8 http://forums.oscommerce.com/index.php?sho...code+image+size Sorry I could not be more specific, still learning and breakin' stuff ;)
  6. I am not sure what will be the best yet to suit the final design, I really like having as many choices as possible which this really added to the possibilities. I like the grid with thumbnails I know this is asking alot :) It would be great to be able to assign different display modes for different templates Some categories are better displayed in a list (like search results maybe), some the grid would work better (what's new section)
  7. Nevermind the products_new.php included in the 1.8 pack was like this; unset($HTTP_GET_VARS['manufacturers_id']; unset($_GET['manufacturers_id']; This seems to work unset($HTTP_GET_VARS['manufacturers_id']); unset($_GET['manufacturers_id']); But I could have just broke it more ;) Thanks for the obvious hard work you put into this mod!
  8. I installed 1.8 version of your contribution and really like it - thanks! I now have an error when clicking through to new products; Parse error: parse error, unexpected ';', expecting ',' or ')' in /hsphere/local/home/compuexp/shop.teknmotion.com/catalog/products_new.php on line 14 http://shop.teknmotion.com/catalog/products_new.php I am really new to PHP Here is the line the above is refering (line 3 below is line 14 require('includes/application_top.php'); $HTTP_GET_VARS['manufacturers_id'] = ''; unset($HTTP_GET_VARS['manufacturers_id']; unset($_GET['manufacturers_id']; require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_PRODUCTS_NEW); require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_DEFAULT); $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_PRODUCTS_NEW)); ?>
  9. nevermind, fiqured it out
  10. Hi I have a quick question (yeah right ;)) I did not know the exact topic to post this under, it seems it could fall under more than one. I have added contributions; Lightbox J query with Ultra pics (Ultra Pics version 2.08) - working - causing the possible issue below xsell_v2.4 - works fine After installing Lightbox J query with Ultra pics the small image in the catalog pages no longer point to a product URL, but show the pop-up large image in the browser window instead I replaced all modified pages for the Lightbox J query with Ultra pics contribution with back-ups and restored a previous database Problem persists I used store database back-up Tool from admin area to restore The only thing that could remain is the SQL Query for the Contribution (below) osCommerce 2.2 RC2 - see problem here http://shop.teknmotion.com/catalog/index.php?cPath=3_11 //----------- SQL INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('', 'Enable Additional Images?', 'ULTIMATE_ADDITIONAL_IMAGES', 'enable', 'Display Additional Images below Product Description?', 4, 10, now(), now(), NULL, 'tep_cfg_select_option(array(\'enable\', \'disable\'),'); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('', 'Additional Thumb Width', 'ULT_THUMB_IMAGE_WIDTH', '140', 'The pixel width of additional thumb images', 4, 11, now(), now(), NULL, NULL); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('', 'Additional Thumb Height', 'ULT_THUMB_IMAGE_HEIGHT', '120', 'The pixel height of additional thumb images', 4, 12, now(), now(), NULL, NULL); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('', 'Medium Image Width', 'MEDIUM_IMAGE_WIDTH', '200', 'The pixel width of medium images', 4, 13, now(), now(), NULL, NULL); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('', 'Medium Image Height', 'MEDIUM_IMAGE_HEIGHT', '200', 'The pixel height of medium images', 4, 14, now(), now(), NULL, NULL); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('', 'Large Image Width', 'LARGE_IMAGE_WIDTH', '400', 'The pixel width of large images', 4, 15, now(), now(), NULL, NULL); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('', 'Large Image Height', 'LARGE_IMAGE_HEIGHT', '400', 'The pixel height of large images', 4, 16, now(), now(), NULL, NULL); ALTER TABLE `products` ADD `products_image_med` VARCHAR(64) AFTER `products_image`; ALTER TABLE `products` ADD `products_image_lrg` VARCHAR(64) AFTER `products_image_med`; ALTER TABLE `products` ADD `products_image_sm_1` VARCHAR(64) AFTER `products_image_lrg`; ALTER TABLE `products` ADD `products_image_xl_1` VARCHAR(64) AFTER `products_image_sm_1`; ALTER TABLE `products` ADD `products_image_sm_2` VARCHAR(64) AFTER `products_image_xl_1`; ALTER TABLE `products` ADD `products_image_xl_2` VARCHAR(64) AFTER `products_image_sm_2`; ALTER TABLE `products` ADD `products_image_sm_3` VARCHAR(64) AFTER `products_image_xl_2`; ALTER TABLE `products` ADD `products_image_xl_3` VARCHAR(64) AFTER `products_image_sm_3`; ALTER TABLE `products` ADD `products_image_sm_4` VARCHAR(64) AFTER `products_image_xl_3`; ALTER TABLE `products` ADD `products_image_xl_4` VARCHAR(64) AFTER `products_image_sm_4`; ALTER TABLE `products` ADD `products_image_sm_5` VARCHAR(64) AFTER `products_image_xl_4`; ALTER TABLE `products` ADD `products_image_xl_5` VARCHAR(64) AFTER `products_image_sm_5`; ALTER TABLE `products` ADD `products_image_sm_6` VARCHAR(64) AFTER `products_image_xl_5`; ALTER TABLE `products` ADD `products_image_xl_6` VARCHAR(64) AFTER `products_image_sm_6`; //----------- Catagories product list source --- <!-- Child Category Listing //--> <table width="625" border="0" align="center" cellpadding="0" cellspacing="0"> <tr> <td><table border="0" width="625" cellspacing="0" cellpadding="0"> <tr> <td class="pageHeading">Let's See What We Have Here</td> <td align="right"><img src="images/subcategory_science_fiction.gif" border="0" alt="Let's See What We Have Here" title=" Let's See What We Have Here " width="57" height="40"></td> </tr> </table></td> </tr> <tr> <td><img src="images/pixel_trans.gif" border="0" alt="" width="100%" height="10"></td> </tr> <tr> <td><table border="0" width="100%" cellspacing="0" cellpadding="2" class="productListing"> <tr> <td align="center" class="productListing-heading"> </td> <td class="productListing-heading"> <a href="http://shop.teknmotion.com/catalog/index.php?cPath=3_11&page=1&sort=2d" title="Sort products descendingly by Product Name" class="productListing-heading">Product Name+</a> </td> <td align="right" class="productListing-heading"> <a href="http://shop.teknmotion.com/catalog/index.php?cPath=3_11&page=1&sort=3a" title="Sort products ascendingly by Price" class="productListing-heading">Price</a> </td> <td align="center" class="productListing-heading"> Buy Now </td> </tr> <tr class="productListing-odd"> <td align="center" class="productListing-data"> <a id="thumb5" class="highslide" onclick="return hs.expand(this);" href="images/BladeRun_DVD_poster.jpg" alt="Blade Runner - Director's Cut"><img src="images/BladeRun_DVD_poster.jpg" border="0" alt="Blade Runner - Director's Cut" title=" Blade Runner - Director's Cut " width="80" height="110"></a> </td> <td class="productListing-data"> <a href="http://shop.teknmotion.com/catalog/product_info.php?cPath=3_11&products_id=5">Blade Runner - Director's Cut</a> </td> <td align="right" class="productListing-data"> <s>$35.99</s> <span class="productSpecialPrice">$30.00</span> </td> <td align="center" class="productListing-data"><a href="http://shop.teknmotion.com/catalog/index.php?cPath=3_11&sort=2a&action=buy_now&products_id=5"><img src="includes/languages/english/images/buttons/button_buy_now.gif" border="0" alt="Buy Now" title=" Buy Now " width="60" height="14"></a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="smallText">Displaying <b>1</b> to <b>1</b> (of <b>1</b> products)</td> <td class="smallText" align="right">Result Pages: <b>1</b> </td> </tr> </table> </td> </tr> </table> <!-- Child Category Listing //--> Thanks in advance! I have been breaking the store and putting it back together to see what everything does for the last week ;)
  11. I will post properly next time I installed STS and then re-installed RC2 and STS then appeared in the module menu Thanks -
  12. I searched the forums and google before posting this topic and found a few similar posts asking this same question. The problem is there are no replies - most say "Nevermind, I fiqured it out" without posting their solution I have installed a fresh copy of osCommerce 2.2 MS2 and attempting to install STS version v4.5.8 Uploaded files as directed in the included docs; From the "STS" folder, copy the new files to your store: catalog\includes\classes\sts.php catalog\includes\functions\sts.php folder catalog\includes\languages\english\modules\sts (plus all other languages you may have in your setup) folder catalog\includes\modules\sts folder catalog\includes\modules\sts_inc folder catalog\includes\sts_templates MS2 folder files; catalog\admin\modules.php catalog\admin\includes\boxes\modules.php catalog\admin\includes\languages\english.php (plus all other languages you may have in your setup) catalog\admin\includes\languages\english\modules.php (plus all other languages you may have in your setup) catalog\includes\application_bottom.php catalog\includes\application_top.php catalog\includes\column_left.php catalog\includes\column_right.php catalog\includes\footer.php catalog\includes\header.php catalog\includes\classes\boxes.php catalog\includes\functions\html_output.php I did this 3-4 times to be sure Can someone please post maybe a simple checklist for me to go over - maybe permissions not set correctly - versions not compatible etc... I really appreciate it!
×