Jump to content

tuppergreen

Members
  • Content count

    41
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Miss Tupper
  1. tuppergreen

    [contribution] Simple Template System (sts)

    Hi Bill, Thanks for the guidance, I decided to go without the tellafriendbox in the content template after spending 2 days trying to get it work to no avail, this is too advance for a newbie like me. :blush: I've another question here if you can help with, I have $myaccountlogo and $loginofflogo on the templates and I'm trying to make the My Account appear only after customer login. Below is my attempt, it doesn't trigger any error message thus I don't know where to begin troubleshooting. Can you kindly help with this? Thanks in advance. <td align="right" class="headerNavigation"><?php if (tep_session_is_registered('customer_id')) { ?> <a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?></a> | <a href="<?php echo tep_href_link(FILENAME_ACCOUNT, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?></a> | <?php } else { ?> <a href="<?php echo tep_href_link(FILENAME_LOGIN, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGIN;} ?></a>
  2. Hi, I want to have My Account appear only after Login. There isn't any error message after I edit includes/header.php as below but My Account is still appearing before customer Login. Without error message, I don't even know whats wrong, can you help please? Thanks! <td align="right" class="headerNavigation"><?php if (tep_session_is_registered('customer_id')) { ?> <a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?></a> | <a href="<?php echo tep_href_link(FILENAME_ACCOUNT, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?></a> | <?php } else { ?> <a href="<?php echo tep_href_link(FILENAME_LOGIN, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGIN;} ?></a>
  3. tuppergreen

    [contribution] Simple Template System (sts)

    Hi Bill, I've posted a question previously and not sure if you have caught it. Do you happen to know what might caused the link problem with tell_a_friend box? I've tried with all other infoboxes and I only have problem with the tell_a_friend box which I can't figure out why once it is placed into the content template, the link changes to shopping_cart.php. Appreciate if you can help with this again. Thanks
  4. tuppergreen

    [contribution] Simple Template System (sts)

    Hi Bill, thanks for the direction and I managed to insert the maninfobox into the content template of product_info page. Out of curiosity, I tried inserting tellafriendbox too and the box does appear but it is pointing to shopping_cart.php instead of tell_a_friend.php.. I've tried including the file with include(DIR_WS_BOXES . 'tell_a_friend.php') to make sure it points to this page but to no avail still. Is there a way that I could insert the tellafriendbox too?
  5. tuppergreen

    [contribution] Simple Template System (sts)

    Hi bkellum, I'm not sure if I get it right... I created this product_info.php.html and saved it in the content folder which will be the content template for all product_info pages. Everything within this content template will appear within the $content of a page template. For some reason, I wanted to include the $maninfobox within the content template instead of the page template. So I added $maninfobox together with $productname$, $productsid$, Product Name: $productname$ ..... etc in the content template. But the $maninfobox appears as text "$maninfobox" instead of the actual manufacturer info box. Is there a way that I can add the infoboxes within the content template of product info?
  6. tuppergreen

    [contribution] Simple Template System (sts)

    Hi, Is it possible to include infoboxes within $content of product_info content template? It looks like $whateverinfoboxName is not recognised in the $content template for product info...
  7. tuppergreen

    [contribution] Simple Template System (sts)

    Hi, I created a content template for product info page but couldn't figure out where should I edit the style (font, border... css properties) of the page? I have fckeditor installed and I know I could change the description text style with the editor but I would like to set a global style using a css stylesheet for the products info pages. Thanks for the help.
  8. tuppergreen

    Header Tags SEO

    Found! Found! They are there! Sorry my bad, I have so many notepads opening up from my test site and the working site and just realised I have been checking the wrong one until now............ Thanks for the help!
  9. tuppergreen

    Header Tags SEO

    Hi Jack, the tags are not there when I checked with View Source....
  10. tuppergreen

    Header Tags SEO

    Hi Jack, I'm not sure if you meant adding the file name headertags.php in the admin along side with the sts_user_code.php, if this is what you meant, yes, I did. While checking your previous post, I double checked on the test result. The above is what I got after removing <?php /*** Begin Header Tags SEO ***/ if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) { require(DIR_WS_INCLUDES . 'header_tags.php'); } else { ?> <title><?php echo TITLE; ?></title> <?php } /*** End Header Tags SEO ***/ ?> in the index.php and product_info.php. If I don't remove them, I'll get the error cannot redeclare tep_header_tag_page... When I do a View Result, I have this error : 401 Authorization in the yellow highlighted box field of Title and the following two rows (description and keywords) are highlighted in red. I'm not sure if it means the headertags.php is not in the correct permission, I've double checked and my headertags.php's permission is set at 777. I've also tried to use previous versions of Headertags SEO but still receiving similar results.. I dont know what I have done wrong here.......
  11. tuppergreen

    [contribution] Simple Template System (sts)

    Ignore my previous post. Phew... finally managed to figure it out!
  12. tuppergreen

    [contribution] Simple Template System (sts)

    After some trials and error, managed to skip this but end up getting this error ......well.... I can understand if someone tells me it is a dynamenu issues and should hop over to the dynamenu support thread.. but if you happen to read and knows how to fix it, appreciate if you can share... thanks!!
  13. tuppergreen

    Header Tags SEO

    Hi Jack, your reply has prompt me to remove <?php /*** Begin Header Tags SEO ***/ if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) { require(DIR_WS_INCLUDES . 'header_tags.php'); } else { ?> <title><?php echo TITLE; ?></title> <?php } /*** End Header Tags SEO ***/ ?> and the error is gone! However, when I do a view source, the meta tags are not there.. is it supposed to work this way? Sorry for asking maybe the obvious, I'm new to this.. thanks for the patience and help!
  14. tuppergreen

    [contribution] Simple Template System (sts)

    Hi, does anyone know if STS and Header Tag SEO is compartible? I received this error when I enabled STS with Header Tag SEO. I have checked through the manuals and instruction txt of STS and header Tag SEO and googled for a solution but to no avail. I love these two contributions, if anyone knows how to make them work together, I am greatly appreciated!! Thanks!
  15. tuppergreen

    Header Tags SEO

    Hi Jack, Need your help again if this error is relevant to Header Tags SEO contribution. When I enabled STS, I got this error I have tried to use version HeaderTags_SEO_V_3.0.8 includes/functions/header_tags.php too but still didn't work. I have tried to search for the function tep_header_tag_page() but it seems that it is not declare in anywhere else. The lines of code are as below //used to add new pages without adding a lot of code function tep_header_tag_page($file) { global $tmpTags, $languages_id; $header_tags_array = array(); $sortOrder = array(); $pageTags_query = tep_db_query("select * from " . TABLE_HEADERTAGS . " where page_name like '" . $file . "' and language_id = '" . (int)$languages_id . "'"); $pageTags = tep_db_fetch_array($pageTags_query); if ($pageTags['append_root']) { $sortOrder['title'][$pageTags['sortorder_root']] = $pageTags['page_title']; $sortOrder['description'][$pageTags['sortorder_root']] = $pageTags['page_description']; $sortOrder['keywords'][$pageTags['sortorder_root']] = $pageTags['page_keywords']; $sortOrder['logo'][$pageTags['sortorder_root']] = $pageTags['page_logo']; } if ($pageTags['append_default_title'] && tep_not_null($tmpTags['def_title'])) $sortOrder['title'][$pageTags['sortorder_title']] = $tmpTags['def_title']; if ($pageTags['append_default_description'] && tep_not_null($tmpTags['def_desc'])) $sortOrder['description'][$pageTags['sortorder_description']] = $tmpTags['def_desc']; if ($pageTags['append_default_keywords'] && tep_not_null($tmpTags['def_keywords'])) $sortOrder['keywords'][$pageTags['sortorder_keywords']] = $tmpTags['def_keywords']; if ($pageTags['append_default_logo'] && tep_not_null($tmpTags['def_logo_text'])) $sortOrder['logo'][$pageTags['sortorder_logo']] = $tmpTags['def_logo_text']; FillHeaderTagsArray($header_tags_array, $sortOrder); return $header_tags_array; } Hope you can help.
×