Jump to content

hwkd

Members
  • Content count

    77
  • Joined

  • Last visited

Everything posted by hwkd

  1. hwkd

    UPSXML_v1_3_5 clean

    Jan, Well, thanks for leading me to water. It appears to have suppressed the warning. Again, for those interested this conversation provided the best discussion of the the issue per SAFE_MODE, cURL and open_basedir and and got us to the point where Jan got me to make the a fix to suppress the warning. My hosting company has not responded as to whether the shared server is running in safe mode though I am guessing it is.
  2. hwkd

    UPSXML_v1_3_5 clean

    Also, this conversation seems largely on point albeit for PayPal. http://forums.cubecart.com/index.php?showtopic=21851
  3. hwkd

    UPSXML_v1_3_5 clean

    All, Also seeing advice like this from diffeent open source forums: Workaround: uncomment the line 2322 in class.t3lib_div.php or set it like the following curl_setopt($ch, CURLOPT_RETURNTRANSFER, 0); Change: curl_setopt($ch, CURLOPT_FAILONERROR, 1); To: curl_setopt($ch, CURLOPT_FAILONERROR, 0); Tried the RETURN_TRANSFER one with no luck.
  4. hwkd

    UPSXML_v1_3_5 clean

    Jan, Clearly, I'll take your word for it. The file nusoap.php does reside in includes/nusoap.php for RC2, but all I am working with is osCommerce so I do not know how it could be from some other open source project. I do agree that the issues is in all likelihood a hosting issue and have found some things in the neighborhood? Like: http://us.php.net/features.safe-mode Thanks again.
  5. hwkd

    UPSXML_v1_3_5 clean

    Here is code from line around 2160 relating to error msg. $hostURL .= $this->path; curl_setopt($this->ch, CURLOPT_URL, $hostURL); // follow location headers (re-directs) curl_setopt($this->ch, CURLOPT_FOLLOWLOCATION, 1); // ask for headers in the response output curl_setopt($this->ch, CURLOPT_HEADER, 1); // ask for the response output as the return value curl_setopt($this->ch, CURLOPT_RETURNTRANSFER, 1);
  6. hwkd

    UPSXML_v1_3_5 clean

    All, So now site's admin for UPS does not show error previously solved. Now test site shows: Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/brigh49/public_html/includes/classes/nusoap.php on line 2160 One thread on osCommerce forum ends with no resolution. http://forums.oscommerce.com/index.php?showtopic=305496 "Try a google search on cannot be activated when in safe_mode or an open_basedir" per Coopco...... looks like it might be resolved with php.ini adjustment any ideas? Thanks
  7. hwkd

    UPSXML_v1_3_5 clean

    OK, looks like I got it in the right place in after all the buysafe code I found the: case 'save': while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) { before the tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $value . "' where configuration_key = '" . $key . "'"); } tep_redirect(tep_href_link(FILENAME_MODULES, 'set=' . $set . '&module=' . $HTTP_GET_VARS['module'])); break; case 'install': So, if you are using the osCommerce v 2.2 RC2 and trying to follow the directions for the readme.txt Step 3 modification to admin/modules.php you have to look past all the buysafe code in admin/modules.php to find the proper insertion point per UPSXML v1.3.5 readme.txt directions.
  8. hwkd

    UPSXML_v1_3_5 clean

    All, Again, this is not an emergency as this is being done a test site. I have installed UPSXML_v1_3_5 following the 4 steps for v1.3.5 install. There was no previous UPSXML version installed. I am now getting the error: [function.constant]: Couldn't find constant UPSXML_Array I have not installed USPS Methods or UPS Connections, so I am trying to follow step 3 as indicated in the readme.txt file and Jan Z's support in this thread: http://forums.oscommerce.com/lofiversion/i...hp?t290275.html However, my code for catalog/admin/modules.php does not resemble the code for catalog/admin/modules.php in the readme.txt file for the add-on. Instead my code looks like this: if (tep_not_null($action)) { switch ($action) { // {{ buySAFE Module case 'buysafe_save': if ( ( $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] == '' || $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] == '-- none --' ) && ( $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] == '' || $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] == '-- none --' ) ) { $seal_data = tep_db_fetch_array(tep_db_query("select configuration_value from " . TABLE_CONFIGURATION . " where configuration_key = 'MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'")); $store_data = tep_db_fetch_array(tep_db_query("select configuration_value from " . TABLE_CONFIGURATION . " where configuration_key = 'MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'")); $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] = $seal_data['configuration_value']; $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] = $store_data['configuration_value']; } I tried to insert the insert code after case 'buysafe_save': but no luck. What am I missing? Thanks.
  9. hwkd

    UPSXML_v1_3_5 clean

    Yes, bad file management was the culprit. I managed to get the modules.php file into the unpacked structure of the add-on in the folder indicated and kept rechecking files to upload from the add-on thinking that was from the add-on. I should have gone back to compressed file and unpacked it again. A lesson learned (and always a good one), when you retrace your steps always go all the way back to the start. I will say I was going to go back and reinstall osCommerce and reinstall the add-on, but I bet I could have missed the step or unpacking the compressed file again. Thanks, Jan
  10. hwkd

    UPSXML_v1_3_5 clean

    Well, I have compared line 166: include(DIR_FS_CATALOG_LANGUAGES . $language . '/modules/' . $module_type . '/' . $file); to the current live and live backup and it is the same as on the test site. I added a close bracket to the end of line 166 and got: Parse error: syntax error, unexpected '}' in /home/brigh49/public_html/admin/modules.php on line 222 Is my editor counting lines differently than your editor? Thanks Jan.
  11. hwkd

    UPSXML_v1_3_5 clean

    Thanks for verifying.
  12. hwkd

    UPSXML_v1_3_5 clean

    Well, I guess this could be part of the problem. From the readme.txt. UPS XML Rates v1.3.5 for osCommerce 2.2 MS2 2008/02/15 Anyone know that UPS XML Rates v1.3.5 for sure will not work with v2.2 RC2a.
  13. All, My concern about UPS choice 1.8.3 was this from the "read me" file. Disclaimer: This revision is based on ups.php v.1.54, which employs the UPS cgi method that has been deprecated for over a year and although it appears to remain functional is no longer officially supported by UPS. The currently supported UPS API requires XML requests through a secure socket layer, for which there is not yet an osC implementation. Did not know quite what to make of that, but elected to try UPS xml first. Cordially, Hank
  14. Bob, Look at http://forums.oscommerce.com/index.php?showtopic=259544 Hope there is something in there. Always try Googling error messages
  15. hwkd

    TEST SITE

    OK, Anyone know a way to install the USPS module via admin on a sub-domain test site and not mess up the live site? Thanks
  16. hwkd

    TEST SITE

    All, I have installed test site on subdomain and checkout goes from subdomain to live site. Looking to fix path for <?php echo '<a href="' . tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL') in shopping_cart.php and other files cannot find FILENAME_CHECKOUT_SHIPPING in any of the include definition files. Anyone tell me where FILENAME_CHECKOUT_SHIPPING is hiding from me? Thanks, Hank
  17. hwkd

    TEST SITE

    All, I said use SSL for test site and obviously that required it to go over to the live site. So, if your hosting company asks that question do not choose SSL??? Or?????
  18. hwkd

    TEST SITE

    OK, I found the FILENAME_CHECKOUT_SHIPPING filenames.php but why is leaving the sub-domain? Thanks
  19. All, I am attempting to get the included AIM module to work. 1.) Or is that simply impossible and I have to go to the "new" AIM module. I have all the settings in osCOmmerce admin correct, except for one thread that said to set the admin settings for 2.) Transaction server and transaction mode to "live". That does not seem right to me. Any input? 3.) Also, have changed switch (MODULE_PAYMENT_AUTHORIZENET_CC_AIM_TRANSACTION_SERVER) { case 'Live': $gateway_url = 'https://secure.authorize.net/gateway/transact.dll'; break; default: $gateway_url = 'https://test.authorize.net/gateway/transact.dll'; break; } in authorizenet_cc_aim.php so that both are "test.authorize.net" and have also tried setting both to "secure.authorize.net" any input on that one? Authorize.net says it should be test.authorize.net while in test mode but again another thread said change over to "secure.authorize.net" 4.) Lunarpages gave me 3 paths for the cURL path and said..... "The pathway you use would depend upon the path that the gateway processor software requires. Please refer to their documentation for further clarification on this issue." OK, except the only thing on A.net about cURL is in reference to using their module with a hosting company that uses proxy servers. Lunarpages does not use proxy servers. Lunarpages says the cURL is compiled in PHP. 5.) I have not entered a MD5 Hash number because it is optional, plus the script apparently in authorizenet_cc_aim.php apparently generates one. At this point the advice on all the different settings makes for so many computations my head is swimming. Lunarpages has been responsive, authorize.net has not been. This thread http://forums.oscommerce.com/index.php?showtopic=293398 has been very helpful, bit I am looking for any insight before I dive into the array of suggestions. Any advice specific or general would be appreciated. Cordially, Hank http://forums.oscommerce.com/index.php?showtopic=293398
  20. At "Delivery Info" stage of shopping cart got a weight is displayed before the USPS logo. I have the code in checkout_shipping.php $total_weight = $cart->show_weight(); $total_count = $cart->count_contents(); I comment it out and it just gives goofy weight. I actually delete the code and it gives same goofy weight. Any ideas where the rest of the code is I need to comment out??? Cordially, hwkd
  21. hwkd

    Remove weight at "Delivery Info"

    Delete (//' . $shipping_num_boxes . ' x ' . $shipping_weight . 'lbs) in the usps.php file
  22. hwkd

    Error: 10 after AIM install?

    Authorize.net has compiled a list of error codes. See if it is not listed there. Try Googling the error code.
  23. hwkd

    osCommerce default AIM Module

    This worked for per Joshua M in this forum: So I found that even though you are testing, you need to make the "Authorize.net Credit Card AIM" Live. Turns out that in the default settings for osc's authorizenet, "Test" means that you are submitting requests to https://test.authorize.net/gateway/transact.dll. This is the wrong gateway to send it to unless your API login starts with "cpdev" or "cnpdev". The server will return error 13 message (basically wrong username or password). The correct test server if your API login doesn't start with "cpdev" or "cnpdev" is the same as the live server: https://secure.authorize.net/gateway/transact.dll For testing, you need to make sure that Authorize.net is in test mode. To do this, log in to Administration. In the left navigation click on Modules then Payment In the center list, click on Authorize.net Credit Card AIM On the right, you will see the settings. Set them as follows: -------------------------------------------------------------------------------------------------------------------------------------------- Enable Authorize.net Credit Card AIM Do you want to accept Authorize.net Credit Card AIM payments? True * False Login ID xxxxxxxxxx The login ID used for the Authorize.net service Transaction Key xxxxxxxxxxx Transaction key used for encrypting data MD5 Hash xxxxxxxxxxxxxxxxxxxxxxx (same as in authorize.net settings) The MD5 hash value to verify transactions with Transaction Server Perform transactions on the live or test server. The test server should only be used by developers with Authorize.net test accounts. Live * Test Transaction Mode Transaction mode used for processing orders Live * Test Transaction Method The processing method to use for each transaction. Authorization Capture * Payment Zone (personal configuration) If a zone is selected, only enable this payment method for that zone. Set Order Status (personal configuration) Set the status of orders made with this payment module to this value Sort order of display. **Not necessary**(0=first in the list 99=last in the list) Sort order of display. Lowest is displayed first. cURL Program Location The location to the cURL program application.
  24. hwkd

    authorize.net problems

    Joshua and All, The settings and URL solution before all the scripting stuff worked for me. So, thanks. I do not currently have any fields listed as required in the Merchant Interface with Authorize.net. Cordially, Hank
  25. hwkd

    authorize.net problems

    Good day, How do you discern what fields are set as required in osCommerce? Cordially, Hank
×