Jump to content

inspiritmedia

Members
  • Content count

    2
  • Joined

  • Last visited

  1. inspiritmedia

    [CONTRIBUTION] Authorize Net AIM module

    New Problem and Fix! Line 312 Needs to be fixed for my issue. As my last post showed how to change the a.net issue of not connecting... to properly move onto the final page change the following line. if ($this->response[0] != '1') { tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode($this->response[3]) . ' - ' . urlencode(MODULE_PAYMENT_AUTHORIZENET_AIM_TEXT_DECLINED_MESSAGE), 'SSL', true, false)); WAS CHANGE TO THIS AND WORKS: if ($this->response[0] != '"1"') { tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . $this->response[3] . ' <br> ' . MODULE_PAYMENT_AUTHORIZENET_AIM_TEXT_DECLINED_MESSAGE, 'SSL', true, false));
  2. inspiritmedia

    [CONTRIBUTION] Authorize Net AIM module

    FOR THOSE OF YOU HAVING THIS SAME PROBLEM HERE IS A QUICK FIX: In a.net make sure your direct response for Delimited is set to YES and | (pipe). In the new AIM code given by Vger it is listed as the following at line 226ish: 'x_relay_response' => 'FALSE', // AIM uses direct response, not relay response 'x_delim_char' => '|', 'x_delim_data' => 'TRUE', // The default delimiter is a comma 'x_version' => '3.1', // 3.1 is required to use CVV codes I HAVE CHANGED IT TO: 'x_relay_response' => 'FALSE', // AIM uses direct response, not relay response 'x_delim_data' => 'TRUE', // The default delimiter is a comma 'x_delim_char' => '|', 'x_encap_char' => '"', 'x_version' => '3.1', // 3.1 is required to use CVV codes That got rid of the error: "- Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance." and now I have: ""(TESTMODE) This transaction has been approved." - Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance." Which I can now fix because I'm connecting properly to a.net Hope this helps someone.
×