Jump to content

gsova

Members
  • Content count

    4
  • Joined

  • Last visited

Profile Information

  • Real Name
    George Sovatzis
  1. Hi guys, On eurobank_ok.php and eurobank_nok.php files, locate this line: $tm_ref = $_REQUEST['Ref']; and change the 'Ref' to 'ref' I had the same problem and I was trying to figure out what the heck is not working for days. Finally I found it, after I have created a logging mechanism to print messages and variables of my e-shop to a LOG file. Anyway, after the above change, I am redirecting to the CORRECT pages (and NOT index.php) which are: If OK, checkout_process.php If NOT OK, checout_payment.php The problem was that the eurobank_ok and eurobank_nok pages could not get the correct Ref number returned from Proxypay on the request and therefore could not query the database correctly to retrieve the session id. Hope that helps! :D <-- happy developer
  2. Thanks for the info spooks. One more thing: I have the same problem as this guy here... I did a search on the topic but couldn't find a resolution for this issue. Has it been resolved? Once again, thanks for your support.
  3. Hi there, I have downloaded the latest Anti-robot contribution (v3.1 posted on 18 Aug 2009) and installed it on my osCommerce installation running under Windows Vista and Apache 2.2.13 / PHP 5.2.10 / MySQL 5.1.38. By default I had the "missing SID problem" and after fixing that, I had a black image. I also fixed the black image, following the instructions on this topic and now I find that even though in my Administrator I have the following options: -Activate for New Users -Activate for Editing User Account -Activate for Changing password -Activate for Contact Us -Activate for Link Submission -Activate for Password forgotten and all these are set to true, I can only see the Anti Robot box for the Contact Us page, for the new Users page and for the Password forgotten page. I cannot see the Anti Robot when I edit a user account and when I change the password. I checked the ZIP file provided on contributions and it seems that account_edit.php and account_password.php are missing from this file. Can you provide these files for the latest version (v3.1)? Also: How can I test the Link Submission page (I mean, where should I go in OsCommerce to verify that it works ok)? Sorry for the trivial questions --> I am a newbie! EDIT: Something I forgot to mention... in my Apache error.log file I get the following: [Tue Sep 15 22:22:28 2009] [error] [client 192.168.1.8] PHP Notice: Undefined variable: rangeList in C:\\Apache2.2\\htdocs\\catalog\\includes\\functions\\account_validation.php on line 47, referer: http://ornella/catalog/contact_us.php?osCs...bn0bnu0ggh27184 [Tue Sep 15 22:22:28 2009] [error] [client 192.168.1.8] PHP Notice: Undefined offset: 17 in C:\\Apache2.2\\htdocs\\catalog\\includes\\functions\\account_validation.php on line 49, referer: http://ornella/catalog/contact_us.php?osCs...bn0bnu0ggh27184 Can you help?
×