Jump to content

MikeTurner

Members
  • Content count

    54
  • Joined

  • Last visited

Everything posted by MikeTurner

  1. MikeTurner

    DUPLICATE SHIPPING COST?

    Hi, I've been running with my store for over a year now but decided to change the way we handle shipping. We used to have multiple shipping methods available and everything was working fine. We're now using a single method using Shipping Zones (as we're expanding our delivery area). However as soon as only 1 shipping option is available something strange happens on checkout_shipping. Basically with only 1 shipping option displayed the shipping price duplicates; once without the £ symbol and once with it: "Zone Rates Shipping to GB : 0.85 lb(s) 7.99 £7.99 " If I have 2 shipping options enabled this will display correctly as £7.99. Has anyone got any ideas on what might be causing this as I'd really appreciate it! Thanks Mike
  2. MikeTurner

    Country-State Selector

    Hey, Yeah I've done a Diff and the only thing that is different around the call to populate the list is that it was previously using the zone_name rather than the zone_id. From what the code looks like it's doing this seems to be the relevent section but somehow it seems that its not getting a match for the array and therefore not populating correctly. Any ideas? - the other pages all work fine :s ORIGN SECTION: $entry_state = tep_get_zone_name($cInfo->entry_country_id, $cInfo->entry_zone_id, $cInfo->entry_state); if ($error == true) { if ($entry_state_error == true) { if ($entry_state_has_zones == true) { $zones_array = array(); $zones_query = tep_db_query("select zone_name from " . TABLE_ZONES . " where zone_country_id = '" . tep_db_input($cInfo->entry_country_id) . "' order by zone_name"); while ($zones_values = tep_db_fetch_array($zones_query)) { $zones_array[] = array('id' => $zones_values['zone_name'], 'text' => $zones_values['zone_name']); } echo tep_draw_pull_down_menu('entry_state', $zones_array) . ' ' . ENTRY_STATE_ERROR; } else { echo tep_draw_input_field('entry_state', tep_get_zone_name($cInfo->entry_country_id, $cInfo->entry_zone_id, $cInfo->entry_state)) . ' ' . ENTRY_STATE_ERROR; } } else { echo $entry_state . tep_draw_hidden_field('entry_zone_id') . tep_draw_hidden_field('entry_state'); } } else { echo tep_draw_input_field('entry_state', tep_get_zone_name($cInfo->entry_country_id, $cInfo->entry_zone_id, $cInfo->entry_state)); } NEWSECTION: // +Country-State Selector $entry_state = tep_get_zone_name($cInfo->entry_country_id, $cInfo->entry_zone_id, $cInfo->entry_state); $zones_array = array(); $zones_query = tep_db_query("select zone_name, zone_id from " . TABLE_ZONES . " where zone_country_id = '" . (int)$cInfo->entry_country_id . "' order by zone_name"); while ($zones_values = tep_db_fetch_array($zones_query)) { $zones_array[] = array('id' => $zones_values['zone_id'], 'text' => $zones_values['zone_name']); } if (count($zones_array) > 0) { echo tep_draw_pull_down_menu('entry_zone_id', $zones_array, $cInfo->entry_zone_id); echo tep_draw_hidden_field('entry_state', ''); } else { echo tep_draw_input_field('entry_state', $entry_state); } // -Country-State Selector
  3. MikeTurner

    Country-State Selector

    Hi Guys, I've installed this contribution on my site, and it's going to make a huge difference since I was originally holding off from allowing non UK users to sign up to the site as there was no real way to control the states. The only problem I have come across so far is that when I am in Admin on customers.php as soon as I change the Country to anything else the State field changes from a combo box to a plain text field as if it couldn't find any matches. However in all of the other pages this works fine. Has anyone else experienced the same? - I've been through the install plan a few times but can't see anything that I've missed. Thanks in advance! Mike
  4. MikeTurner

    PayPal WPP Direct Payments & Express Checkout Support

    Thanks Glen - I wish PayPal would improve their communications - I can't believe how bad their customer service / back-end tools / communications are! :P
  5. MikeTurner

    PayPal WPP Direct Payments & Express Checkout Support

    Hey, I just got an e-mail from PayPal saying that they are upgrading their platform and by Sept 09 everyone needs to update the SDK to version 4.3 or higher as the old platform will not continue to work. Anyone else got this? - No idea what I'm supposed to do (the instructions tell you to look at a recent transaction to see what version is recorded but no version is recorded in the transactions) Soon, we’ll be making enhancements to our Website Payments Pro service. While we are doing everything to make these updates as seamless as possible, you will need to make some changes to your Website Payments Pro integration. Here’s what’s happening Beginning September 2009, PayPal will be upgrading its Payflow gateway service to a new, more secure SSL server certificate hierarchy. Here’s what it means to you To continue processing transactions after this date, you will need to update your current integration to the latest Software Development Kit (SDK version 4.3 or higher) or to our direct HTTPS interface. The update will give you more security and you won’t have to worry about your payment service being interrupted in September. Here’s what you need to do For a detailed explanation of what’s changing and step-by-step instructions on what to do, go to https://www.paypal.com/gatewayupdate
  6. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Hi Ashley, If you are only interested in the customer getting the points then merely add the 'tep_add_welcome_points($customer_id);' line someone under the if(EMAIL_USE_HTML == 'true')... i.e. the below: if (EMAIL_USE_HTML == 'true') { require(DIR_WS_MODULES . 'UHtmlEmails/'. ULTIMATE_HTML_EMAIL_LAYOUT .'/create_account.php'); tep_add_welcome_points($customer_id); $email_text = $html_email; }else{ Please note that the contribution was designed to give an updated email to include the fact that they were given points and if you use the HTML contribution without even more work it won't generate any different e-mail message. The above will solve the problem of the points not being added, if you want to amend the e-mail text some additional changes would also be required (I wasn't bothered about the e-mail so 'patched' the issue and leaving the default e-mail text in place). Mike
  7. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Ashley I had the same problem since I am assuming you are using the uHTML contribution? - In the create_account.php there is code which you edited to insert the call to update the points, but if you notice that code was already edited by uHTML to say if it is HTML use the code above. I literally copied the code which calls the update of the function and duplicated it in the other section of the IF statement. Hope this helps. Mike
  8. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Hey Deep, The fix that you have described asks for the languages file to be changed which wouldn't work. The correct file that should be changed is: catalog/includes/modules/order_total/ot_redemptions.php But I'm sure everyone would have worked that out on their own :) Cheers! Mike
  9. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Hi Deep, I'm sure you will say that it is a problem with the payment module and I appreciate that, but it still leaves me in a difficult situation as I am not a payment module coder and can't see how I can easily link the payment module to call the discount amount. Without asking you to fix this completely for me (unless you were willing to ;) ), would you be willing to point to the relevant function in your module that I can call from another module when the payment is being made which would result in giving me the 'redeemed points amount'? - If you could provide me with that then I have a chance of being able to add code to the payment module to take the correct amount. If I can get this working using the minimal help from you then I will be able to post the solution in the forum to stop anyone else with my payment module having the same issue. I really appreciate your help! Mike
  10. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Deep, That's all fine re: not showing that it displayed that I was paid by points, I can certainly live with that... With regards to the forcing of entering a credit card number for WPP I'm sure I can work around this with a bit of code that I may be able to come up with... My main issue and the one that I can't figure out on my own is that if I choose to redeem the points which doesn't cover the whole amount, the order to the customer shows that they would only be charged the discounted amount, however they actually get charged the full amount.. The PayPal WPP module uses the total order amount and it has added support to look up discounts applied by the CCGV which has added code to the order_total.php. However, their is no code which would take the total amount off of the total cost to support this Points and Rewards from what I can make out. I'm really struggling, I know that this module wasn't designed specifically to work with each and every payment module, but I would hope that you may be able to help provide compatibility as I think this module is fantastic and it would be a real shame if I couldn't get this working on my live site....
  11. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Tracy, never seen that before...even if you deleted the order_total folder the option should still appear...Have you made any changes to the modules.php file recently?
  12. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Hi Deep-Silver, The PayPal WPP module works slightly different as it asks you for the credit card details at the checkout_Payment page and not the checkout_confirmation. So I guess something needs to be changed somewhere... The payment module for PayPal at checkout uses the order_total module, which I do not believe is edited by this contribution so it doesn't know to take the redemption amount from the order total and charges the full amount. I have performed the install 3 times now and have the same problem, so think this is just an incompatibility between the 2 modules. I'd really appreciate it (as I'm sure lots of other people would) if you were willing to provide added support for the PayPal WPP module and would be happy to provide any information and testing. Thanks again Mike
  13. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Thanks Deep-Silver but as per the above post it looks like the problem with forcing to use the credit card details if using all points is appearing on the demo site. Unfortunately I can't test the partial points redemption since everything on the site will show it to be correct, its only if I login to Paypal that I see the points weren't redeemed. In addition, there seems to be no reference in Admin / the order that points were redeemed..all that shows is payment type = 'Credit/Debit Card'.... I trawled through the whole day yesterday and looked at posts since 2005 which all described the issue of partial points not being redeemed if using PayPal WPP but there seems to be no indication of a fix... In the WPP module there is code compatibility for CCV but since this module uses a different total module (redemptions) the payment module isn't picking up the true total. Any ideas would be really appreciated, as I'm sure lots of people are wanting to get this module working with PayPal WPP. Thanks! Mike
  14. MikeTurner

    PayPal WPP Direct Payments & Express Checkout Support

    Hi In addition to my last problem I am having problems installing another contribution which I think would be of benefit to lots of shops. I am trying to install 'Points and Rewards v2.1' and I guess it works in a similar concept to CCGV which you have provided support for. The issue I am having is that a customer can redeem collected points against the cost of the item and although on the checkout_confirmation page, it will show an amended total to be paid, PayPal takes the complete amount. I am guessing that some modification would need to be done in paypal_wpp.php and I can see reference to ccgv in wpp_generate_PDI but I'm not an expert on this as to what I should change to allow the transaction amount to become modified. Would really appreciate any pointers, you may have come across this before? Thanks Mike
  15. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Further to my previous post I'm not doing so well on the new install.... 1. If I select to use all my points it will still ask me for a credit card number but will not charge the card if I confirm checkout. 2. If I select to use partial points it bills the credit card for the whole amount I'm using the "PayPal Pro Direct Payments & Express Checkout" as my payment module... Any ideas on what is wrong? Thanks mike
  16. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Issue Redeeming All Points in V2.1rc2a Hey Deepsilver, thanks for taking the time to rewrite the contribution, I was having lots of problems trying to get the original one working and v2.1 seems to fix most of the issues I had however the only problem I am having is if you want to check out by redeeming all of your points. If I select that I want to redeem all of my points, it forces the credit card details to be entered but the customer wouldn't expect to enter their details if they are not paying by Credit Card? Are you able to advise if this is intentional or a bug? Thanks again! Mike
  17. MikeTurner

    PayPal WPP Direct Payments & Express Checkout Support

    Hi, I'm currently using this module and have just started getting a strange error. The error seems to occur after deleting an order from the admin side and then making another order. Basically I can successfully perform a transaction on checkout but the SQL to add an entry to the orders_status_history_transactions table for the key it is trying to enter already exists. I'm not sure how the code calculates the next key it requires and also not sure if this is a bug or something I've done wrong. Any advice would really be appreciated! Thanks Mike P.S Error Below: 1062 - Duplicate entry '11' for key 1 INSERT INTO orders_status_history_transactions ( `orders_status_history_id`, `transaction_id`, `transaction_type`, `payment_type`, `payment_status`, `transaction_amount`, `module_code`, `transaction_avs`, `transaction_cvv2`, `transaction_msgs` ) VALUES ( 11, '2SX03103X3483513H', 'AUTHORIZATION', 'INSTANT', 'PENDING', 3.56, 'paypal_wpp', 'UK-specific “X” Address and Postal Code', 'Match CVV2', 'authorization' ) [TEP STOP]
  18. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    OK just managed to fix the issue re the points not getting created...I had the u HTML contribution installed which was bypassing that section so now sorted on that one. However, I am still having loads of Tax issues. Is there any fix for this as it seems to be affecting a number of things, including the max amount of points it can use. i.e. if you have £5 in points and the amount came to £3.56 it will only take off £3.03 as this is the price it thinks it comes to? - If theres no fix, any indications of where calculation takes place and I will develop and share a fix???... please :) In addition I found another bug which you might want to take note of: If you disable the option for expiring points after a certain date, the my_points.php page will say that you have no points. This is because the SQL query filters on the expiry date field i.e. customers_points_expires > CURDATE() However since the field is NULL there is no match. To resolve simply I changed the query so that it can handle the NULLs. Also added an IF statement so that it wouldn't display the 'Expire At:' detail on the page when there is NULL dates. If you need more details just reply...
  19. MikeTurner

    ### POINTS AND REWARDS MODULE V1.00 ###

    Hi, I have just installed this contribution which looks great but having 2 problems. 1. When a customer creates a new account they do not automatically receive the points which I have set up in the options. The user gets the message at create account success but doesn't actually get any points. I can add the points manually. 2. On the payment page it displays the total order amount however as I have tax added to my delivery price it doesn't take this in to account in the calculation although it does for the product tax. I've seen a few posts regarding this but after searching through the forums couldn't find the answer. Would really appreciate any help or pointers you can give me! Thanks Mike
  20. MikeTurner

    PROBLEM with Points/Rewards Module V2.00

    Hey, I've just installed this contribution and looks really good but have 2 major issues so far.... 1. I have set the option for customers to receive points when signing up, and they get a message telling them it has been added but the points do not get added. I've gone over the install notes and can't see where I went wrong? I can add points manually to their account, but they would be expecting them automatically. 2. On the Payment Confirmation page it estimates the total cost of the order, but the VAT hasn't been added on to the shipping costs (as configured in admin). The VAT seems to have been added to the product so the cost does not match the final price. I've seen a few posts in here asking about this but after almost an hour searching I couldn't see any answers. Would really appreciate your advice! Mike
  21. Hi, I'm looking for a quick bit of advice... Essentially as a general rule all products in our store are sold at a fixed cost of £7.29 for DHL. We also offer a table based shipping dependant on weight using Royal Mail prices so that if you order something light then this price will be cheaper. We are now talking to other suppliers who will drop-ship (deliver direct to customer) but their costs are higher than our current standard. i.e. Their minimum delivery fee is £10 and they then have their own shipping table for heavier weights. So essentially I need a mechanism to be able to split my delivery options in to 2. 1 set of delivery for the items I ship and another set for the suppliers products. As their range is not particularly huge I could quite happily work out the prices per product and assign a fixed price for delivery for each of the products, but I wouldn't be able to do this for the rest of my stock. The only obstacle I would then have is when they combine orders. i.e. ordered 1 item from our stock and 1 from the suppliers. Or if they ordered 2 products from the supplier as it would be worked on the combined weight of the 2 products. Is there a suggested contribution that may help me? Many thanks Mike
  22. MikeTurner

    PayPal WPP Direct Payments & Express Checkout Support

    Hi, I posted an issue a while back but didn't get an answer and am still having the issue on my live shop :( It would seem that if you already have an account in OScommerce but don't sign in, rather click the PayPal express checkout. You then login and return back to your site. You select the delivery option and continue. When you try to proceed even though there is a large row at the top saying 'You are checking out with PayPal Express' an error is displayed saying 'No Checkout Method Selected'. When you then select a different Payment method no values display on the screen. The payment address is empty but when you click on the payment address it brings up your details to select. After further testing it would appear that this issue only occurs when you use PayPal express and you have an account on the store but haven't logged in to it. Somehow it reassociates the accounts after the PayPal selection - by email address? and then throws up errors / doesn't register variables. If I try checking out with PayPal express without having an account in OSCommerce it works ok. Does this issue sound familiar? - Anyone else having it or any pointers you can give me? - I really need to get this fixed as think I am losing customers :( Many thanks Mike
  23. Hi, I'm having a problem before I've pretty much started. In the common.sql I get the following error: SQL query: ALTER TABLE `customers` MODIFY COLUMN `customers_password` VARCHAR( 40 ) CHARACTER SET utf8 COLLATE utf8_general_ci MySQL said: #1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_general_ci' at line 1 Any ideas how to fix this? Thanks in advance Mike
  24. Hi, I've had a few problems when implementing this contribution which I am hoping you can help with: 1. If I sort by price it is the NET price that seems to be sorted and not the GROSS price. Therefore if I have mixed products in a category i.e. Kids/Adults where kids are Zero Rated VAT the NET price for the adults is appearing before the price of the kids. I.e. £24.99 is showing before £22.99 as £21.27 is the gross of £24.99. Is there a fix for this? - I am guessing that a query just needs to be changed somewhere so it multiplies by the VAT rate (if applicable) 2. If I filter by a manufacturer the data is filtered as expected. If I then try to sort on these values, i.e. by Price the screen takes me back to a list of all the products and the sort is reverted back to Product Name. The sorting doesn't appear to work when the filter is used. I don't think I've done anything wrong on the install? - is this a known issue? 3. If I am not on the 1st page of results i.e. Page 2 and I try to apply the price sorting it doesn't work. However if I go back to Page 1, apply the sort and then go to page 2 it works. I'd be really grateful if you can confirm if these are bugs and how I should fix them? Many thanks Mike!
  25. MikeTurner

    Header Tags SEO

    Got it working by unticking Category and ticking it again (the sort order was missing)...I had a few problems with updating the words yesterday: 1. There are multiple includes that did not show a sort order but the sort order option box is disabled until you click off and on again. 2. My pages were not taking in to affect the changes made on the admin side. I had to delete the pages in header tags seo, then click 'add missing'. When I defined it again they worked. Is this a bug from the upgrade?
×