Latest News: (loading..)

m.a.t.t

Members
  • Content count

    98
  • Joined

  • Last visited

1 Follower

About m.a.t.t

Profile Information

  • Real Name
    Matt Hawkins
  1. Ah yes, my bad I'd uploaded an older version of the admin database tables file! OK that's that sorted.. next problem along... Fatal error: Call to undefined function tep_create_random_value() in /home/***/public_html/admin/orders_protx.php on line 80 I'm guessing there's a function missing from a functions file, but I can't see anything in the install instructions, using the 5.0b readme file. Sorry to be a pain in the arse :s
  2. ^^ Have you created your own test vendor account over at protx? Just a thought, I might be totally wrong of course :) I have another problem of my own... the guy who's site I am building as a favour managed to corrupt the mysql database (without backing it up, which I did reiterate several times!!!), so I've been working to fix it.. I'm mostly there now but, I get this error when trying to process a refund using the orders screen in OSC admin: 1146 - Table '*********.TABLE_PROTX_DIRECT' doesn't exist SELECT * FROM TABLE_PROTX_DIRECT WHERE id='1' [TEP STOP] Could someone post up their Protx table from their database (just the makeup, not the customers bit) so I can double check that the entries are correct from this end. Cheers Matt
  3. Thanks Tom, I will look further into it... Haven't added the SSL on yet, and the colours are a WIP,
  4. Hi Tom... Great contrib, works perfectly on the processing side, I've just got a small problem with the layout of checkout_confirmation.php For some reason, it's throwing out the nicely centered shop on the above page, and moving everything back over to the left. Any reason you can think of? I've tried Rory's solution above, with no change. Thanks! Matt
  5. How strange.. mine too! I've currently got mine set to sandbox for testing, if that's any help
  6. Do you have IPN (Instant Payment Notification) activated in Paypal?
  7. Paypal IPN would solve this... It's built into the standard paypal module that comes with OSC.
  8. Have a read here: http://forums.oscommerce.com/index.php?showtopic=313232
  9. I saw another report of this in one of the feedback threads as well?
  10. Anyone?
  11. Hi. I'm struggling to get the IPN back to my site, using sandbox. I've checked all the file permissions, and the php.ini file, everything seems to be in order, I can call ipn.php from my browser. I can't see that Paypal are returning to my site at all through the "who's online" panel in admin. My site settings are as follows: PHP Version: 5.2.6 OSC Version: 2.2RC2 IPN Version: 2.3.3 cUrl Information: libcurl/7.18.2 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5 php.ini is installed in the ext folder as per the install instructions. Would it be anything to do with the IP trap addon? Pls help :D
  12. Never mind.. I restored the backups :)
  13. Hello great people of OSC ;) I need some help :D I've installed this addon: http://addons.oscommerce.com/info/4148 It's throwing up this error when I load index.php: Fatal error: Call to a member function add_current_page() on a non-object in /home/hawkinsp/public_html/theglittergarden.co.uk/includes/application_top.php on line 320 Line 320 of application_top.php reads: $navigation->add_current_page(); All I added to the application_top.php file was this: // coupons addon start require('includes/application_coupon.php'); // coupons addon end So I haven't modified the line thats throwing up the fatal error at all. I hope someone can help here, if not, I'll have to sign up to the .de version of the OSC forum and muddle through. Here's hoping, thanks in advance :)
  14. Thanks for this contribution, really appreciated :) Great install instructions too! Cheers
  15. To fix the above issue, I've had to remove the No Images section of the auto thumbnailer (found on the addons section of the site) To do this: Go to catalog/includes/functions/html_output.php Locate around line 96: // if no file exists display the 'no image' file if (!is_file($src)) { $src = "images/no_image.jpg"; } Replace with // if no file exists display the 'no image' file //if (!is_file($src)) { //$src = "images/no_image.jpg"; sadly, that means that any products without images will just show broken links :s I don't know enough PHP to fix it //}