Jump to content

dollcreator

Members
  • Content count

    20
  • Joined

  • Last visited

Posts posted by dollcreator


  1. I have the COD module installed. However, when it is used there are no items listed on the invoice. The items are not even listed in the database, just the order total and the taxes. The only way I know what has been ordered is in the pending order email send out by the pending order module. The order process email, and the email send to the customer does not show the items. This makes it impossible to fill the order when the pending order email gets marked as junk and deleted...

    What do I have wrong with this module? Orders that are paid with Paypal show the individual items ordered, but when COD is used there are no items. This payment is used a lot, since I do local deliveries,and then people can pay me cash.

    Can someone tell me how to fix this?


  2. For the first problem, that field isn't part of this contribution so you've made a mistake somewhere.

     

    Hmmm, interesting. I came up with the same error when going to mydomain/googlesitemaps/index.php. If it not part of this contrib, it sure is strange that this is the only time it has ever come up. Sure would like to know where it came from....

     

    Marianne


  3. Hi,

    I have searched everywhere, but can't seem to get the search to come up with meaningful answers. I am using osCommerce 2.3.1 and the latest download of this addon.

    I have set this addon to force cookie use, to get rid of the session id, but now it keeps reporting that the browser has blocked cookies, I have it happen with Firefox, Chrome and IE, and all are set to accept cookies. I'd really like to use the cookies, since I think it is inappropriate for the session id to be showing up in the browser address bar. That is too risky if anyone wants to copy and paste the address to forward to someone else, they would get the session id as well, which could lead to problems.

    Is there something I have missed that it keeps reporting that the browser has blocked cookies even though they haven't?

    I hope someone can tell me what I did wrong.

    Thanks,

    Marianne


  4. Hi Frank,

    I've installed the contribution and it was super easy to do. However, I am getting the "Image not found" image on all my jpg files - interestingly, it seems to know the general dimensions of the image that it's not finding, because they are all appear with slightly (and correctly) different displayed sizes of the "Image not found" - have you any thoughts on what might cause this?

    Test site is here http://www.classicbikebooks.com/catalogus

     

    Thanks

    Chris S.

     

    I am running into the same problem. Has anyone figured what causes this? All my images come up with 'image not found'. The images appear in the preview on the admin page, but only in thumbnail size.

    I guess I'll have to uninstall this, and manually resize the images to get them to show up properly, since the product images were humongous and not resizing at all before I installed this.

     

    Thanks,

    Marianne


  5. While testing the paypal standard addon when being redirected back to my website after making payment, it comes up with the following error:

    Fatal error: Call to a member function update_credit_account() on a non-object in the paypal_standard.php file.

    the error line is as follows:

    // Start - CREDIT CLASS Gift Voucher Contribution

    $order_total_modules->update_credit_account($i);

    // End - CREDIT CLASS Gift Voucher Contribution

     

    Anyone know what I missed, or where I made an error to cause this?

     

    Thanks,

     

    Marianne

     

    After several days digging in the forum for version 5.23, I found that someone more than a year ago found that the $order_total_modules variable was not declared in line 396 of the function before_process(). If you insert that variable in that line, it seems to work fine. Has no one else run into that problem since then? It was never fixed in the files. I don't know how to add it into the download package, but maybe someone else can.


  6. While testing the paypal standard addon when being redirected back to my website after making payment, it comes up with the following error:

    Fatal error: Call to a member function update_credit_account() on a non-object in the paypal_standard.php file.

    the error line is as follows:

    // Start - CREDIT CLASS Gift Voucher Contribution

    $order_total_modules->update_credit_account($i);

    // End - CREDIT CLASS Gift Voucher Contribution

     

    Anyone know what I missed, or where I made an error to cause this?

     

    Thanks,

     

    Marianne


  7. I've never tried using HTML in the banner rotator. The Javascript that runs it was designed to work with images, so i may just not work. Can you get the images and use those instead?

     

    Regards

    Jim

    No, Amazon does not use seperate pictures, it uses html, since your affiliate account is embedded into the html. That is how you earn your money....You can't make your own banner, you have to use theirs.

    Guess I'll just have to keep the banner at the bottom....

     

    Marianne


  8. Must be doing something wrong with the banner rotator. The only banners I have right now are from Amazon, which just come in html form, not pictures to download. They work fine when they are in the footer, but when I use the rotator it only shows the html text, and not the animated banner picture like it does in the footer.

    Am I missing some setting?

     

    Marianne


  9. I also seem to have a problem with the master product adding when a slave is added to the cart, I only want the slaves to be added to the cart, not the master, it is only the description of the item, not the actual product. I do have the 'Allow checkout' set to false in the config, so since the master has 0 quantity, it should not add to the cart.

     

    Marianne

     

    Ok, I have figured out how to stop the 'out of stock' appearing on the master listing. BUT....I still have the problem that when adding a slave to the shopping cart, it automatically adds the master as well. This is not what I want. I want only the slave added, since the master only has the description, no price or quantity. Sure it can be deleted later, but that is a nuisance. I don't want it added in the first place!!

     

    How can I stop this from happening??

    Thanks,

    Marianne


  10. I am sure I read somewhere that when you have your master set at no price/no quantity that it should not show 'products out of stock'. If that is true, how come it still shows up? Doesn't look very good to have the master say that products are out of stock, while the slaves still have products.

    What do I need to fix?

     

    Thanks,

     

    Marianne

    I also seem to have a problem with the master product adding when a slave is added to the cart, I only want the slaves to be added to the cart, not the master, it is only the description of the item, not the actual product. I do have the 'Allow checkout' set to false in the config, so since the master has 0 quantity, it should not add to the cart.

     

    Marianne


  11. I am sure I read somewhere that when you have your master set at no price/no quantity that it should not show 'products out of stock'. If that is true, how come it still shows up? Doesn't look very good to have the master say that products are out of stock, while the slaves still have products.

    What do I need to fix?

     

    Thanks,

     

    Marianne


  12. I've run into a problem with the manufacturers.php. When I try to add a manufacturer I first end up with the error that mfg_abbrev does not exist in the database. I can get around that by not using the abbreviation. However, then I end up with the warning ERROR_NOT_EMPTY, and it does not add the manufacturer. I haven't made any changes to the manufacturers file, just uploaded the one that came with the addon. Comparing it to the original, I think it has something to do with the mfg_abrev, since it does say ...&& tep_not_null($mfg_abbrev))in line 25, so obviously it is insisting on adding it, but there is no such column in the database.

     

    Marianne


  13. Is this going to be updated to work with osCommerce V2.3.1??

    I downloaded the update that was posted just last week, and I was hoping it would be compatible with the latest version, since the program was updated several months ago. However, I find it is not compatible. I am having some serious display issues, since they changed from using tables to using divs. The tables just don't work well on a page that is set up differently.

    I have been struggling with this add-on, and/or others for filing the images in different folders and to get it to work with 'Master Products and Magic Variants for OSCOM V2.3x' which can be found here for several weeks now, but I just can't get them to work together. I think the main issue is the difference in how the product display is set up.

    Is there anyone who could help me with this? I guess I just don't know enough about webdev to get this done, any help would be greatly appreciated.

    thanks,

    Marianne


  14. That didn't work. Still the same error message. Must be missing something else.

     

    Never mind, figured it out. The instructions for the new shop install don't mention that you still have to copy over what is in the upload directory. So all those files were missing. You might want to add the files from the upload to the newshop directory, so that they will also be installed when copying the newshop directory.

     

    thanks,

     

    Marianne


  15. Hi,

     

    catalog/includes/filenames.php

     

    insert if not exist

    // Master Products
     define('FILENAME_MASTER_LISTING', 'master_listing.php');
     define('FILENAME_MASTER_PRODUCTS', 'master_products.php');
     define('FILENAME_SUGGESTED_MASTERS', 'suggested_masters.php');  
    // Master Products EOF
    

     

    regards,

    Gergely

     

     

    That didn't work. Still the same error message. Must be missing something else.


  16. Thanks for post.

     

    Categories and products counter for master products

     

    edit:

     

    includes/functions/genereal.php

     

    change (in 418):

     

    $products_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where p.products_id = p2c.products_id and p.products_status = '1' and p2c.categories_id = '" . (int)$category_id . "'");

     

    to:

     

    // master products  	
     	$products_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where p.products_id = p2c.products_id and p.products_status = '1' and if(p.products_master_status = '0', p.products_listing_status = '1', p.products_master_status = '1') and p2c.categories_id = '" . (int)$category_id . "'");
    // master products

     

     

    I installed a new version of OSC2.3.1, did the newshop install etc. and came up with the following errors:

     

    Warning: include(includes/modules/FILENAME_MASTER_PRODUCTS) [function.include]: failed to open stream: No such file or directory in C:\xampp\htdocs\store\product_info.php on line 236

     

    Warning: include() [function.include]: Failed opening 'includes/modules/FILENAME_MASTER_PRODUCTS' for inclusion (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\store\product_info.php on line 236

     

    I did the fix as quoted above, but it still comes up with the same error.

    What else do I need to fix?

×