Jump to content

sandwick

♥Ambassador
  • Content count

    106
  • Joined

  • Last visited

Everything posted by sandwick

  1. Thanks to George, he was able to help me work this out ! Issue Solved !!! Thanks again George.
  2. How do i change my footer from a grid 4 to grid 6 ? You can see in the image that there are four columns now, would like to add 2 more for more Customer information on products. I am currently using 2.3.3 with Mini Template System. thanks !
  3. i need to know where in easy populate it deletes the photo, when i do an insert into db, and the product end of line is set to "Delete" it removes the picture. any help on this would be appreciated ! i am running the following . . . Settings & Info EP vers: 2.8-231 osCommerce Online Merchant v2.3 OS: Array HTTP: DB: PHP: Array (Zend: ) Temp Dir is Writable Magic Quotes is: off register_globals is: off Split files on: 500 records Model Num Size: 12 Price with tax: false Calc Precision: 2 Replace quotes: false Field seperator: comma Excel safe output: true Preserve tab/cr/lf: false Category depth: 7 Enable attributes: true SEF Froogle URLS: false Other Support: MVS Support: false Products Images: true Additional Images: false Additional Images: false More Pics: false UltraPics Pics: false HTC: false SPPC: false Extra Fields: false PDF Upload: false Master Products: false
  4. sandwick

    Seperate Pricing Per Customer v3.5

    I am using SPPC 4.2.2 and wishlist 2.3.3R1 can someone direct me to what I need to modify in the wishlist.php file ? When someone logs in with a Designer level pricing and puts the item on the wishlist, the pricing on the wishlist reflects default price level. any help would be appreciated. running 2.3.3 OSC thanks !
  5. I am very pleased with the quality of service/work that George at (MTS Mini Template System) has provided me. He was very helpful in getting MTS up and running to my specifications and to meet a dead line. George was responsive and very concerned with my needs and assisting when changes needed to be made to my site. I would recommended installing the (MTS) Mini Template System, it will make your life easier when using Oscommerce. I look forward to doing business with George for years to come.
  6. sandwick

    Member Approval 1.6

    I have member approval running on OSC 2.3.3 and PHP 5.4, when and email is sent from create_account.php in the header of the subject line, listed in this code $name, does not show up in the subject line. it is blank, everything gets inserted into the data base. the email vars are empty. I use $name, $firstname, $lastname and they are blank also. Was working great in OSC 2.2 running PHP 5.2 ? what do I need to change to make this work ? $admin_email_text = $customer_opening . ADMIN_EMAIL_WELCOME . ADMIN_EMAIL_TEXT . EMAIL_WARNING; $admin_subject = sprintf(ADMIN_EMAIL_SUBJECT, $name); tep_mail(STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, $admin_subject, sprintf($admin_email_text, $name), STORE_OWNER, EMAIL_FROM, ''); Here is my code where I am trying to pull the data and send in an email define('ADMIN_EMAIL_TEXT', ' ' . $firstname . '<b> ' . $lastname. ', </b>at ' . $company . ', has applied for access to <b>' . STORE_NAME . ' </b>eCommerce web site on ' . strftime(DATE_FORMAT_SHORT) . ' at ' . strftime(DATE_TIME_ONLY) . ' <br /> ' . $firstname . ' ' . $lastname . ' <br /> ' . $company . ' <br /> ' . $street_address . ' <br /> ' . $city .', ' . $state .' ' . $postcode . ' <br /> ' . $telephone . ' <br /> ' . $email_address . ' ' . "\n\n"); any help would be appreciated. thanks Sandwick
  7. sandwick

    [Addon] PDF Datasheet

    Bummer, it has to be related with the image. if I change to image width to 300px wide, the footer line will be longer then what it is now. Larry
  8. sandwick

    [Addon] PDF Datasheet

    I have the contribution installed and up and running, but have a few questions about the layout . is there a way to center the image on the page, there are only options to place the image left or right ? At the bottom of the screen my footer line does not go all the way across the page, it seems to be as long as the images size is. See pdf attached. thanks Sandwick
  9. sandwick

    [Addon] PDF Datasheet

    looking into it, thanks for the directions. // Larry
  10. sandwick

    [Addon] PDF Datasheet

    my categories boxes was working OK, before I installed this contribution ? I installed pdf datasheet 1.2.1 Regards Larry
  11. sandwick

    [Addon] PDF Datasheet

    I have manage to install the pdf module and I have installed serveral modules. When I click on the link on the products_info page I get the following errors. I did install the headsent.php file to test for file integrity and received no erros. I am runnung Osc 2.3.3 and 5.4 PHP can you suggest anything i can look at to resolve the errors. I have gone as far as removeing all modules except the one that are "Required" . any help would be appreciated. Thanks !
  12. sandwick

    Store Mode (Open | Closed | Maintenance)

    I have just installed this great contribution on my server that is running the following Osc 2.3.3 PHP 5.4 Everything is working like it is supposed to except when I try to submit an email, I get the following error, can someone offer any advise as why i would get this error. The contact form works when the store is OPEN and I have waited the alloted 15 minutes. here is a screen shot of the error I am getting Any help would be appreciated !!! Thanks Sandwick
  13. I just added this to my OSC 2.3.3 and it does NOT work, the prices are still listed. ************************************** 2. In includes/classes/currencies.php ************************************** find: function format($number, $calculate_currency_value = true, $currency_type = '', $currency_value = '') { Add below: // Start Prices for Logged-In Users Only v5 if ( defined( STORE_SHOW_GUESTS_PRICES ) && ( STORE_SHOW_GUESTS_PRICES == 'true' ) && (! tep_session_is_registered('customer_id') ) ) { return TEXT_LOG_IN_TO_SEE_PRICE; } // End Prices for Logged-In Users Only v5 ************************************** 3. In includes/languages/english.php ************************************** add: // Start Prices for Logged-In Users Only v5 define('TEXT_LOG_IN_TO_SEE_PRICE', 'Please log in to see prices'); // End Prices for Logged-In Users Only v5 ************************************** is there anything else I need to modify to make this work ? any suggestions would be appreciated. // Sandwick OSC 2.3.3 PHP 5.4
  14. sandwick

    KissIT Image Thumnailer

    I have just installed this contribution, and I have some problems with the aspect ratio of the images on the product_info.php page. Some of my images are square and some are rectangles how to I maintain aspect ratio ? My images are as follows, 150px on the long edge (thumbnail) 475px on the long edge (product_info) 950px on the long edge (click image on product_info page) what do I have to do to correct the, my images are already uploaded, just in different directories. Any help would be appreciated. Oscommerce 2.3.3 Contributions Installed MTS SPPC Secrity Pro
  15. sandwick

    Member Approval Installation

    I have the same error, just showed up, when I changed the PHP version on my server from 4.4.9 to 5.2. Can anyone make a suggestion as to how to resolve this issue ? Any help would be appreciated. Thanks in advance. osCommerce Online Merchant v2.2 RC2a PHP 5.2.17
  16. You contribution is easy as 1 2 3, on number 2, how do I install the infobox in my admin ?

    any suggestions would be appreciated.

    Thanks.

  17. Everytime I perform an update with easy populate, my images are deleted. How can I stop this ? Any help would be appreciated. EP vers: 2.76g-MS2 osCommerce Online Merchant v2.2 RC2a OS: Linux 2.6.28.8-20100125a-iscsi-ntacker-fasync-mremap-grsec HTTP: Apache DB: MySQL 5.0.91-log PHP: 4.4.9 (Zend: 1.3.0)
  18. Could NOT get help with the Official Forum Support Thread: http://forums.oscommerce.com/index.php?showtopic=96806 First let me say this is a great contribution. I am currently running 1.5.1 and everything has been running great ! I would like to know how to change the code listed below to make it manditory to fill out the referral or other ... <!-- //from create_account.php --> <!-- //rmh referral start --> <?php if ((tep_not_null(tep_get_sources()) || DISPLAY_REFERRAL_OTHER == 'true') && (!tep_session_is_registered('referral_id') || (tep_session_is_registered('referral_id') && DISPLAY_REFERRAL_SOURCE == 'true')) ) { ?> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td class="main"><b><?php echo CATEGORY_SOURCE; ?></b></td> </tr> <tr> <td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox"> <tr class="infoBoxContents"> <td><table border="0" cellspacing="2" cellpadding="2"> <tr> <td class="main"><?php echo ENTRY_SOURCE; ?></td> <td class="main"><?php echo tep_get_source_list('source', (DISPLAY_REFERRAL_OTHER == 'true' || (tep_session_is_registered('referral_id') && tep_not_null($referral_id)) ? true : false), (tep_session_is_registered('referral_id') && tep_not_null($referral_id)) ? '9999' : '') . ' ' . (tep_not_null(ENTRY_SOURCE_TEXT) ? '<span class="inputRequirement">' . ENTRY_SOURCE_TEXT . '</span>': ''); ?></td> </tr> <?php if (DISPLAY_REFERRAL_OTHER == 'true' || (tep_session_is_registered('referral_id') && tep_not_null($referral_id))) { ?> <tr> <td class="main"><?php echo ENTRY_SOURCE_OTHER; ?></td> <td class="main"><?php echo tep_draw_input_field('source_other', (tep_not_null($referral_id) ? $referral_id : '')) . ' ' . (tep_not_null(ENTRY_SOURCE_OTHER_TEXT) ? '<span class="inputRequirement">' . ENTRY_SOURCE_OTHER_TEXT . '</span>': ''); ?></td> </tr> <?php } ?> </table></td> </tr> </table></td> </tr> <?php } else if (DISPLAY_REFERRAL_SOURCE == 'false') { echo tep_draw_hidden_field('source', ((tep_session_is_registered('referral_id') && tep_not_null($referral_id)) ? '9999' : '')) . tep_draw_hidden_field('source_other', (tep_not_null($referral_id) ? $referral_id : '')); } ?> <!-- //rmh referral end --> What i am finding out is that if they do not give me any data in the REFERRAL Source section of the create account screen the user information DOES NOT get inserted into the data ! any help would be appreciated ! Thanks Server OS: Linux 2.6.28.8-20100125a-iscsi-ntacker-fasync-mremap-grsec Database: MySQL 5.0.81-log HTTP Server: Apache PHP Version: 4.4.9 (Zend: 1.3.0) osCommerce Online Merchant v2.2 RC2a
  19. sandwick

    How Did You Hear About Us - Support

    First let me say this is a great contribution. I am currently running 1.5.1 and everything has been running great ! I would like to know how to change the code listed below to make it manditory to fill out the referral or other ... <!-- //from create_account.php --> <!-- //rmh referral start --> <?php if ((tep_not_null(tep_get_sources()) || DISPLAY_REFERRAL_OTHER == 'true') && (!tep_session_is_registered('referral_id') || (tep_session_is_registered('referral_id') && DISPLAY_REFERRAL_SOURCE == 'true')) ) { ?> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td class="main"><b><?php echo CATEGORY_SOURCE; ?></b></td> </tr> <tr> <td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox"> <tr class="infoBoxContents"> <td><table border="0" cellspacing="2" cellpadding="2"> <tr> <td class="main"><?php echo ENTRY_SOURCE; ?></td> <td class="main"><?php echo tep_get_source_list('source', (DISPLAY_REFERRAL_OTHER == 'true' || (tep_session_is_registered('referral_id') && tep_not_null($referral_id)) ? true : false), (tep_session_is_registered('referral_id') && tep_not_null($referral_id)) ? '9999' : '') . ' ' . (tep_not_null(ENTRY_SOURCE_TEXT) ? '<span class="inputRequirement">' . ENTRY_SOURCE_TEXT . '</span>': ''); ?></td> </tr> <?php if (DISPLAY_REFERRAL_OTHER == 'true' || (tep_session_is_registered('referral_id') && tep_not_null($referral_id))) { ?> <tr> <td class="main"><?php echo ENTRY_SOURCE_OTHER; ?></td> <td class="main"><?php echo tep_draw_input_field('source_other', (tep_not_null($referral_id) ? $referral_id : '')) . ' ' . (tep_not_null(ENTRY_SOURCE_OTHER_TEXT) ? '<span class="inputRequirement">' . ENTRY_SOURCE_OTHER_TEXT . '</span>': ''); ?></td> </tr> <?php } ?> </table></td> </tr> </table></td> </tr> <?php } else if (DISPLAY_REFERRAL_SOURCE == 'false') { echo tep_draw_hidden_field('source', ((tep_session_is_registered('referral_id') && tep_not_null($referral_id)) ? '9999' : '')) . tep_draw_hidden_field('source_other', (tep_not_null($referral_id) ? $referral_id : '')); } ?> <!-- //rmh referral end --> What i am finding out is that if they do not give me any data in the REFERRAL Source section of the create account screen the user information DOES NOT get inserted into the data ! any help would be appreciated ! Thanks Server OS: Linux 2.6.28.8-20100125a-iscsi-ntacker-fasync-mremap-grsec Database: MySQL 5.0.81-log HTTP Server: Apache PHP Version: 4.4.9 (Zend: 1.3.0) osCommerce Online Merchant v2.2 RC2a
  20. using product_listing.php,v 2.1.5 The image file must be put in the catalog/images folder, not the folder with your images in it. Now when and image does not exist, the server will not make a WAG and just show the next closest image, I also found where to go to stop EP to stop deleting images, when an upload is performed. Two big fixes and it is just Monday !!! I had to change the following to get the "NO-IMAGE" to work, not running the latest and greatest. YET ! I am running SPPC, that is why the numbering might be off ! Line 213 Replace this $lc_text = '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'manufacturers_id=' . $_GET['manufacturers_id'] . '&products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $listing['products_image'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a>'; with this $lc_text = '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'manufacturers_id=' . $_GET['manufacturers_id'] . '&products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . (file_exists(DIR_WS_IMAGES . $listing['products_image']) ? $listing['products_name'] : 'no-image.jpg'), SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a>'; Line 215 Replace this $lc_text = ' <a href="' . tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $listing['products_image'], $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a> '; with this $lc_text = ' <a href="' . tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . (file_exists(DIR_WS_IMAGES . $listing['products_image']) ? $listing['product_image'] : 'no-image.jpg'), $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a> '; Line 232 Replace this 'text' => (isset($_GET['manufacturers_id']) && tep_not_null($_GET['manufacturers_id']) ? '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'manufacturers_id=' . $_GET['manufacturers_id'] . '&products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $listing['products_image'], $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a>' : '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $listing['products_image'], $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a>' )); } with this 'text' => (isset($_GET['manufacturers_id']) && tep_not_null($_GET['manufacturers_id']) ? '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'manufacturers_id=' . $_GET['manufacturers_id'] . '&products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . (file_exists(DIR_WS_IMAGES . $listing['products_image']) ? $listing['products_image'] : 'no-image.jpg'), $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a>' : '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . (file_exists(DIR_WS_IMAGES . $listing['products_image']) ? $listing['products_image'] : 'no-image.jpg'), $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a>' )); } Line 382 Replace this $image = $products['$products_image']; with this $image = (file_exists(DIR_WS_IMAGES . $products['$products_image']) ? $products['products_image'] : 'no-image.jpg'); Line 390 Replace this $image = '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $products['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $image, ($addimages ? (tep_not_null($selected_image['images_description']) ? $selected_image['images_description'] : (tep_not_null($selected_image['products_image_description']) ? $selected_image['products_image_description'] : $products['products_name'])) : $products['products_name']), PRODUCT_IMAGE_WIDTH, '') . '</a>' . '<br><br>'; with this $image = '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $products['products_id']) . '">' . tep_image(DIR_WS_IMAGES . (file_exists(DIR_WS_IMAGES . $image) ? $image : 'no-image.jpg'), ($addimages ? (tep_not_null($selected_image['images_description']) ? $selected_image['images_description'] : (tep_not_null($selected_image['products_image_description']) ? $selected_image['products_image_description'] : $products['products_name'])) : $products['products_name']), PRODUCT_IMAGE_WIDTH, '') . '</a>' . '<br><br>'; Thanks for the directions SPOOKS !
  21. I have been running this for a while now and it is a great contribution. Here is my infomation Server Information Server OS: Linux 2.6.28.8-20090428g-filemon-idmap-grsec Database: MySQL 5.0.81-log HTTP Server: Apache PHP Version: 4.4.9 (Zend: 1.3.0) osCommerce Online Merchant v2.2 RC2a product listing v 2.1.5 I am running into problem where the images are not being displayed correctly, where ERROR 300 Multiple Choice kicks in and it grabs the closes file that would match 22345.jpg when I am really looking 22354.jpg. Where in the products_listing.php modules can I test to see if the image exists in the directory and if not replace with 0.jpg (NO Image picture). I tried to put this code listed below on line 388 of my file <?php $filename = $image; if (file_exists($filename)) { $image = $image; } else { $image = "0.jpg"; } ?> Just after this code and it does not work, I keep getting NO image. $addimages = (file_exists(DIR_WS_CLASSES . 'displayimages.php')); // Additional Images Present if ($addimages) { $image_query = tep_db_query( "SELECT ai.medium_images, ai.images_description, ai.popup_images, p.products_image_med, p.products_image_description FROM " . TABLE_ADDITIONAL_IMAGES . " ai, " . TABLE_PRODUCTS . " p WHERE ai.products_id=p.products_id and ai.products_id = '".(int)$products['products_id']."'"); $selected_image = tep_db_fetch_array($image_query); $image = ($selected_image['medium_images'] ? $selected_image['medium_images'] : ($selected_image['products_image_med'] ? $selected_image['products_image_med'] : ($selected_image['popup_images'] ? $selected_image['popup_images'] : $products['products_image']))); } Any help in showing me how to test for a file exist and substituting a NO image if the file is not there would be appreciated. thanks in advance.
  22. very frustrating . . . I am not using anything that would substitute images the only contrib I have that deals with images is this one. I have not even installed the multi images contrib.
  23. Sam, great contribution ! When the query runs to pick up the images and I do not have an image that needs to be displayed, I should get the "X" image, the default for broken link to image. I am not getting this, for what ever reason if the query returns M173.jpg and I do not have the image in my directory, it will display M137.jpg ? This is weird :rolleyes: When I display the source for the HTML page being displayed, the CODE has M173.jpg, but the thumbnail page displays the WRONG image. Any suggestions and help would greatly be appreciated! thanks.
  24. Can someone make it so when customer A logs in the manufacture list displays all manufactures in the STORE ( This is the DEFAULT on the STORE ) manufactureA, manufactureB, manufactureC, manufactureD and when a flag is set on the customer B it will display LIMITED manufactures in the the STORE manufactureA, manufactureB, manufactureC this will allow STORES to show certian Items to customers in certian places in the world ? Any help in getting this done would be greatly appreciated !!!
  25. Great Product !!! When I do an update to my database is there a way NOT to delete my IMAGE when the status is changed from ACTIVE to DELETE ? I need to save my images, where in the code does it REMOVE the images that are flag for DELETE ? My settings are listed below, and any help would be appreciated ! Here are my Easy Populate Settings 2.76g-MS2 EP vers: 2.76g-MS2 osCommerce Online Merchant v2.2 RC2a OS: Linux 2.4.21-NIT-1 HTTP: Apache DB: MySQL 3.23.47 PHP: 4.4.7 (Zend: 1.3.0) Temp Directory: /tmp/disk/home/webmaster/Files/WWW/catalog/temp/ Temp Dir is Writable Magic Quotes is: off register_globals is: on Split files on: 300 records Model Num Size: 12 Price with tax: false Calc Precision: 2 Replace quotes: false Field seperator: comma Excel safe output: true Preserve tab/cr/lf: false Category depth: 7 Enable attributes: true SEF Froogle URLS: false More Pics: false Unknown Pics: false HTC: false SPPC: false Extra Fields: false Thanks in advance // Larry
×