Jump to content

mark27uk3

Members
  • Content count

    1,481
  • Joined

  • Last visited

Everything posted by mark27uk3

  1. mark27uk3

    Protx Direct v2.22

    ok changed all $HTTP_POST_VARS to $_POST and the same error still occurs and no data is in the hidden fields in the source code. Mark
  2. mark27uk3

    Protx Direct v2.22

    Hi Tom, Yes the details are shown as hidden fields <input type="hidden" name="cc_owner"><input type="hidden" name="cc_expires"><input type="hidden" name="cc_type"><input type="hidden" name="protx_direct_cc_number"><input type="hidden" name="cc_cvv"><input type="hidden" name="cc_start"><input type="hidden" name="cc_issue"><input type="hidden" name="osCsid" value="466fd9b1be86151e8dc6f235af21dfc7"><input type="hidden" name="shipping_total" value="1.95"><input type="hidden" name="ord_total" value="3.74"><input type="image" src="includes/languages/english/images/buttons/button_confirm_order.gif" border="0" alt="Confirm Order" title=" Confirm Order " value="submit"> I presume thats a good thing then lol Mark
  3. mark27uk3

    Protx Direct v2.22

    ok looking again at the debug output, I see that all the customer data shows in the debug i.e. name, address, product, product description however the cc data does not I presume then that CC data should be in the string along with the name, address and order details hence why this error is being produced: The BIG BIG question is should the cc data be in string and if so why aint it lol I know I posted alot above, just trying to get my around it and understand it. Thanks Mark
  4. mark27uk3

    Protx Direct v2.22

    Ok so I uninstalled the module in the admin and then reinstalled it and some of the error disappeared and has now been replaced by this: Now normally headers already sent indicates white space but there is no white space in protx_process urgh Mark
  5. mark27uk3

    Protx Direct v2.22

    Ok after looking deeper I saw your reply about this in January, however register_long_arrays is 'On' so something else must be causing it. Regards Mark
  6. mark27uk3

    Protx Direct v2.22

    Hi Tom, Thanks for posting back. I have done as suggested and now it skips the checks, now when I confirm the order on checkout_confirmation I am presented with this error: I can be a pain cant I lol Mark
  7. mark27uk3

    Protx Direct v2.22

    Tom, this is error is generated before checkout_confirmation.php Mark
  8. mark27uk3

    Protx Direct v2.22

    Hi Tom, I have tried various expiration dates as it states in the module Mark
  9. mark27uk3

    Protx Direct v2.22

    Hi Guys, I have installed protx 4.4 and thought all was well until I tried to run a test transaction through the protx test server. I am receiving this error: I have googled forever and day and have noticed that others have had this issue but I can not find definitive resolve. I hope one of you kind people would be able to point me in the right direction as to why the test cc numbers always fail on the cards expiry date :'( Thanks Mark
  10. Hi Todd, My apologies for not replying sooner, its been a wild week. You were correct in your assumptions and it was barfing on products not associated with category. Sorted now thanks :thumbsup: Onward and upward to my next issue lol I am trying to get EP to chuck out a full download through the store front, I have had to copy a couple of functions over from the admin and I will also have to strip out any import features. However when I try and run http://www.mydomain.co.uk/easypopulate.php...amp;dltype=full through the browser it chucks all the data to the screen instead of generating the file to download. Your thoughts would be appreciated. Thanks Mark
  11. Hi Todd, oh yeah theres the little blighter lol Ok here is the info as requested: 1 ) PHP Version: 2) Set EP_SHOW_EP_SETTINGS to true in the EP settings and then 3) Copy of any error message you are receiving. 4) Post a link to a sample of any upload file you are trying. Thanks Mark
  12. ok now I am being blind which part of the docs would that be (now I feel :blush: ) Mark
  13. Hi Guys, I hope someone can point me in the right direction here as I have read and read and read and googled and googled (you get the picture) Either I am being extremely dense or just plain blind. I am pretty sure that my problem is a php5 and can find others with the same problem but no resolution. I am using EP 2.76f This is line 577 $row2 = array_merge($row2, tep_db_fetch_array($result2)); Hoping that someone else has had this issue and resolved it. Thanks Mark
  14. mark27uk3

    [Contribution] U HTML Emails

    Hi Olof, 'Send E-Mails' is set to 'True' (I never turned it off lol) I just dont see why it is not sending the emails because as you say it is creating the html email and saving it in debug format. Weird :'( Mark
  15. mark27uk3

    [Contribution] U HTML Emails

    Hi Olof, Great guide, maybe you should add this to the download. Ok next issue which I can not seem to resolve urgh Our store uses the 'Separate Pricing Per Customer' mod and I thought heh why not add a notify field to send the customer an email when their group status changes. So I did and the email generates perfectly (using debug mode) except that it does not send the email. This is the code I have in admin>customers.php if (isset($HTTP_POST_VARS['notify']) && ($HTTP_POST_VARS['notify'] == 'on')) { //--- Beginning of addition: Ultimate HTML Emails ---// if (EMAIL_USE_HTML == 'true') { require(DIR_FS_CATALOG_MODULES . 'UHtmlEmails/group_update_'. ULTIMATE_HTML_EMAIL_LAYOUT .'.php'); $email = $html_email; }else{//Send text email //--- End of addition: Ultimate HTML Emails ---// //--- Beginning of addition: Ultimate HTML Emails ---// } if(ULTIMATE_HTML_EMAIL_DEVELOPMENT_MODE === 'true'){ //Save the contents of the generated html email to the harddrive in .htm file. This can be practical when developing a new layout. $TheFileName = DIR_FS_CATALOG . 'Last_mail_from_orders.php.htm'; $TheFileHandle = fopen($TheFileName, 'w') or die("can't open error log file"); fwrite($TheFileHandle, $email); fclose($TheFileHandle); } //--- End of addition: Ultimate HTML Emails ---// tep_mail($customers['customers_firstname'], $customers['customers_email_address'], EMAIL_TEXT_SUBJECT, $email, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS); } Is my tep_mail function correct ????? Thanks Mark
  16. mark27uk3

    [Contribution] U HTML Emails

    Hi Olof, Thanks for the point in the right direction. In the end all I had to do was add the login and password calls before this : '. $HTMLMailMainContent.' in the template. Happy Days :thumbsup: Mark
  17. mark27uk3

    [Contribution] U HTML Emails

    Hi Jan, Are you able to shed any light on what you did to fix the name and password being added to the email. I am not sure how the track and trace module works but I have managed to integrate this Tracking Module which supercedes the Royal Mail Track & Trace module quite successfully with the order process email. This is my line from admin>orders.php $email = STORE_NAME . "\n" . EMAIL_SEPARATOR . "\n" . EMAIL_TEXT_ORDER_NUMBER . ' ' . $oID . "\n" . EMAIL_TEXT_INVOICE_URL . ' ' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT_HISTORY_INFO, 'order_id=' . $oID, 'SSL') . "\n" . EMAIL_TEXT_DATE_ORDERED . ' ' . tep_date_long($check_status['date_purchased']) . "\n\n" . sprintf(EMAIL_TEXT_STATUS_UPDATE, $orders_status_array[$status]) ."\n\n" . $tracking->email_add_tracking()."\n" . $notify_comments . "\n" . EMAIL_TEXT_REGARDS; Mark
  18. mark27uk3

    [Contribution] U HTML Emails

    Hi All, I added this contribution last night and it works like a bloomin charm. However I do have one strange issue. Our checkout process is highly modified and it sends a system generated password to the customer in the welcome email. The issue is that all information is present in the welcome email apart from the customers login and password details. I am presuming that they are being stripped out somewhere along the line. This is the code from our checkout page. // build the message content //--- Beginning of addition: Ultimate HTML Emails ---// if (EMAIL_USE_HTML == 'true') { require(DIR_WS_MODULES . 'UHtmlEmails/create_account_'. ULTIMATE_HTML_EMAIL_LAYOUT .'.php'); $email_text = $html_email; }else{ //--- End of addition: Ultimate HTML Emails ---// $email_text = sprintf(EMAIL_GREET_NONE, $firstname . ' ' . $lastname) . EMAIL_TEXT0 . sprintf(EMAIL_LOGIN, $email_address) . sprintf(EMAIL_PASSWORD, $new_password) . EMAIL_TEXT1 . EMAIL_WARNING; //--- Beginning of addition: Ultimate HTML Emails ---// } if(ULTIMATE_HTML_EMAIL_DEVELOPMENT_MODE === 'true'){ //Save the contents of the generated html email to the harddrive in .htm file. This can be practical when developing a new layout. $TheFileName = 'Last_mail_from_create_account.php.htm'; $TheFileHandle = fopen($TheFileName, 'w') or die("can't open error log file"); fwrite($TheFileHandle, $email_text); fclose($TheFileHandle); } //--- End of addition: Ultimate HTML Emails ---// tep_mail($firstname . ' ' . $lastname, $email_address, EMAIL_SUBJECT, $email_text, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS); And this is the code from the html template file. <?php /* ================================================================================ ========= This module does one thing: It creates the contents of the html email in the variable $html_email. If you would like to customize this html email you should first make sure you know a bit about html emails. Here are some liks that might be interesting for you: http://www.xavierfrenette.com/articles/css-support-in-webmail/ http://www.alistapart.com/articles/cssemail/ http://www.campaignmonitor.com/blog/archives/2006/03/a_guide_to_css_1.html http://www.reachcustomersonline.com/content/2004/11/11/09.27.00/index.php ================================================================================ ========= */ require(DIR_WS_LANGUAGES . $language . '/modules/UHtmlEmails/' . 'standard_create_account.php'); $ArrayLNTargets = array("\r\n", "\n\r", "\n", "\r", "\t"); //This will be used for taking away linefeeds with str_replace() throughout the mail. Tabs is invisible so we take them away to $HTMLMailMainContent = str_replace($ArrayLNTargets, '<br />', UHE_WELCOME . UHE_TEXT . UHE_CONTACT . UHE_WARNING); if (ACCOUNT_GENDER == 'true') { if ($gender == 'm') { $HTMLGreet = sprintf(trim(UHE_GREET_MR), $lastname); } else { $HTMLGreet = sprintf(trim(UHE_GREET_MS), $lastname); } } else { $HTMLGreet = sprintf(trim(UHE_GREET_NONE), $firstname.' '.$lastname); } $html_email = '<html> <head><meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"></head> <body width="750" style="margin: 0px; padding: 0px; background-color:#666666;"> <font face="Arial, Verdana, serif"> <table width="750px" height="121px" border="0" cellpadding="0" cellspacing="0" align="center"><tr><td valign="bottom" align="center"><img src="http://www.puzzledrop.co.uk/images/'.STORE_LOGO.'" width="750" height="121"></td></tr> <tr><td><div style="font-size: 12px; padding: 14px; border-style:solid; border-width: 0px; border-color: #666666; background-color:#FFFFFF;"> <span style="font-size: 12px;">'.$HTMLGreet.'</span><br/><br/>'. $HTMLMailMainContent.'</div></td></tr> </table> </body> </html>'; $html_email = str_replace($ArrayLNTargets, '', $html_email); ?> would the str_replace be removing them do you think or have I boobed somewhere else do you think?? Thanks Mark
  19. mark27uk3

    Seperate Pricing Per Customer v3.5

    Hi Jan, I hope you are able to shed a little light for me on a strange issue that I am having. I am running SPPC with all the bells and whistles and it works great apart from that I can not seem to select/deselect the payment and shipping modules when editing the groups, they still appear during the checkout. Now I am not looking for a fix just a shove in the right direction to which file I should actually be looking in. Apologies if I have missed this in the thread somewhere or in the install instructions. Thanks Mark
  20. mark27uk3

    Google CheckOut responsehandler.php order update?

    Do you have 'Force Cookies' set to 'True', if so then set it to 'False' and try it again.
  21. mark27uk3

    [Contribution] PayOffline (Pro)

    Hi Tom, My account is now live and and I am testing out your changes above, yes it does insert the customers name into the transaction but when I go to print the barcode out or reprint through 'my account' it says 'INVALID TRANSACTION ID' Any ideas?
  22. mark27uk3

    [Contribution] PayOffline (Pro)

    Hi Tom, I have installed this module and run some tests on the test server and all appears fine, I do however have a few questions. 1. I presume that when a payment is process through the PayOffline Admin that the callback should then update the order status?? If so does the test environment update the order status or not as my test order was not updated. 2. Is it possible to change the order id to display the actual store order id in PayOffline Admin as at the moment all test orders are showing up as a load of horrible characters 'QAoDh6PZd3KQMhN0FNVgwbbPqKtKxLAvNse0ydhOgOAUkB0g' 3. The display of the barcode on the checkout_success page and the payofflinepro_payslip causes secure/insecure image warnings with my SSL, any ideas??? Thanks Mark
  23. mark27uk3

    Article Manager v1.0

    Hi Guys, Just wondering how the best way to go about changing the article listing, at the minute it displays as such: I was wondering if anyone has tackled article manager to make it look similar to say a knowledge base where the topic categories are listed with the number of articles in brackets and couple of articles underneath the topic name. Maybe this already works out of the box and I am just blind lol Mark
  24. mark27uk3

    Contribution Tracker

    I must have been half a sleep when I type that last reply lol Ok open your catalog/admin/includes/configure.php and look for DIR_WS_CATALOG and change it too this: define('DIR_WS_CATALOG', '/home/myaccountname/public_html/'); // absolute path required Obviously make sure you change the account name to mactch your own. Mark :thumbsup:
  25. mark27uk3

    Contribution Tracker

    My path was set incorrectly in catalog/configure.php Maybe it would be worth putting an example of an absolute url in the install docs just to reinforce the point. Mark
×