Jump to content
Latest News: (loading..)

caniol

Members
  • Content count

    73
  • Joined

  • Last visited

Profile Information

  • Real Name
    Charles Aniol
  • Gender
    Male
  • Location
    Phoenix, AZ USA
  1. Need to update for TLS 1.2

    My online store is built on v2.2 RC2a. I utilize both Authorize.net and PayPal Exress to process payments. They have both stopped supporting TLS 1.0 and TLS1.1. I don’t want to move up to a new version of osCommerce just yet (I have a new project in the works). What do I need to update to use TLS 1.2? Thanks in advance.
  2. Basic Design Pack Support

    I have a webstore currently running on osCommerce-2.2rc2a. I have the Basic Design Pack add-on installed and am very happy with the look and feel. I am now attempting to install the Wishlist 5.1 add-on and all is well except that the CSS button function in the BDP seems to interfere with the Wishlist add-on. I have discovered that if I use the html_output-no-cssbuttons.php file, the Wishlist add-on works perfectly. But now none of my product images are appearing. What I need to do is one of two things: 1. Figure out how to remove just the CSS button function from the html_output-rc2a.php file OR 2. Figure out how to modify the Wishlist add-on to work with the CSS button functionality of the BDP. Any ideas out there?
  3. I've asked this question before and never got an answer... This add-on is working great, except for one thing. It puts the Discount Code info on the same line as the Tax info in the email that is sent to customer after a successful order. ++++++++++++++++ Products ------------------------------------------------------ 1 x Scout Mount () = $34.95 Model SM-E ------------------------------------------------------ Flat Rate (Best Way): $6.95 Discount Coupon MIL/LE01 applied: -$6.95 AZ TAX 8.3%: $2.90 Total: $37.85 ++++++++++++++++ I've seen this issue brought up before, but have yet to see a definitive answer. Can someone please help with this? Thanks!
  4. Wishlist 3.0 Support Thread

    I've gone back to my backup and reinstalled from scratch four times. No errors show up - the products still go to the shopping cart.
  5. Wishlist 3.0 Support Thread

    Any ideas as to what causes the products to go to the shopping cart instead of the wishlist?
  6. Wishlist 3.0 Support Thread

    Has anyone gotten this contribution to work correctly? The customer's products go directly to the shopping cart and never reach the wishlist. I have redone the installation several times and it still does not work correctly.
  7. Wishlist 3.0 Support Thread

    I'm having the same problem. Anyone come up with a solution yet?
  8. Download this fix and apply per instructions. It worked for me. Bug Fix for subtotals problem -=Charles
  9. how to arrange free shipping offer

    Download and install this contribution. It does what you are looking for. Discount Coupon Codes
  10. Can anyone be of assistance with this?
  11. This add-on is working great, except for one thing. It puts the Discount Code info on the same line as the Tax info in the email that is sent to customer after a successful order. ++++++++++++++++ Products ------------------------------------------------------ 1 x Scout Mount () = $34.95 Model SM-E ------------------------------------------------------ Flat Rate (Best Way): $6.95 Discount Coupon MIL/LE01 applied: -$6.95 AZ TAX 8.3%: $2.90 Total: $37.85 ++++++++++++++++ I've seen this issue brought up before, but have yet to see a definitive answer. Can someone please help with this? Thanks!
  12. I ended up do a reinstall and everything is now ok. Thanks.
  13. I tried changing that line. In my setup if I change that line to anything else, it messes up everything else. Using '/catalog/', most everything else works ok. Thanks anyway.
  14. They are the three modules that are part of the OSC 2.2RC2a installation: Payment, Shipping, Order Total. My understanding is that once you hit the install button, the module installs and the button changes and you have access to the module. Now, you hit the install button, a few second hourglass, and nothing. Thanks for taking a look at this.
  15. I’ve asked this in the Installation & Configuration Forum with no result. Hoping someone here can help. When I attempt to install the three modules, it appears they are installing, but they never appear. All I end up with is the same "install modules" button. All of the files appear to be in the three module folders and everything else works fine with the installation. What might I be doing wrong? Here are my configure.php files - if it helps. includes/configure.php // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://www.blackstonetactical.com/catalog/'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers define('HTTPS_SERVER', 'https://www.blackstonetactical.com/catalog/'); // eg, [url="https://localhost"]https://localhost[/url] - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', ''); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', ''); define('HTTPS_COOKIE_PATH', ''); define('DIR_WS_HTTP_CATALOG', ''); define('DIR_WS_HTTPS_CATALOG', ''); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); admin/Includes/configure.php // define our webserver variables // FS = Filesystem (physical) // WS = Webserver (virtual) define('HTTP_SERVER', 'http://www.blackstonetactical.com/catalog/'); // eg, [url="http://localhost"]http://localhost[/url] or - [url="https://localhost"]https://localhost[/url] should not be NULL for productive servers define('HTTP_CATALOG_SERVER', 'http://www.blackstonetactical.com/'); define('HTTPS_CATALOG_SERVER', 'https://www.blackstonetactical.com/'); define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs) define('DIR_WS_ADMIN', '/admin/'); define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN); define('DIR_WS_CATALOG', '/catalog/'); define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
×