Jump to content

dhnelson1

Members
  • Content count

    5
  • Joined

  • Last visited

Profile Information

  • Real Name
    Debbie Nelson
  • Gender
    Female
  • Location
    USA
  • Website
  1. dhnelson1

    Authorize.net PAYMENT MODULE PROBLEMS

    Nicole- in answer to your question: You said to make sure I have the SIM OSC module installed -- how would I check that and if I determine that I do not have it, how would I go about installing it?... When you first go to the OSC admin section for payment modules, there is a generic Auth.net module (which I never used). Instead, I downloaded the following contributions for the AIM http://www.oscommerce.com/community/contributions,4091 http://addons.oscommerce.com/info/5662 http://addons.oscommerce.com/info/5663 and SIM modules, and then settled on the AIM. After you have the contribution installed it will show up in your admin/payment module section which you'll need to "install" right there (see following screen shot) Let me know if this helps at all... Debbie
  2. dhnelson1

    Authorize.net PAYMENT MODULE PROBLEMS

    Nicole- If you want to use the AuthorizeNet form, then you need the SIM OSC payment module (make sure you have that installed in OSC). For your AuthNet settings, the Direct Response needs to be set to NO. Right above that choice in AuthNet I think it even states that the YES setting is only for AIM. And you WILL need to specify URLs for the default Relay and Default Receipt. My understanding is that the URL needs to get the customer back to the shopping cart page at your site. The links per my client's host were: Default Receipt URL setting: ../storename/catalog/checkout_process.php (storename is the directory where you installed OSC) Default Relay Response URL setting: ../storename/catalog/checkout_confirmation.php Give that a try and let me know if it works. good luck, Debbie
  3. dhnelson1

    Authorize.net PAYMENT MODULE PROBLEMS

    I think I've gotten past my problem. It turns out that the transaction key my client provided me with was wrong (even though he's supposed using it for his other sites). It was a frustrating experience but I think I learned a lot during the process of elimination... Regarding your problem, I just might be able to help. There are a couple of settings in AuthorizeNet that need to be specifically set, depending on whether you're using the AIM or the SIM, according to one of their developers (I pestered them a LOT). for SIM: Direct Response: OFF Default Receipt & Relay Relay Response URLs: both should reflect actual pages from the site for AIM: Direct Response: ON Default Receipt & Relay Relay Response URLs: both should be BLANK to accept the default Good luck and let me know if this helps.
  4. CAN SOMEONE PLEASE HELP help with the Authorize.net payment module (have tried both AIM and SIM modules) and have exhausted all of my ideas in getting this resolved for my client. I created an extremely simple site for my client, who sells just 4 products, employing an existing Authorize.net account that was working fine on his old site (his site was set up with a simplistic CMS and wanted a redesign and different host). HERE'S THE PROBLEM: -We can not successfully process a test transaction ---when using AIM module we simply get an "unable to process your credit card...try again" message whether we use the designated "4111..." number or a real card. ---when using the SIM module we get an error (14) reflecting invalid links HERE'S WHAT I'VE TRIED: -both the SIM and AIM modules with appropriate settings on AuthorizeNet account -have tried several suggested fixes from this site, that sounded just like my issue without success -have had numerous tech support calls with NetFirms (host) confirming the correct URLs for the receipt and relay links and anything else I can think of -placed numerous calls to AuthorizeNet, which put me through to one of their developers, who helped me for 2 days and then dropped off the face of the earth. -have also enlisted the help of 2 programmers that specialize in OSC and they're scratching their heads and telling me that all the code looks fine -oh, and I've also successfully processed a test transaction for offline credit card processing so I think everything else works fine CAN SOMEONE PLEASE HELP? I don't know where else to turn. Would appreciate any help!!!! thanks
  5. dhnelson1

    error processing your credit card. (authorize.net)

    Did you ever resolve this issue? I'm trying to get a new client set up with oscommerce and authorize.net and am having the same problem as you. I have tried every fix I could find on this site and nothing works... am at my wits end...any information would be greatly appreciated!!!!!! thanks! :(
×