Jump to content

chiroptera

Members
  • Content count

    9
  • Joined

  • Last visited

Profile Information

  1. chiroptera

    RSS Feed contribution support thread

    With the help of the coder of STS I found a much better solution that the above. Here is how I got RSS 2.0 to work with STS: In sts_default.php find if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "info_shopping_cart")) return ''; // We don't use template for these scripts and replace with if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "rss")|| strstr($scriptbasename, "info_shopping_cart")) return ''; // We don't use template for these scripts Hope this will help other RSS + STS users.
  2. chiroptera

    [contribution] Simple Template System (sts)

    Thx - found it and works :-) This information should be added to the STS manual. Here is how I got RSS 2.0 to work with STS: In sts_default.php find if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "info_shopping_cart")) return ''; // We don't use template for these scripts and change to if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "rss")|| strstr($scriptbasename, "info_shopping_cart")) return ''; // We don't use template for these scripts
  3. chiroptera

    RSS Feed contribution support thread

    Unfortunately I found another problem - UTF8 seems not to work in $rss_title. German Umlauts are not encoded correctly in the RSS title tag :huh: f.e. -> Armbänder should be -> Armbänder Edit: When line 245 of rss.php $rss_title = utf8_encode (replace_problem_characters($rss_title)); is replaced with $rss_title = replace_problem_characters($rss_title); it works :blink:
  4. chiroptera

    RSS Feed contribution support thread

    Found a solution :-) To get RSS Feeds 2.0 to work with STS open rss.php FIND require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_RSS); AFTER ADD $sts->display_template_output = 0;
  5. chiroptera

    [contribution] Simple Template System (sts)

    Found a solution :-) To get RSS Feeds 2.0 to work with STS open rss.php FIND require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_RSS); AFTER ADD $sts->display_template_output = 0;
  6. chiroptera

    RSS Feed contribution support thread

    As I wrote some postings above, I found that this is related to an installed template system. Do you have a template system like STS installed? Think there should be a simple fix for the problem, but I can not find it ;) <_<
  7. chiroptera

    [contribution] Simple Template System (sts)

    I can not get RSS Feeds 2.0 (http://addons.oscommerce.com/info/1513) to work with STS. Is there somone out there who has solved this problem already?
  8. chiroptera

    RSS Feed contribution support thread

    Seems to be a problem with the Simple Template System (STS). If STS is disabled it works - if enabled, STS catches the output of rss.php. Is there someone out who has solved this problem?
  9. chiroptera

    RSS Feed contribution support thread

    I have just installed RSS 2.0 - same problem as described :blink:
×