Jump to content

ccohen

Members
  • Content count

    1
  • Joined

  • Last visited

  1. ccohen

    Paypal Pro, cURL, Godaddy

    This worked for me: //BEGIN GODADDY FIX curl_setopt($curl, CURLOPT_VERBOSE, 1); curl_setopt($curl, CURLOPT_HTTPPROXYTUNNEL, TRUE); curl_setopt($curl, CURLOPT_PROXYTYPE, CURLPROXY_HTTP); curl_setopt($curl, CURLOPT_PROXY, "http://proxy.shr.secureserver.net:3128"); curl_setopt($curl, CURLOPT_TIMEOUT, 120); //END GODADDY FIX Add to your catalog/includes/modules/payment/paypal_direct.php right under: if (function_exists('curl_init')) { $curl = curl_init($server['scheme'] . '://' . $server['host'] . $server['path'] . (isset($server['query']) ? '?' . $server['query'] : '')); curl_setopt($curl, CURLOPT_PORT, $server['port']); curl_setopt($curl, CURLOPT_HEADER, 0); curl_setopt($curl, CURLOPT_SSL_VERIFYPEER, 0); curl_setopt($curl, CURLOPT_RETURNTRANSFER, 1); curl_setopt($curl, CURLOPT_FORBID_REUSE, 1); curl_setopt($curl, CURLOPT_FRESH_CONNECT, 1); curl_setopt($curl, CURLOPT_POST, 1); curl_setopt($curl, CURLOPT_POSTFIELDS, $parameters); Your cUrl parameter on the admin side must be as per default: cURL Program Location /usr/bin/curl Good Luck!
×