Jump to content

cr41g

Members
  • Content count

    27
  • Joined

  • Last visited

Profile Information

  • Real Name
    Craig
  • Gender
    Male
  • Location
    UK
  • Website
  1. cr41g

    Down for Maintenance Add on

    Incase anyone else has issues... I was using the contrib - http://addons.oscommerce.com/info/5865 but - http://addons.oscommerce.com/info/1057 is the same thing but with a different (correct) down_for_maintenance.pfp file. This solved all the problems I was having, in other words don't use 5865!
  2. cr41g

    Google XML Sitemap w/ Admin support

    Hi, I have just added this contrib to my site and all seems to work ok. No errors and the XML files are created, however in the sitemapindex.xml there are no URLs listed other than the the 3 sitemaps themselves. Is this correct? The other two are listing the categories and products respectively as they are supposed to. Cheers, Craig
  3. cr41g

    Down for Maintenance Add on

    Ok thanks anyway you've been a great help. I'll keep trying with that code, and looking into the Error, if not, as you say use a supported add on, I wish i'd noticed that to start with!!! Cheers
  4. cr41g

    Down for Maintenance Add on

    Still no, but I don't think its either of the code lines, even the original if I add the extra "!" infront of "strstr" i'm sure that should work, as the line above (almost identical) works. Could it be that when the right code IS added and the function IS working the application_top.pfp file can't handle that one extra function and times out! I do have other add ons as well that have been added to the this file, such as sid killer and Meta Tags? If this is the case is there a way around it?
  5. cr41g

    Down for Maintenance Add on

    Sorry it does seem to be when I add those lines, not saying its your code but probably me adding it wrong, this is what it looks like when i change it... // BOF: Down for Maintenance except for admin ip if (EXCLUDE_ADMIN_IP_FOR_MAINTENANCE != getenv('REMOTE_ADDR')){ if ( ( DOWN_FOR_MAINTENANCE == 'false' ) and ( !strstr( $PHP_SELF, DOWN_FOR_MAINTENANCE_FILENAME ) ) ) { tep_redirect(tep_href_link(DOWN_FOR_MAINTENANCE_FILENAME)); } } // do not let people get to Down for Maintenance page if not turned on if ( ( DOWN_FOR_MAINTENANCE == 'false' ) and ( !strstr( $PHP_SELF, DOWN_FOR_MAINTENANCE_FILENAME ) ) ) { tep_redirect(tep_href_link(FILENAME_DEFAULT)); } // EOF: WebMakers.com Added: Down for Maintenance When I put it back to the oringinal instructions code I don't get a FastCGI error but obviously I can then view the D4M page when I shouldn't be able to.
  6. cr41g

    Down for Maintenance Add on

    Thanks yet again for you're help. I had to reload a back up version of my site for another error which overwrote all the code i'd added for this contrib previously but I have since re-added it with the two code changes you suggested, but although it was working previously when I go to my site now it brings back a FastCGI Error. I've looked this up and to be honest the answers aren't making much sense to me. Can you please help. I will re-install the back ups again if need be but i'd rather like to have this code/contrib working!
  7. cr41g

    Down for Maintenance Add on

    Yes I did, thank you. Although i've noticed another issue now... When the down for Maintenance option is set to false vistitors are not meant to be able to view the D4M page, yet this does not seem to be the case. This is the code that is added to application_top.php, could this be redundant also? // BOF: Down for Maintenance except for admin ip if (EXCLUDE_ADMIN_IP_FOR_MAINTENANCE != getenv('REMOTE_ADDR')){ if (DOWN_FOR_MAINTENANCE=='true' and !strstr($PHP_SELF,DOWN_FOR_MAINTENANCE_FILENAME)) { tep_redirect(tep_href_link(DOWN_FOR_MAINTENANCE_FILENAME)); } } // do not let people get to Down for Maintenance page if not turned on if (DOWN_FOR_MAINTENANCE=='false' and strstr($PHP_SELF,DOWN_FOR_MAINTENANCE_FILENAME)) { tep_redirect(tep_href_link(FILENAME_DEFAULT)); } // EOF: WebMakers.com Added: Down for Maintenance Craig
  8. cr41g

    Header Tags for novices

    No Worries, I found it, just swapped the TITLE to the front of the section, sorry for being stupid!
  9. cr41g

    Header Tags for novices

    Hi all, How can I change it so, at least in the index page, my site name appears 1st in the title tag? I want it so it says "My Site - My Slogan" at the moment i've only been able to set it to "My Site - My Slogan - My Site" as it defaults to having my site name last. Thanks for any help Craig
  10. cr41g

    Down for Maintenance Add on

    Thank you for your help.
  11. cr41g

    Down for Maintenance Add on

    The contrib was down for maintenance the (http://addons.oscommerce.com/info/5865) I followed the instuctions and have double checked what I did. I cannot see any errors I have made comparing back to the instructions.
  12. cr41g

    Down for Maintenance Add on

    This is the error message I receive on the index page when activating the matenance notification. Thank you.
  13. I recently installed the above add on which does turn on and off via admin correctly. But the notify customer section does not work. When I activate it an error appears from the header.php file. This is the code that has been added to said file. // give the visitors a message that the website will be down at ... time if ( (WARN_BEFORE_DOWN_FOR_MAINTENANCE == 'true') && (DOWN_FOR_MAINTENANCE == 'false') ) { tep_output_warning(TEXT_BEFORE_DOWN_FOR_MAINTENANCE . PERIOD_BEFORE_DOWN_FOR_MAINTENANCE); } // this will let the admin know that the website is DOWN FOR MAINTENANCE to the public if ( (DOWN_FOR_MAINTENANCE == 'true') && (EXCLUDE_ADMIN_IP_FOR_MAINTENANCE == getenv('REMOTE_ADDR')) ) { tep_output_warning(TEXT_ADMIN_DOWN_FOR_MAINTENANCE); } Is there something wrong here or could it be something else? Thanks in advance for any help. Craig
  14. cr41g

    Stray Line of code!

    Just for reference, I finally found the problem! If anyone else gets this it was right at the bottom of the english.php file. I have no idea how it got like it was as I hadn't done anything to that file, but hey there it was! Simply deleting the stray line fixed it! Cheers.
  15. cr41g

    Stray Line of code!

    Thanks for trying Jim, but I can't find it in either of those either!!!!
×