Jump to content

pinballfixer

Members
  • Content count

    15
  • Joined

  • Last visited

About pinballfixer

  • Birthday 02/12/1979

Profile Information

  • Real Name
    Owen
  • Gender
    Male
  • Location
    Melbourne
  1. pinballfixer

    Header Tags SEO

    Sorry for not being clearer - it was VERY late here when I posted. I modified the code in the header_tags_social_bookmarks.php file to display "Add [product name] to:" and then the social bookmark images. [product name] is a clickable link in the same way that your "Currently Viewing: [product name]" is. I added this to line 4 of header_tags_social_bookmarks.php: $PROD = $_SERVER["REQUEST_URI"]; I then added this to line 10 of header_tags_social_bookmarks.php to display "Add [product name] to:" (before the social bookmark images): <td style="font-family: Arial, Helvetica, sans-serif; font-size: smaller;">Add <a href="<?php echo $PROD ?>"><?php echo $NAME ?></a> to:</td> I also found that if I used this code in products_info.php for "Currently Viewing: [product name]" it would work as it should in STS: <?php /*** Begin Header Tags SEO ***/ ?> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td class="smallText" align="center"><?php echo TEXT_VIEWING; ?> <?php $PROD = $_SERVER["REQUEST_URI"]; ?> <a href="<?php echo $PROD ?>"><?php echo $NAME ?></a> </td> </tr> <?php /*** End Header Tags SEO ***/ ?> I hope this makes sense now... Regards, Owen.
  2. pinballfixer

    Header Tags SEO

    In addition to my last post... (which got submitted when it shoudn't have)... The following code will take care of the STS and Header Tags SEO problem for the "Currently viewing:" code: <!--- BEGIN Header Tags SEO Social Bookmarks --> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td class="smallText" align="center"><?php echo TEXT_VIEWING; ?> <?php $PROD = $_SERVER["REQUEST_URI"]; ?> <a href="<?php echo $PROD ?>"><?php echo $NAME ?></a> </td> </tr> <!--- END Header Tags SEO Social Bookmarks --> This solved the problem for me. I hope it helps... Regards, Owen.
  3. pinballfixer

    Header Tags SEO

    Hi Jack (and Bill), I've been playing around with the problem I mentioned a few pages back (the "Currently viewing:" code from Header tags SEO)... I've changed the following code to the "header_tags_social_bookmarks.php" file (the first 10 lines) before the actual social bookmarks images: <?php $NAME = $product_info['products_name']; $TITLE = urlencode($product_info['products_name']); $PROD = $_SERVER["REQUEST_URI"]; $URL = urlencode("http://" . $_SERVER["HTTP_HOST"] . $_SERVER["REQUEST_URI"]); ?> <tr> <td align="right"><table border="0"> <tr> <td style="font-family: Arial, Helvetica, sans-serif; font-size: smaller;">Add <a href="<?php echo $PROD ?>"><?php echo $NAME ?></a> to:</td>
  4. pinballfixer

    [Contribution] STS v4

    That's a fair point. I was focused on this particular thing, but you are right. I will still see if I can find a way around this (with my limited PHP knowledge). Thanks Bill.
  5. pinballfixer

    [Contribution] STS v4

    Very true Bill, and I have done as suggested. But this particular code does not get automatically pulled in, as it is for a text link inside the product page - it has nothing to do with the META tags. They work fine by the way - as I have followed the instructions. So, is there a better place to insert this code? If you did look at my page, then you would have also noticed the Social Bookmark logo's. These are also inserted into the product_info.php file from the HTSEO instructions - they work. Which now makes me think that I should do something similar for the Currently viewing text link... The code in question is supposed to pull the information from $header_tags_array['title'] to create a text link based on the product currently being viewed. Regards, Owen.
  6. pinballfixer

    [Contribution] STS v4

    Thanks for the reply Bill. Jack has confirmed that on his test install of osCommerce with STS and HTSEO that this part does not work. I have currently commented out the code for it, but I am happy to un-comment it so you can see it. The code is added to the stock product_info.php file (around line 260 in mine - although this will be different if you view the source). Look for: <?php /*** Begin Header Tags SEO ***/ ?> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td class="smallText" align="center"><?php echo TEXT_VIEWING; ?> <?php echo '<a title="' . $header_tags_array['title'] . '" href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL') . '"/# ' . $header_tags_array['title'] . '">' . $header_tags_array['title']; ?></a></td> </tr> <?php /*** End Header Tags SEO ***/ ?> The "$header_tags_array['title']" is the part that is not working. if you go to http://parts.pinball-fixers.com/product_in...?products_id=29 you will see the "Currently Viewing:" text at the bottom. Thanks for taking the time to help on this Bill. Regards, Owen.
  7. pinballfixer

    [Contribution] STS v4

    Thanks for your help Bill, I'm not using Product Info templates, but I did try with it on which made no difference. I had look through the code changes for the old HTC version, and the code for "Currently Viewing:" is there also (exactly the same). So I am wondering if the HTC version does or doesn't work with STS? This seems to be the only problem between the two for me - everything else is working fine. Regards, Owen.
  8. pinballfixer

    [Contribution] STS v4

    Another thing I have noticed is that because the "Currently Viewing:" code from Header Tags SEO doesn't work properly with STS, it also screws up the page view in Internet Explorer, but not in FireFox.
  9. pinballfixer

    Header Tags SEO

    Further to this problem... While the "currently viewing:" code doesn't doesn't seem to work with STS (4.5.8), it also screws up the page view in Internet Explorer when using STS. I have disabled it for now, until a fix is available... Regards, Owen.
  10. pinballfixer

    [Contribution] STS v4

    Hi everyone, I have a problem with STS 4.5.8 and Header Tags SEO v3 (the new version of the old Header Tags Controller). On the products info page, there is some text at the bottom that Header Tags SEO puts in which says "Currently Viewing:" Unfortunately it does not have the link after it that it should have. I have already contacted Jack (creator of Header Tags SEO) and he says that the problem is probably between STS and Header Tags SEO somewhere, but was unable to help at this stage. I have followed the instructions in both packages, and the writeup from bkellum on the older HTC version with STS, but to no avail. Has anyone else had this problem? And does anybody know how to solve this? Thanks in advance, Owen.
  11. pinballfixer

    Header Tags SEO

    Thanks Jack, at least I now know it was not from something I had done or done wrong. I will post at the STS forum and see if they know how to solve it, and if there is an answer I will post back here. Regards, Owen.
  12. pinballfixer

    Header Tags SEO

    Thanks for the reply Jack. The web browser title is correct. And everything else does seem to be working as it should. One thing I should point out (I didn't think this was related until I read your answer) is that I am using STS 4.5.8. I did follow the instructions for the STS users that you provided. I will spend some time looking though their forum in case there is an answer there. Thanks again for you help and fast response!!
  13. pinballfixer

    Header Tags SEO

    Hi Jack, I really like this contrib of yours! One question... When viewing the products_info page, I have the text "Currently Viewing" at the bottom, but no text after it. I have checked and re-checked the source mods, and they are correct according to your install instructions. If I view the HTML source for the page, i see this: <td class="smallText" align="center">Currently viewing: <a title="" href="http://mysite.com/product_info.php?products_id=28/# "></a></td> As you can see, the title tag is empty, along with the link. I am wondering if this is to do with the database install, as it did have an error. If it is to do with the database, is there a way I can check if everything is there properly? Regards, Owen.
  14. pinballfixer

    Paymate Support Thread

    There is a problem in the current paymate release (29 Oct 2007)... Open the file: catalog/includes/modules/payment/paymatespi.php and find: // $this->form_action_url = 'https://www.paymate.com.au/PayMate/ExpressPayment'; // uncomment for New Zealand websites: 'https://www.paymate.com.au/PayMate/GenExpressPayment'; $this->form_action_url = 'http://localhost:8080/npaymate/expressPaymentAU.jsf'; replace with (for the Australian paymate): $this->form_action_url = 'https://www.paymate.com.au/PayMate/ExpressPayment'; // uncomment for New Zealand websites: 'https://www.paymate.com.au/PayMate/GenExpressPayment'; // $this->form_action_url = 'http://localhost:8080/npaymate/expressPaymentAU.jsf'; Or edit the above for New Zealand...
  15. pinballfixer

    Fancier Invoice & Packingslip v1.0

    Is it possible to have the "Invoice" heading text changed to "Tax Invoice" for customers from a specific country? ie: Australian customers see "Tax Invoice" while everyone else sees "Invoice"
×