Jump to content

Tomcat

Members
  • Content count

    185
  • Joined

  • Last visited

Everything posted by Tomcat

  1. Tomcat

    EasyMap

    Hi Jack, I've installed the new version and it works just fine (see here). Wouldn't it be nice and handy to add the map controls like zoom, overview or labels?
  2. Hi all, I did install the contribution successfully on my very old and modded (loaded) store. Just some minor tweaking was needed. Can anybody test with an iphone browser? I never managed to get one :D website is here
  3. Tomcat

    photo gallery for oscommerce

    Hi all, Would it be possible to process images during upload? I guess there will be many problems with users trying to upload huge photos either in size or dimensions. There is an interesting class called class.upload that just does all the image processing, resizing, watermarking, etc. Does anybody know how to make it work together with photo gallery? Thank you
  4. Tomcat

    photo gallery for oscommerce

    for those of you having the login redirect problem try to change the form constructor for uploading images located in gallery_user.php from: <form enctype="multipart/form-data" action="gallery_user.php" method="POST"> to: <?php echo tep_draw_form('fotouploaden', 'gallery_user.php?osCsid=' . $osCsid ,'post', 'enctype="multipart/form-data"');?>
  5. Try adding rel="lightbox" to the tep_href_link of the extra image
  6. Hi, Very nice contrib. I installed it in local and works fine so far. Only thing , since I run a multilanguage site I would like to change the close image "images/closelabel.gif" accordingly to the website language. That could be done changing the URL path, but I'm not sure how to insert some php code to retrive the language_id on a .js file. Any ideas ? Thanks
  7. Tomcat

    NEW! Complete Order Editing Tool!

    Hi, I have the same problem. I can't see any articles next to or under the imput field. I also have errors on the JS, I think it's because I removed the Function : tep_html_quotes // Arguments : string any string // Return : string with single quotes converted to html equivalent // Description : Function to change quotes to HTML equivalents for form inputs. function tep_html_quotes($string) { return str_replace("'", "'", $string); } If I put it back it gives me an error... Thanks
  8. Ed, I'm not under SSL on my admin
  9. Leapfrog got stuck with FF as well :-( after about 5 mins
  10. I also noticed that registered users are not recognized , at least not me browsing in another window
  11. Hi, yes, the code is LDF004. I'm currently using IE, I'll have a try with FF as well. The error happens quite often
  12. Hi, why I keep getting disconnected from the DB ? this is the msg I get: Unable to connect to the Leapfrog data feed. Please read the following suggestions: 1. Do you have an admin login contribution installed? If so you must edit it to allow Leapfrog to access '/admin/leapfrog_feed.php'. 2. Are you using IE and SSL? There is a known issue with this setup. Please see INSTALL.txt for details. Alternatively switch to Firefox. 3. Visit the support thread on the official osCommerce forum. There might be an answer there.
  13. I don't think it's a good idea since in many cases (like mine) robots do thousands of hits per hour... Why not using the session_id instead ? seems to work fine Franco
  14. I also noticed that leapfrog disconnects from DB quite often, saying that "...can't connect to DB". does anybody has the same problem ?
  15. Hi, well, for some reasons I can't access my logs right now, so I can't really check the user agent. I had a look at my spider.txt and found that either googlebot and slurp where already there. Do you think the names must be written the same way ? I mean capital letter like "Googlebot" or is googlebot the same thing ? Since spiders were recorded despite I excluded them from settings I had to change functions/leapfrog.php to only write into DB the hits with a session ID assigned. The exclusion via settings wasn't working for me... Thanks
  16. Hi Ed, Just installe version 1.3 All fine except for the fact that I have google and inktomi recorded by leapfrog even though I've excluded robots in settings (IP 74.6.74.205 for ink and 66.249.65.46 for google ) any ideas why ? Thanks Franco
  17. What about making the IP clickable with link to dnsstuff whois ? You know ? I have a problem with sessions: Even though I downloaded and installed the latest spiders.txt I have many robots getting the session_id. I have this on my catalog/functions/leapfrog.php if ($wo_session_id != 0 ) { $insert_query = "insert into leapfrog" . " (customer_id, customer_name, session_id, ip_address, click_time, page_url, page_title, referer_url, thumb_url)" . ' values ("' . $wo_customer_id . '", "' . $wo_full_name . '", "' . $wo_session_id . '", "' . $wo_ip_address . '", "' . $current_time . '", "' . $wo_last_page_url . '", "' . $page_desc . '", "' . $referer_url . '", "' . $page_thumb . '")'; tep_db_query($insert_query); } and this on my application_top.php: // start the session $session_started = false; if (SESSION_FORCE_COOKIE_USE == 'True') { tep_setcookie('cookie_test', 'please_accept_for_session', time()+60*60*24*30, $cookie_path, $cookie_domain); if (isset($HTTP_COOKIE_VARS['cookie_test'])) { tep_session_start(); // user_tracking modifications if (!$referer_url) { $referer_url = $HTTP_SERVER_VARS['HTTP_REFERER']; if ($referer_url) { tep_session_register('referer_url'); } } $session_started = true; } } elseif (SESSION_BLOCK_SPIDERS == 'True') { $user_agent = strtolower(getenv('HTTP_USER_AGENT')); $spider_flag = false; if (tep_not_null($user_agent)) { $spiders = file(DIR_WS_INCLUDES . 'spiders.txt'); for ($i=0, $n=sizeof($spiders); $i<$n; $i++) { if (tep_not_null($spiders[$i])) { if (is_integer(strpos($user_agent, trim($spiders[$i])))) { $spider_flag = true; break; } } } } if ($spider_flag == false) { tep_session_start(); $session_started = true; } } else { tep_session_start(); $session_started = true; } what can it be ?
  18. possibility of interacting with the guest ? I mean by java chat or something ? Sometimes I see scammers I don't want to be on the website and I feel like saying:<<..don't even think of using your flipping cards on my website, you're just waisting your (and my) time..>> :lol:
  19. Hi, Are you sure the if statemets makes sense ? if ( (LEAPFROG_EXCLUDE_ROBOTS == 'true' && $wo_session_id != '') || LEAPFROG_EXCLUDE_ROBOTS == 'false') { Meaning: if LEAPFROG_EXCLUDE_ROBOTS is true and session is not empty or LEAPFROG_EXCLUDE_ROBOTS is false... Thanks
  20. Hi, I removed the if statement on line 112 and now works like a charm. Thanks
  21. delete the existing leapfrog table and run the new sql statement included in package 1.2 I upgraded to version 1.2.3 as well and have a different issue: records are not written to DB, not even one and if I run admin/leapfrog.php with Firefox ( 1.5 or 2) the browser crashes... Any help on that ? Thanks
  22. Ed, Nice work, very nice indeed. Can you make the referal field a bit wider (or in two lines) so that one can read all the referal url? Thanks
  23. The change to the url parser made above by abra123cadabra wasn't working for me. I'm using this one instead: // Get the product image if on product item page $pattern = "/p-[0-9]+/"; preg_match($pattern, $row['page_url'], $matches); $productPage = $matches[0]; $productId = substr($productPage, strpos($productPage, "p-")+2); $productId = str_replace (".html", '', $productId); if ($productId == "") { $thumbUrl = ""; } else { $itemQuery = "select products_image from products where products_id=" . $productId; $itemResult = mysql_query($itemQuery); $item = mysql_fetch_object($itemResult); $thumbUrl = DIR_WS_CATALOG . DIR_WS_IMAGES . "/" . $item->products_image; }
  24. I also made the script discard all the hits without a session_id ( robots, mainly ) changing this bit of code: // Insert all the information we have gathered into the database $current_time = time(); if ($skip_tracking[$wo_ip_address] != 1) { $insert_query = "insert into leapfrog" . " (customer_id, customer_name, session_id, ip_address, click_time, page_url, page_title, referer_url)" . ' values ("' . $wo_customer_id . '", "' . $wo_full_name . '", "' . $wo_session_id . '", "' . $wo_ip_address . '", "' . $current_time . '", "' . $wo_last_page_url . '", "' . $page_desc . '", "' . $referer_url . '")'; tep_db_query($insert_query); } } to this : // Insert all the information we have gathered into the database $current_time = time(); [b] if ($wo_session_id > 0 ) {[/b] if ($skip_tracking[$wo_ip_address] != 1) { $insert_query = "insert into leapfrog" . " (customer_id, customer_name, session_id, ip_address, click_time, page_url, page_title, referer_url)" . ' values ("' . $wo_customer_id . '", "' . $wo_full_name . '", "' . $wo_session_id . '", "' . $wo_ip_address . '", "' . $current_time . '", "' . $wo_last_page_url . '", "' . $page_desc . '", "' . $referer_url . '")'; tep_db_query($insert_query); } [b] }[/b] }
  25. Hi, I love this contrib. Could someone add the country of provenience based on the IP ? something like: require(DIR_WS_INCLUDES . 'geoip.inc'); $gi = geoip_open(DIR_WS_INCLUDES . 'GeoIP.dat',GEOIP_STANDARD); and then: <td class="dataTableContent" valign="top"><?php if (geoip_country_code_by_addr($gi, $whos_online['ip_address'])) { echo tep_image(DIR_WS_FLAGS . strtolower(geoip_country_code_by_addr($gi, $whos_online['ip_address'])) . '.gif', geoip_country_name_by_addr($gi, $whos_online['ip_address'])) . ' ' . geoip_country_name_by_addr($gi, $whos_online['ip_address']); } else { echo TEXT_UNKNOWN_COUNTRY ; } ?></td> thanks again
×