Jump to content

pbrunnen

Members
  • Content count

    3
  • Joined

  • Last visited

1 Follower

Profile Information

  1. pbrunnen

    SIM service throws osc login screen

    Hi all, I seem to be making headway here... I have setup the following and it appears to work. :-) I hope this helps someone down the road... ----- In the Admin under Configuration ----- Session Settings Force Cookie Use = False Check SSL Session ID = True Check User Agent = False Check IP Address = False Prevent Spider Sessions = True Recreate Session = False Authorizenet_sim Settings Transaction Mode = Production ----- For testing, I suggest that you create a separate php file and include this: print "<br><br><hr><br>Post Values:<br>\n"; print_r($_POST); and direct authorize.net to relay to that page any you can see everything that auth.net is returning. ----- Additionally, It seems that even with authorize account in test mode, I need to set the Transaction Mode setting to production or I get flakey results. Also I modified the payment modules thusly: @ tep_draw_hidden_field('x_method', ((MODULE_PAYMENT_AUTHORIZENET_SIM_METHOD == 'Credit Card') ? 'CC' : 'ECHECK')) . -- tep_draw_hidden_field('x_receipt_link_method','POST') . ++ //tep_draw_hidden_field('x_receipt_link_method','POST') . -- tep_draw_hidden_field('x_receipt_link_text','Complete your Order') . ++ //tep_draw_hidden_field('x_receipt_link_text','Complete your Order') . -- tep_draw_hidden_field('x_receipt_link_url', tep_href_link(FILENAME_CHECKOUT_PROCESS)) . ++ //tep_draw_hidden_field('x_receipt_link_url', tep_href_link(FILENAME_CHECKOUT_PROCESS)) . @ //PAYMENT FORM DETAILS -- tep_draw_hidden_field('x_relay_url', tep_href_link(FILENAME_CHECKOUT_PROCESS)) . ++ tep_draw_hidden_field('x_relay_url', tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL', true)) . tep_draw_hidden_field('x_relay_response','TRUE') . Thanks. -Cheers, Peter.
  2. Hi everyone... I am ripping out hair here with the SIM module for authorize.net I have the handoff going from OSC to SIM working fine, but the relay response comes back to the login screen. Any ideas where I can look??
×