Jump to content

mendoh

Members
  • Content count

    94
  • Joined

  • Last visited

Everything posted by mendoh

  1. mendoh

    SMTP with authentication on Phoenix 1.0.5.0

    Matt, thanks a lot. After following your advice, I checked the error logs on the server and realized I had left the following file behind: Save this email.php file in a directory named includes/system/override (which you will probably have to create) and see if it starts working. in the attempt to deal with the following issue (which still remains unsolved): Posted 2 hours ago Hello Stewart. I have exactly the same needs as yours that basically depend on this isssue here: Could you point me out on how you solved the problem? Thank you in advance. How can any customer registering on the shop with a hotmail or gmail address get an email confirmation for their order if non-SMTP authenticated emails get blocked before being delivered to hotmail/gmail addresses?
  2. mendoh

    SMTP with authentication on Phoenix 1.0.5.0

    I have come to the final stage of checking everything on my Phoenix 1.0.7.7 store before opening it to the public and a 500 error is displayed immediately after clicking on the "finalize and pay for my order" button at check-out confirmation. I have updated from a 1.0.7.6 version where orders could be confirmed correctly. I even tried a second upload of all the 1.0.7.7 files, however, the 500 error on check-out is still there. Any idea on where the culprit may be?
  3. mendoh

    SMTP Authentication and OSCommerce

    Hello Peter, is this valid for the latest Phoenix? Also, the link to PHPMailer download returns a 404 error...
  4. mendoh

    SMTP with authentication on Phoenix 1.0.5.0

    Hello Stewart. I have exactly the same needs as yours that basically depend on this isssue here: Could you point me out on how you solved the problem? Thank you in advance.
  5. mendoh

    Header Tags SEO

    Thanks Jack, roots of the issue found at last. I will keep waiting for the release of your updated version, then.
  6. mendoh

    Header Tags SEO

    I think I am narrowing it down to the roots of the issue. While the above issue disappeared (probably a matter of browser cache flushing/page refresh after installing the HTS contribution) and accessing admin side does not give me a 500 error any more, a 500 error is however displayed after clicking on categories/products in admin. Since the issue appears to lay within the categories.php file, I followed your troubleshooting guide and test-compared my modified categories.php with the one included with your contribution files and found out that the main differences are related to the file itself, not the contribution modifications. As long as I could understand, everything is related to this string: const DIR_FS_CATALOG_IMAGES = DIR_FS_CATALOG . 'images/'; (which is NOT present in your version of categories.php) along with quite a few other following strings in the file that all relate to the same images/ directory, e.g.: tep_image(HTTP_CATALOG_SERVER . DIR_WS_CATALOG_IMAGES (your version of categories.php) VS tep_image(HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/' (updated 1.0.7.7 version of categories.php) Then, if I replace my 1.0.7.7-updated and modded categories.php file with the categories.php file included with your contribution, I get no more 500 error when clicking on categories/products in admin, however, the following error is displayed: Error: Catalog images directory does not exist: %s I suppose both your provided admin/categories.php file and its related modifications as included in your latest contribution version are just incompatible with 1.0.7.7?
  7. mendoh

    Header Tags SEO

    Jack, I have tried a new contribution install from scratch and the 500 error is gone. Everything would appear to work as it should, except for a strange behaviour as follows: if I click on any product page, the HTS line below the product correctly shows "Currently viewing: product name" and the "Popular searches" tag box in the footer shows up nicely, whereas if I do the same on index.php or any other product category page, I get " HTS_TEXT_VIEWING: category name " or "HTS_TEXT_VIEWING: index page title " and the "Popular searches" tag box in the footer also shows "BOX_HEADING_HEADERTAGS_TAGCLOUD" instead of "Popular searches". Pressing the "test" button on admin side returns the following: Results of scan: index.php is missing Header Tags code or it is not installed correctly. Verify that Fill Tags has been ran and that the root checkbox or the default checkboxes have been checked in Page Control. then, if I do exactly as suggested, I get the following error in Page Control: Missing sort orders are not allowed -> index.php Can you tell me where did I go wrong? "HTS_TEXT_VIEWING
  8. mendoh

    Header Tags SEO

    Thanks Jack. What really puzzles me is that I have started getting 500 error after upgrading to 1.0.7.7....nonetheless, I will take your advice and start investigating the cause of the issue...
  9. mendoh

    Header Tags SEO

    Hello Jack, could you please confirm whether your contribution works on Phoenix 1.0.7.7? I installed it on 1.0.7.6 where it was working ok, however, after upgrading to 1.0.7.7 I had to uninstall it because I get a 500 error on admin side. Triple-checked my modified admin/categories.php file for errors: no errors on file and the 500 error still there on admin side...
  10. mendoh

    XML Sitemap Generator

    Header Tags Seo + Ultimate Seo Urls
  11. mendoh

    XML Sitemap Generator

    I have noticed that a sitemap for the language in which the site is being browsed is generated and that language is extended to all the remaining sitemaps for all the other available languages, that is, although you actually get as many different sitemap files as the available languages, all of those files only show the one site language which was on at the time the sitemap.php file was run...
  12. mendoh

    XML Sitemap Generator

    😮 After replacing the file section as suggested, the add-on does not work any more and I am getting a 404 error when running the sitemap.php file, even if the file is actually present...
  13. mendoh

    XML Sitemap Generator

    Hello Ruden, thanks. The multi-language website where I am trying to use your add-on is this: netgun.store/webshop
  14. mendoh

    XML Sitemap Generator

    First of all, thanks for your writing this nice add-on. I installed it and tested it and it apparently works fine on my multi-language website (4 active languages): I could verify that it actually generates all the different .xml files for the various languages that are active on my website. Checking the actual .xml files in a different language than English, however, gives me bad news: I could realize that the file listed as a Spanish product sitemap actually contains a product sitemap in French. French product sitemap is in French, however, the same happens with all the remaining sitemap files for all the other available languages: they are all in French, despite the default language is set to English. In layman's terms, it seems to randomly take one among the available languages and that language stays the same for all product sitemaps regardless of the language. Would you know how to fix the above issue?
  15. mendoh

    ULTIMATE Seo Urls 5 - by FWR Media

    Thanks for your clarifications. I can only confirm that installing Ultimate_Seo_Urls_5_PRO_BS_209_beta_2.zip on Phoenix 1.0.7.4 or 1.0.7.5/6 will definitely NOT work.
  16. mendoh

    ULTIMATE Seo Urls 5 - by FWR Media

    To whom this may concern: the latest Ultimate Seo Urls 5 PRO for Phoenix 1.0.7.4 or 1.0.7.5 can be found here: Do not install Ultimate_Seo_Urls_5_PRO_BS_209_beta_2.zip on Phoenix 1.0.7.4 or 1.0.7.5 as it just will NOT work.
  17. mendoh

    ULTIMATE Seo Urls 5 - by FWR Media

    Hello everybody. Does anyone have any idea on how to install the latest Ultimate_Seo_Urls_5_PRO_BS_209_beta_2.zip on Phoenix 1.0.7.4 or 1.0.7.5? I have tried but the installation instructions appear to be fairly clumsy, to say the least: code in the "compare_files" is completely different than the most recent one and uploading only those files inside the "drop_on_top" folder does not actually do....
  18. mendoh

    Information Pages SEO addon

    Thanks Artcolnc! Unfortunately, the one above is only half of the problem: 😥
  19. mendoh

    Information Pages SEO addon

    Thanks a lot Jack! I will do exactly as you suggested and wait for a new release to come out...
  20. mendoh

    Information Pages SEO addon

    Hello Jack, Mendoh here. I have tried to install your contribution on the very latest Phoenix 1.0.7.5 and despite I have triple-checked everything, I could not get it to work. Admin seems to work, however: 1) no line title or name is displayed for each new page on the admin list of added pages 2) trying to install the "information pages block" footer content module gets me the following error: 1146 - Table 'mystoredb_2.TABLE_CONFIGURATION' doesn't exist insert into TABLE_CONFIGURATION (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Enable Information Pages Links Footer Module', 'MODULE_CONTENT_FOOTER_INFORMATION_PAGES_STATUS', 'True', 'Do you want to enable the Information Pages Links content module?', '6', '1', 'tep_cfg_select_option(array(\'True\', \'False\'), ', now()) [TEP STOP] On top of the above, after adding a new page on admin, its name/title (the very same that does not show on admin list of new pages) actually shows as a link in the "Helpful Links" information box on the store side, however, clicking on either such link or the "view" icon for the same page on the admin side, delivers another error: This page isn’t working Yourwebsite is currently unable to handle this request. HTTP ERROR 500 Can you point me out on what is wrong with my install or is it just the contribution to be incompatible with Phoenix 1.0.7.5? Thank you
  21. mendoh

    View Counter

    Dear Jack, based on your suggestions, I started investigating the contribution deeply and it did not take me too long to realize my colleague actually installed an old version of your contribution (v1.4) instead of the most recent one. Therefore, I downloaded the most recent release, installed it and now everything works as fast as lightning even when "show flags" and "external checks" are on. There is, however, a code error which I have found inside the "view_counter_tools.php" file under admin: this error prevents you from successfully creating an .htaccess backup file. As a matter of fact, running the related function under admin/tools/maintenance tools gives you a 404 error. That happens because there are four wrong instances of the file name FILENAME_VIEW_COUNTER_TOOLS (which is correct), while the (wrong) file name in the file shows up as "view_counter-tools.php": it is sufficient to replace the four wrong instances with the correct file name and everything works as it should. Thanks for your valuable help!
  22. mendoh

    View Counter

    The bad link was actually inside the view_counter_country_block.php file. Removing the link caused the error to vanish on the catalog side and page loading speed is back to normal. On the admin side, however, the page stucks whenever I click on view counter/monitor: not only I am totally unable to access the monitor data but also I am now getting another type of error which is this: Unable to connect to database server! I am going crazy...
  23. mendoh

    View Counter

    504 gateway timeout error also shows up on the admin side
  24. mendoh

    View Counter

    Thanks. I actually downloaded and renamed the DB (i.e.: .BIN file inside the zip) as suggested in your install file, then uploaded the DB file to admin/includes directory: it is almost 600Mb in size. After adding the line you mentioned to the includes/application_top.php file, the following error shoots up: Warning: file_get_contents(http://api.hostip.info/?ip=xx.xxx.xx.xxx): failed to open stream: HTTP request failed! HTTP/1.1 522 Origin Connection Time-out in /xxx/yyy/zzz/kkk/jjj/website/includes/modules/view_counter_country_block.php on line 79
  25. mendoh

    View Counter

    Jack, many thanks for your fast reply! The site in question has recently gone online and is well below 9000 visits in the last 24 hours. I also tried to adjust some of the settings by turning off the flags and country blocking is not even enabled: no way, it stays slower than a turtle...monitor page in admin does not even load and on the catalog side the page loads completely white. Under these conditions, other than turning it off, I would not really know what to do with it...
×