Jump to content

innometrix

Members
  • Content count

    14
  • Joined

  • Last visited

Profile Information

  • Real Name
    Bill Wignall
  1. I haven't looked at the problem of attributes disappearing yet and I am unaware of the textbox error. Do either affect what I need? Ideally I'd much rather have the checkout procedure for this one type of product that added in a whole new page with just a load of text boxes that got added to the order in much the same way that the order comments box works - I'd have to limit the product purchase to one per order but then again it's the sort of thing that people only want one of anyhow, indeed I think all other shops I have seen only allow you to purchase one at a time anyhow.
  2. Hi - contrib is just what I need but I have a problem in that I need a very large text input box and so I need to specify the height and width of the box as it will not be standard. I was wondering whether it would be possible to add three fields into the database to hold these parameters, but my PHP isn't good enough to understand how to add in the coding into the files. In the interim I'd be happy just to have ALL the boxes oversized so they pick up a default hard-coded width and height. I tried to add a new section in the html_output.php file to create a new type of input box just for this (tep_input_attrfield or something) which basically took the coding for the normal text box and added some parameters but this was far too complex for me! Anyone able to help at all? Thanks in advance. Obviously with the size of this input I also need to solve how to get them to display correctly on other screens.
  3. innometrix

    [Contribution] STS v4

    Hi Bill Thanks, although later last night I realised that because my store uses the main site's CSS as well as it's own (temporary transfer situation) that theere was a clash of styles and that was causing the appearance! Apologies for wasting your time :blush:
  4. innometrix

    [Contribution] STS v4

    Hi Bill. Thanks for the comments, however they do not help much :( For one thing - I can't put in an image source, because the PHP code involved is <td align="right" width="100%"><?php echo tep_image_submit('button_login.gif', IMAGE_BUTTON_LOGIN) ?></td> I can merge in your idea of putting in the width and height things (sorry don't know the technical term) and thus making the PHP..... <td align="right" width="100%"><?php echo tep_image_submit('button_login.gif', IMAGE_BUTTON_LOGIN, 'width="96px" height="24px" class="buttonstyle"') ?></td> this translates into an output code of <td align="right" width="100%"><input type="image" src="includes/languages/english/images/buttons/button_login.gif" border="0" alt="Sign In" title=" Sign In " width="96px" height="24px" class="buttonstyle"></td> I still have the border, and although the width and border have been factored in, the height has been ignored. It obviously still takes into account the fact that the code is within a form, and the form's default inputs have a height of something other than what I'm trying to achieve? Sorry if this isn't clear :( Cheers Bill
  5. innometrix

    [Contribution] STS v4

    I have a problem with buttons that act as a form input. They all appear on screen as if they are actually part of a form, instead of simply being a button that has a form action attached to it. Therefore if I have a button which is just a link, it appears fine on screen. If I have a button (such as the Add to Cart one on http://www.innometrix.net/store/product_info.php) then it has a border round it and is resized as if it were an actual input field. This makes the button look terrible and I can't understand where the sotre is picking up the format from because if I turn STS off then the button returns to normal - yet the source code behind the button whether STS is on or off is absolutely identical! Any help gratefully received. I have given up all hope, yet STS has got my site almost perfect in every other way :(
  6. Apologies just ignore this - seemingly there is an issue where Microsoft's web design software was putting some strange characters at the start of my php files which was causing the shop to fail.
  7. I have a pretty standard install of OSC, with STS installed over the top. I have no problems with my template, I only use one template for the whole store. My problem is that when I try to alter the layouts in the body of the original files that STS pulls the #content from, I always, without exception, get this.... Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/innoxkbx/public_html/store/shopping_cart.php:1) in /home/innoxkbx/public_html/store/includes/functions/sessions.php on line 102 It doesn't matter what I try to do - even putting width="33%" against one cell of a table causes the error to appear. What on earth can be so unstable in my install that even the most slight of changes to the original file, even when not tampering with any coding, causes the whole install to fail?
  8. innometrix

    Paypal IPN SQL error

    Interesting - that narrows it down to STS, as that's the only other alteration made. ps that was my first post under this account, although it's my 3rd full OSC install, so I'm not an utter newbie.
  9. innometrix

    Paypal IPN SQL error

    I'm getting an error log on my server which has the following.... [20-Feb-2008 23:25:44] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0 [20-Feb-2008 23:25:44] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0 [20-Feb-2008 23:35:21] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0 [20-Feb-2008 23:35:21] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0 [20-Feb-2008 23:48:29] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0 [20-Feb-2008 23:48:29] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0 [20-Feb-2008 23:48:48] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0 [20-Feb-2008 23:48:48] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0 [22-Feb-2008 22:54:21] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0 [22-Feb-2008 22:54:21] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0 [24-Feb-2008 16:53:11] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0 [24-Feb-2008 16:53:11] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0 [24-Feb-2008 17:13:03] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0 [24-Feb-2008 17:13:03] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0 I only have STS installed over the default installation, the paypal ipn module was the first after that. When I use sandbox, the details get sent to paypal OK, the payment gets added to my sandbox seller's account, and the sandbox email is received. However in OSC the email never arrives and the status never changes from Processing. Additionally I get an email, presumably from the debug option which has as the body just this... $_POST: $_GET: Any ideas?
×