Jump to content

Pelvis

Members
  • Content count

    60
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Nikolaos
  • Gender
    Male

Recent Profile Visitors

6,488 profile views
  1. Jesus Burt!!!!!! Thank You!!!!!
  2. Hello Everybody ...short question: My Inline code looks as follow: $cashondelivery_cost = "0.50"; ------- I want to convert this to dynamic, I mean I want to get the value "0.50" from the Db. The value "0.50" is stored on table "configuration" row called "configuration_value" of the key "CASHONDELIVERY" Code shown like this but I can not get anything: $cashondelivery_cost = tep_db_query("SELECT configuration_value from configuration where configuration_key='CASHONDELIVERY' "); Any Help :-) Thanks!
  3. Thanks a lot! will try this
  4. I use OSCommerce v2.2 and what I want is when the user visits a page that redirects him to login after a successful login to be redirected to the page that initially visited. For example, the user receives an email that prompts him to visit the page review.php he clicks the page and gets redirect to login.php. After the login I want him to be redirected to review.php OSCommerce seems to have this functionality at login.php if (sizeof($navigation->snapshot) > 0) { $origin_href = tep_href_link($navigation->snapshot['page'], tep_array_to_string($navigation->snapshot['get'], array(tep_session_name())), $navigation->snapshot['mode']); $navigation->clear_snapshot(); tep_redirect($origin_href); } else { tep_redirect(tep_href_link(FILENAME_DEFAULT)); } And at the review.php file, the snapshot is set when the user is not logged in. $navigation->set_snapshot(); tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL')); but then in application_top.php the following code seems to destroy the navigation snapshot // navigation history if (tep_session_is_registered('navigation')) { if (PHP_VERSION < 4) { $broken_navigation = $navigation; $navigation = new navigationHistory; $navigation->unserialize($broken_navigation); } } else { tep_session_register('navigation'); $navigation = new navigationHistory; } $navigation->add_current_page(); So before I fix this with my own session variables I would like to use the implemented functionality. Has anyone experienced the same problem and came up with a solution to the default functionality? P.S The PHP version of the site is 7.2 Thanks for your time :-)
  5. Pelvis

    PHP Execute - Small Help

    Thanks for help! This has done the Job <?php if (isset($_GET['my_code'])) { $remove_null="DELETE FROM `supplier_product` WHERE (`model` IS NULL OR `model` = '')"; tep_db_query($remove_null); } ?> <form action="<?=MY_FILE_NAME ?>" method="get"> <input type="hidden" name="my_code" value="run"> <input type="submit" value="Remove Null Records"> </form>
  6. Pelvis

    PHP Execute - Small Help

    Hello! all OsCommerce friends, I am a newbie in coding try to make a php script that do follow simple task: DELEETE from Table "supplier_product" all the rows from column "model" that have NULL values or are EMPTY What I make wrong, here is my code <?php if(isset($_POST['submit'])){ $code = $_POST['niks_code1']; } ?> ------- <form name="niks_code1" action="<?php $delete_null="DELETE FROM `supplier_product` WHERE (`model` IS NULL OR `model` = '')"; ?>" method="POST"> <button type="submit" name="niks_code1" style="display:normal; color:green; font-size:11px; font-weight:bold;">Remove Null Records</button> </form>
  7. 2 simple questions (of course i have searched and couldn find an answer). 1. If you have instaled b2b or the simplefied version of b2b and iosc-mobile, is B2B working in iosc mobile when somebody visit the site from a mobile phone I mean the prices did they apear as in the desktop version or must i install the b2b as a separet version for iosc-mobile again? Or a link where I can read something about that. 2. General question does this iosc-mobile contrib affect only to the design e.g. css or do you have to install all the contributions that the desktop shop have for to the iosc-mobile version again. Or a link where I can read about a small explantetion for how this contrib works.
  8. Thanks !!!! You must delete also in the Table "customers" the column "customers_guest" THank you for the fastest Help Reiner!!
  9. Help Reiner (Brauche Bitte deine hilfe) I meesed PWA up ...did something wrong (i haveOSC in 2 folders the second is a Backup but with the same DataBase) I have upgrade the files from 2.2r2 to 2.3 in one folder and did the same in the other folder and then uninstal and instal and i forgat to refresh in the other folder and click to uninstall again (in the Database it was uninstalled) Now when I go in admin to modules->login->Install->Login without Account Form 1060 - Duplicate column name 'customers_guest' alter table address_book add column `customers_guest` INT(1) NOT NULL DEFAULT '0' AFTER `customers_id` ----- I checked the Database at the Table "address_book" there is only one Column with the name "customers_guest" but in the Table Customers exists another one column with the same name "customers_guest".
  10. @@dominic Did the standard Tetimonials from Burt have this Problem? do you know?
  11. I have try everything and can not fix. The question is why the html_text are displayed with no problems in admin (at the right side of the page) and not on the Frontpage Box. I saw the code but I can;t transfer it at th FrontPage. Thanks for trying.
  12. Hallo Dominic! I found a "bug" in this Contib which I trying to fix for more than 5 Days but it is impossible I can't! (I am not a programmer) I use OSC about 11 Years and I learned a lot of things fixing this and that by my self. and with the help of the people of the OSC community. in my Language witch is Greek, I use utf8 encoding and everything is ok in the shop. The main Text in the Fontend displays a "utf8 Replacement character" it has something with the rendering of php or something like that. In the Database looks everything fine the characters are displayed o.k. but not in the Frondend. Put the follow text in a second Language in your database in the Table "testimonials_html_text" the character encoding of the text Tables must be set to "utf8_unicode_ci" and look in the Frontend how it is displayed. ================== testimonials_html_title: Καλά Παιδιά ================== testimonials_html_text: Άψογη εξυπηρέτηση, ασυναγώνιστη ποιότητα και πάνω από όλα καλές τιμές. ================== testimonials_name: Γιώργος Αντωνίου ==================== (See Attachement picture) https://dl.dropboxusercontent.com/u/17918482/testimonials_bug.jpg
  13. Pelvis

    [Addon} Modular Front Page

    Solved! Instruction for Others with the same Issue: In Catalog/includes/modules/content/front_page/templates/cm_fp_new_products.php Find This: <div class="row"> And Replace with this: <div class="row" style="display:-webkit-box; display:-webkit-flex; display:-ms-flexbox; display:flex; flex-wrap:wrap;"> -- In Catalog/includes/modules/content/front_page/templates/cm_fp_categories_images.php Find This: <div class="row"> And Replace with this: <div class="row" style="display:-webkit-box; display:-webkit-flex; display:-ms-flexbox; display:flex; flex-wrap:wrap;">
  14. Pelvis

    [Addon} Modular Front Page

    About the Categories Images Content Module. I had the OSC Edge before October with the Filenames. I have now upgrade it to the Latest with Depricated Filnames/Paths and have this Gap. I had the same Isue before and have fix that adding the folowing string in CATALOG/includes/modules/content/front_page/templates/cm_fp_categories_images.php ----- <div class="thumbnail equal-height-categories-images"> ----- and adding the folowing class in user.css .thumbnail .categories-images { height: 30px; padding: 1px; } ---- With the Latest Edge with Depricated Filnames/Paths i can't fix that. See atachment Photo https://dl.dropboxusercontent.com/u/17918482/osc_edge_gap.jpg
×