Jump to content

jblausey

Members
  • Content count

    77
  • Joined

  • Last visited

Posts posted by jblausey


  1. Has anyone found an answer to this problem? I've found the same thing too.

     

     

    DJMONKEY1 thoroughly answered this in the Order Editor Forum - look around page 97

     

    Disable the payment method dropdown.

     

    or

     

    // disable the module if the order only contains virtual products

    if ( ($this->enabled == true) && (is_object($cart)) ){

    global $cart;

    if ($cart->show_total() >= 0.01) {

    $this->enabled = false;

    }

    }

     

     

     

    or

     

     

     

    CODE

    // class methods

    function update_status() {

    global $order;

     

    // disable the module if the order only contains virtual products

    if ($this->enabled == true) {

    global $cart;

    if ($cart->show_total() >= 0.01) {

    $this->enabled = false;

    }

    }

    }

    to

    CODE

    // class methods

    function update_status() {

    global $order;

     

    // disable the module if the order only contains virtual products

    if ($this->enabled == true) {

    global $cart;

    if (is_object($cart)) {

    if ($cart->show_total() >= 0.01) {

    $this->enabled = false;

    }

    }

    }

    }


  2. I have also disabled GZIP Compression and inserted that line yet i have an unusual problem.

     

    When i click on "Buy Now" the rotating button comes and keeps rotating. If i reload the page then the item is added to the cart.

     

    Has anyone got this to work with STS v4.2 (Latest Version)

     

    Please help in this matter.

     

     

    I'm using STS 4.5 and I got it working by changing

    if (strstr($scriptbasename, "popup")|| strstr($scriptbasename, "info_shopping_cart"))

    in sts_default to

    if (strstr($scriptbasename, "popup")|| strstr($scriptbasename, "info_shopping_cart") || strstr($scriptbasename, "ajax"))  

     

    I enabled infoboxes and created infobox_shopping_cart.php.html and wrapped like so:

     

         <tr>
          <td style="padding: 0">
          <script language="JavaScript" src="includes/ajax_sc.js"></script>
            <div id="divShoppingCard"><table border="0" width="100%" cellspacing="0" cellpadding="2">$content</table></div>
          </td>
        </tr>

     

    Hope this helps Someone


  3. Thanks!- it works now. You saved me!

     

    Now If I could figure out a way to email it to customers who haven't ordered off the website but over the phone. Maybe someone will write a new version that does this.

     

     

    If I'm not mistaken, there is at least one contribution already available that allows you to manually create a customer and/or an order. If you're taking orders over the phone, this is extra work for you, but it allows you to send the survey.


  4. I was having trouble getting the "Click here to go to survey" in the email to actually work as a link. It was appearing, but as another poster kept repeating, nothing was linking. After a little thought, I realized that under my Configuration -> Email Options -> Use MIME HTML When Sending Emails was set to FALSE. Once I changed this to true, then everything worked fine.

     

    Took awhile to make this work with a tracking contribution too, but think I figured it out. Had been hoping someone would have time to write good Survey script. Thanks!!!!!


  5. The file contained only these headings on the columns -

     

    v_products_model - v_products_name_1 - EOREOR

    it was edited in excel , which i've used before with EP , and saved as tab de-limited.

     

    It took away all the product descriptions. The file contained about 269 products , i edited only about 60 of the product names, the rest were left as they were. I re-uploaded it with "Upload and Import EP File"

     

    Settings are -

     

    Temp Dir:

    /var/www/domain/temp/

     

    Split files on: 300 records

     

    Model Num Size: 25

     

    Price with tax: true

     

    Replace quotes: false

     

    Field seperator: tab

     

    Excel safe output: false

     

    Preserve tab/cr/lf: false

     

    Category depth: 3

     

    Enable attributes: true

     

    SEF Froogle URLS: false

    Thanks for your help

     

     

    I'm having the same problem and have similar settings, though I've tried making Excel safe 'true' and tried various field separators, used custom to build the file and then "Upload and Import EP File". On upload all the descriptions disappear. I've also got attributes set to false. $tempdir = DIR_FS_DOCUMENT_ROOT . "temp/"; Seen this problem brought up in an earlier post with no answer, figured I'd say how I was updating the file - maybe I'm still doing something wrong. Thanks

     

    only products updated were affected.


  6. I've seen several inquiries so I'm going to throw my hat in. We're using this great contribution (thank you everyone) and like others there will be times that the coupon code will make the price $0.00. I've tried to use a payment module for checking out when $0

    http://www.oscommerce.com/community/contri...y,1/search,free

    but I need to be able to read the new total as $0 - the new total is still the original price minus the coupon.


  7. Just as a double check - this is the sql statement that's to be used - correct?

     

    ALTER TABLE `products` ADD `products_make_an_offer` TINYINT(1) DEFAULT '0' NOT NULL;

     

    INSERT INTO `configuration_group` VALUES ('', 'Make An Offer', 'The options to configure the MAO button.', '1', '1');

    UPDATE `configuration_group` SET sort_order = last_insert_id() WHERE `configuration_group_id` = last_insert_id();

    INSERT INTO configuration VALUES ('', 'Accept offer directly', 'MAO_ACCEPT_OFFER_DIRECTLY', 'true', 'Add an accepted offer directly to the shopping cart', last_insert_id(), '1', NULL, now(), NULL, 'tep_cfg_select_option(array(\'true\', \'false\'),'),

    ('', 'Maximum allowed offer percentage', 'MAO_MAX_OFFER_PERCENTAGE_ALLOWED', '20', 'The maximum percentage of the official price you will accept an offer for (ie. if the set price is 100 all offers below 80 will not be accepted for the default of 20%.).', last_insert_id(), '2', NULL, now(), NULL, NULL);

     

     

    Let me apologize for letting this post - I had duplicated an existing site and had forgotten to change out the database info - what maroon. Sorry, but thanks for the reply.


  8. The error occurs when you do not have all needed SQL statements applied to your database and/or missed one of the neccessary changes. Best advise is to check everything carefully (again). I have never heard back from EIH so I guess he found the error himself in the end.

     

     

    Just as a double check - this is the sql statement that's to be used - correct?

     

    ALTER TABLE `products` ADD `products_make_an_offer` TINYINT(1) DEFAULT '0' NOT NULL;

     

    INSERT INTO `configuration_group` VALUES ('', 'Make An Offer', 'The options to configure the MAO button.', '1', '1');

    UPDATE `configuration_group` SET sort_order = last_insert_id() WHERE `configuration_group_id` = last_insert_id();

     

     

    INSERT INTO configuration VALUES ('', 'Accept offer directly', 'MAO_ACCEPT_OFFER_DIRECTLY', 'true', 'Add an accepted offer directly to the shopping cart', last_insert_id(), '1', NULL, now(), NULL, 'tep_cfg_select_option(array(\'true\', \'false\'),'),

    ('', 'Maximum allowed offer percentage', 'MAO_MAX_OFFER_PERCENTAGE_ALLOWED', '20', 'The maximum percentage of the official price you will accept an offer for (ie. if the set price is 100 all offers below 80 will not be accepted for the default of 20%.).', last_insert_id(), '2', NULL, now(), NULL, NULL);


  9. where do you have your sts_template.html file? the download had it all under the sts_ folder

     

    Downloaded and installed sts 3.0 yesterday - so far so good :thumbsup:

     

    From the list of new features I thought that my sts_template.html had to be inside the sts directory, but it works great outside the folder - loving the fact that it parses php code!


  10. What lines were being referred to??????? :blink:

     

    I later found out that I didn't work. I ended up unistalling the linkpoint contribution and found a more recent contribution at http://www.oscommerce.com/community/contri...earch,Linkpoint

     

    It had better instructions and I was able to determine that my client did not added the right plan to his merchant account.

     

    I don't remember anymore what the lines were but I didn't end up using it. If you downloaded the contribution I mentioned in the first paragraph and still need help finding the lines, then let me know or you can contact the author of the contribution directly. He offers free support on this contribution.


  11. I had the same error when I tried to install the contribution. Tried adding "comments" to the database and it then said it was missing "new_field" in the orders_history section... before I knew it I was adding fields left and right. Fortunately I read the instructions and did a backup... backup... backup.....

     

    If anyone knows how to install this script then please advise.

     

    Using STS and Linkpoint

×